Parte 1.- Daz Studio

Comentarios

Transcripción

Parte 1.- Daz Studio
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
¿Qué es DAZ Studio?
!
Piensa de DAZ Studio como un estudio virtual completo. Luces, cámaras, figuras y
decorados. Tu puedes crear escenas situando actores virtuales, decorados y otros
elementos en el estudio. Ajustar su luz, posicionar tus cámaras y tener un control total de
la imagen. La pestaña de superficie “Surfaces” te permite cambiar el color de cualquier
objeto, la opacidad, su rugosidad y cualquier otro atributo. Este extracto de manual está
sacado de su versión completa inglesa y traducido deliberadamente por Israel Luri Terrés,
además de modificaciones libres puede contener fallos en su traducción, por lo que es
recomendable su lectura en su versión original.
Características clave
- Soporte PC y MAC.
- Completamente optimizado: DAZ Studio soporta aceleración OpenGL en vistas 3D, lo
cual te da una alta calidad en tiempo real. Optimización inteligente de la memoria para
mejorar los recursos del sistema e incrementar el rendimiento.
- Múltiples vistas 3D.
- Interfaz de usuario totalmente personalizable.
- Soporte de múltiples monitores.
- Formatos nativos: Los formatos .daz, .dsb, y .ds permiten la protección del contenido del
autor.
- Importación de formatos populares: DAZ Studio puede importar Objetos de Wavefront
(*.obj) y todos los formatos de Poser 4 - escenas / scenes (.pz3), caracteres / character
(.cr2), decorados / props (.pp2), cámaras / cameras (.cm2), luces/lights (.lt2), manos/
hands (.hd2), pelo/hair (.hr2), expresiones faciales / face (.fc2), poses/pose (.pz2) y
todos sus correspondientes formatos comprimidos (.**Z).
- Motor de renderizado: DAZ Studio usas 3Delight de RederMan
- Selección directa: Selecciona cualquier objeto o material haciendo click directamente
dentro de una ventana de vista.
- Pestaña de escena (Scene Tab): Lista de todos los componentes de la escena.
- Pestaña de parámetros (Parameter Tab): Aquí puedes modificar cualquier parámetro de
las luces, cámaras, objetos, decorados, etc.
- Pestaña superficie (Surface Tab): Edita cualquier material de tu escena, incluyendo color,
altas luces, opacidad, reflexión y textura usando esta pestaña.
- Manipulación 3D: Mueve las figuras usando controles intuitivos sobre la pantalla.
Posiciona los limites de movimiento definiendo los rangos personalizados.
- Hacer / Deshacer múltiples.
Programa, recursos y tutoriales
!
El programa DAZ Studio se encuentra para su descarga en la página http://
www.daz3d.com dentro del apartado 3D Software. Este programa es gratuito y el proceso
a seguir una vez descargado es instalarlo en nuestro equipo. Una vez instalado cuando lo
ejecutemos nos pedirá una clave de registro, para ello nos mandará a la página web
donde debemos rellenar los datos que nos soliciten para registrarnos. Después del
registro se nos dará una clave que deberemos introducir en nuestro programa. Desde el
momento en que nos registramos en la página tenemos un apartado llamado “My
-1-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
account” donde podemos acceder siempre a nuestro número de serie así como a un
historial donde se refleja todo lo que hallamos comprado aquí.
!
Dentro de la página web también existe un apartado llamado “3D Models” donde
podemos acceder a toda las base de datos de recursos que existen para utilizar con el
programa DAZ Studio así como otros programas de la misma empresa. Simplemente
utilizando el campo búsqueda “Search” podemos visualizar contenidos referentes a lo que
estamos buscando. Por otro lado podemos acceder también a los recursos basándonos
en tipos distintos de temáticas como por ejemplo escenas “Scenes” donde nos podemos
encontrar con escenas de interior, exterior, entornos, etc.
!
Podemos acceder también a distintos tutoriales de este programa dentro de la
página http://arcana.daz3d.com! en la sección wiki.
!
Los recursos de descarga aunque son compatibles tanto los de PC como los de
Mac, el proceso de instalación es individual en las distintas plataformas. Es decir,
cualquier objeto que adquiramos lleva su propio ejecutable con lo cual debemos
descargarlo para nuestra plataforma. Aun así una vez instalado si cogemos los archivos
instalados en una plataforma y los copiamos directamente en la otra funcionarán sin
ningún tipo de problema.
Comenzando...
!
Vamos a ver primero el proceso mas o menos genérico de trabajo. Para ello
necesitamos por lo menos tener algunos objetos para poder iniciarnos en este programa.
Podéis descargar desde dentro de vuestra cuenta en la pagina web un paquete de
bienvenida gratuito para poder comenzar. Para ello accederéis dentro de vuestra cuenta
al apartado “Avaliable Downloads”. Una vez descargado e instalado ya estamos
preparados para comenzar con este programa. Ejecutemoslo.
Paso 1: Añadiendo una figura
!
Usar la pestaña “Content” para ver los distintos tipos de recursos que tenemos.
Para tener todos el mismo tipo de visualización al lado de la pestaña “Content” hay un
triángulo con una serie de opciones. Elijamos ver carpetas como árbol “View Folders as
tree”. Nos movemos por el árbol e iremos a DAZStudio / People / Victoria. En la parte
de abajo veremos el archivo Victoria 3 RR LE. Para abrirla hagamos doble clic.
-2-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
!
Añadiendo ropa y utensilios.
!
Ahora vamos a añadirle algunos objetos a la escena. Nos movemos en la
estructura de árbol hasta Victoria / Clothing / Faerie Outfit. Hagamos doble clic sobre el
vestido “Dress”. Posteriormente buscaremos las alas, las añadiremos, y por último el
pelo.
!
Puntualización:
!
Si os fijáis el árbol de directorios está diferenciado dos dos grandes ramas una
llamada “DAZStudio” y otra llamada “content”. Distingamos desde el principio que la
primera de las ramas son archivos procedentes del programa DAZStudio y que desde su
origen han sido diseñados para este programa. Por el otro lado la rama “content” son
archivos compatibles con este programa pero que no han sido diseñados con el. Esto
pueden ser archivos por ejemplo del programa “Poser”. Dentro de este apartado
“content” veremos que está subdividido según los criterios siguientes:
- Camera / Cámara: Archivos que instalan cámaras predefinidas en nuestro plató virtual.
- Faces / Caras: Archivos sobre cambios faciales a nuestros objetos.
- Figures / Figuras: Objetos con propiedades de huesos, para poder mover partes
independientes.
- Hair / Pelo: Tipos de pelos distintos para las figuras.
- Hands / Manos: Tipos de manos distintas con múltiples poses.
- Lights / Luces: Conjunto de luces para nuestras escenas.
- Poses / Poses: Distintos tipos de poses para nuestras figuras.
- Props / Decorados: Objetos que no tienen la propiedad de mover partes individuales.
Enlazando objetos
!
La pestaña escena “Scene” te permite trabajar a través de los objetos de tu
escena. Como verás cada tipo de objeto se distingue por un icono diferente. Así veremos
un icono tipo un cubo cuando nos refiramos a un objeto con una sola parte “props”, es
decir, sin huesos que nos permitan mover algo. El icono representado por tres cubos es
justo lo contrario, nos dice que este objeto está formado por dos o mas partes y que
tienen huesos, es decir, que podremos manejar individualmente alguna de sus partes.
Luego nos encontraremos con iconos que nos pueden representar tipos distintos de luces
que mas adelante veremos y un icono también que nos representará la cámara.
-3-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
!
Ajustando el vestido
!
Para conseguir que el vestido se ajuste exactamente a Victoria, primero debemos
cambiar a la pestaña escena “scene”, seleccionar el objeto perteneciente al vestido en
este caso “Faerie Dress” y veremos como en la pestaña parámetros “parameters” nos
aparecen todas las opciones pertenecientes a este objeto. Una de estas opciones es
ajustar a... “fit to”. Si desplegamos esta casilla veremos como aparece “Victoria 3 RR
LE”. La seleccionamos y automáticamente el vestido se ajustará a Victoria.
Posteriormente haremos lo mismo con las alas.
De la misma forma que la ropa, el pelo es una figura
específica. Cada objeto pelo es diseñado específicamente
para funcionar con una determinada figura. Algunos creadores
de contenido crean pelo que carga como una figura con
partes móviles. En este caso, podrías enlazar ese pelo a la
figura como hemos hecho anteriormente. Sin embargo, lo mas
común es que el pelo sea una figura sin huesos “prop”, la cuál
deberás enlazar a un objeto padre. Normalmente el objeto padre para el pelo es la cabeza
de la figura. De esta forma, cuando muevas la cabeza, el pelo le seguirá.
!
Para asignar el padre del pelo, buscaremos en la pestaña “scene” el objeto cabeza
“Head”. Ahora con el árbol ya expandido, selecciona el objeto pelo “hair” y mueveló hasta
“head”. Verás como este se sitúa dentro del árbol.
-4-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Creando la pose de la figura
!
Ya hemos creado la figura y añadido objetos, ahora nos falta darle el gesto
oportuno. Las poses son la simple manipulación de lo que se llama comúnmente juntas
internas de la figura o huesos.
!
Puedes manipular las juntas de diferentes formas.
- Usar el ratón para mover las partes del cuerpo en la vista directa.
- Seleccionar la parte del cuerpo y usar los deslizadores generales en la pestaña
parámetros “parameters”.
- Usar la pestaña “Powerpose” para manipular las partes de la figura, situándonos en los
puntos marcados.
- Aplicando una pose predefinida.
!
Para hacerte una idea de como funcionar las poses predefinidas ves a la pestaña
contenido “content” y selecciona DAZStudio / People / Victoria / Poses / Faerie. Haz
doble clic sobre cualquiera de las figuras que aparecen para cargar la pose.
Usar “Morphs” para cambiar la forma del cuerpo
!
Los “morphs” trabajan de una forma un poco diferente a las poses. Los morphs
deforman la estructura base de la figura para darle una apariencia diferente. Por ejemplo,
podríamos utilizar uno de los deslizadores para hacer que Victoria pareciese embarazada
en menos de un segundo.
!
Los morphs no siempre están disponibles con las figuras. Algunas figuras tienen
morphs ya hechos, mientras otros están disponibles como paquetes para descargar que
se venden separadamente.
!
Para comenzar y darnos una idea de como funcionan los morphs, selecciona
Victoria RR LE en la pestaña “Scene”. Selecciona la rama principal y no uno de sus
huesos. Ves a la pestaña “Parameters” en la parte derecha de la pantalla. Baja en las
opciones hasta que encuentres la sección “Morphs”. Localiza el deslizador “Skinny”.
Modifica el deslizador “Skinny” y verás como Victoria pierde peso.
-5-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Renderizado
!
Si eres nuevo en esto del software 3D, es posible que no te hayas dado cuenta de
lo que ves en las vistas tan solo son previos. Muchos de los software 3D no visualizan los
resultados finales hasta que lo renderizas. Durante el proceso de renderizado, el software
analiza todos los elementos de tu escena y realiza los cálculos para determinar la
apariencia de los materiales, luces, sombras, altas luces, reflexiones y demás. En este
ejercicio final, tu aprenderás a convertir tu primer tutorial en una imagen.
Paso uno: Parámetros de renderizado.
!
No te preocupes si tu escena no está correctamente centrada o perfecta (esto ya lo
trabajaremos después).
!
Para ver los parámetros de renderizado, busca la pestaña render en el panel
derecho o busca Render > Render Settings si no te aparece la pestaña.
!
La sección velocidad “Speed”, arriba de todo en la pestaña general, contiene un
deslizador que ofrece una forma rápida y fácil de ajustar la velocidad y la calidad de tus
renders.
!
!
En estilo “Style”, podemos dar un efecto normal o de dibujo “Cartoon”.
!
En dimensiones “Dimensions”, seleccionaremos el tamaño de archivo deseado en
pixeles.
!
Y por último indicaremos donde queremos que se guarde el render final en el
apartado “Render To”, donde podemos elegir entre Ventana Activa “Active Viewport”,
nueva ventana “New Window” o guardar el disco con “Image File”.
Paso dos: Renderizar la imagen.
!
Para renderizar la imagen, usa uno de los siguientes métodos: click en el botón
render (el icono de la esfera sólida) en la barra de herramientas o elige el comando
Render > Render
!
Ahora puedes echarte hacia atrás en la silla y contemplar el show de como DAZ
Studio utiliza su motor de renderizado para calcular todas las variables. Cuando el render
haya acabado, deberías tener una imagen en la ventana que debería parecerse a la
imagen que se muestra a continuación.
-6-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Paso tres: Guardar el render
!
Si tu quieres guardar la
imagen renderizada, elige File >
Save Last Render. El cuadro
de dialogo te pedirá que
introduzcas un nombre y elijas
un formato de archivo. Puedes
salvar en JPG, PNG, TIF o
BMP.
Paso cuatro: Guardar la
escena
!
Ahora que tenemos la
escena básica, vamos a
grabarla para poder trabajar con
ella posteriormente. Para ello ir
a File > Save As > Scene.
!
En conclusión
!
En este tutorial, hemos aprendido a como cargar una figura, y como añadir y
ajustar la ropa, pelo y otros objetos (como las alas). Tu también a aprendido a cargar
poses y alterar un poco la apariencia. Finalmente has renderizado y salvado la imagen y
la escena como archivos separados.
Luces! Cámara!
Sobre las luces
!
La iluminación es una de las partes mas importantes en la creación de una escena
3D. DAZ Studio viene con tres tipos de luces.
- Spotlights (luces puntuales) que iluminan en una dirección específica. Su escena
contendrá una luz puntual que proporcionará la luz principal. Está luz emitirá sombras en
la escena.
- Distant Lights (luces distantes) producen una iluminación uniforme, similar a la del sol.
Es utilizada para rellenar áreas oscuras.
- Point Lights (luces omnidireccionales) que iluminan en todas las direcciones. Se utilizan
normalmente para producir énfasis en determinadas áreas. (Imaginemos que queremos
representar una fogata en un campamento)
-7-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Usando cámaras
!
Las cámaras en DAZ Studio funcionan como una cámara convencional con dos
grados de SLR de interés.
- Focal Length (Longitud focal), representada en milímetros que sería en homónimo al
zoom de los equipos fotográficos.
- Focal Distance (Distancia focal), la cual nos permite indicar la distancia de foco.
Nota: para averiguar la distancia numérica exacta de foco podemos utilizar la siguiente
fórmula:
!
Sabiendo que la cámara se encuentra en la posición (x2,y2,z2) y nuestro objeto en
(x1,y1,z1)
!
!
!
!
√((x2-x1)
^2+(y2-y1)^2+(z2-z1)^2
)
Paso uno: Cambiar el color de fondo
!
Para empezar, abre la escena guardada del último tutorial. Puedes cambiar el color
de fondo utilizando la ventana de vista previa y las herramientas de cámara que hay
localizadas en la esquina superior izquierda.
!
1.- Haz click en la flecha de las opciones del menú y elige color de fondo
(background color) para que la iluminación en la escena sea mas dramática.
2.- Cambia el color a negro y haz click en OK para salir del selector de color. Tu fondo
debería ahora ser negro.
Paso dos: Crear y ajustar una luz puntual
!
Para crear una nueva luz puntual, elige Create > New Spotlight. El cuadro de
dialogo se abre con el nombre Spotlight1 preasignado. Para este tutorial, se ha puesto
de nombre faceLight tal y como se indica abajo. Haz clic en Accept del cuadro de
diálogo para aceptar el cambio de nombre y crear nuestra luz.
-8-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
!
No te preocupes si ves que todo ha quedado negro después de crear la luz. La luz
está ahí pero seguramente no está iluminando en la dirección correcta.
!
Seleccionando la cámara faceLight
!
La forma más fácil de apuntar con la luz al sitio donde queremos es situando
nuestra vista sobre la luz misma. Así que ves al botón de selección de cámara en la
esquina superior izquierda del panel de vista y selecciona faceLight de la lista
desplegable.
En estos momentos estarás viendo la escena a través da
la vista de la luz creada. La linea blanca que ves en
medio de la pantalla es el suelo, porque cuando creamos
algo por defecto no situamos a nivel del suelo. Ahora el
siguiente paso será mover la luz a su punto y dirección
adecuada.
!
En el panel de vista aparecen en columna desde la parte superior izquierda todos
los controles que puedes utilizar como mover, rotar, desplazar, etc. Utilízalos para llevar el
punto de luz hasta el lugar deseado.
!
Antes de considerar la luz terminada, vamos a ver unas cuantas opciones añadidas
sobre la luz que hemos creado. Para ello aseguraté de que tienes la luz seleccionada
-9-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
desde la pestaña Scene y comprueba ahora la pestaña Parameters. Aquí verás una serie
de propiedades de la luz que puedes cambiar.
- Shadow Type (tipo de sombra): Es la forma en que la luz arrojara la sombra. Sus
variantes son ninguna (None), mapa profundo de sombras (deep shadow map), trazado
de rayos (raytraced). Esta última tiene un consumo excesivo de procesamiento ya que
se basa en calcular hasta la cantidad de luz que reflejan los objetos según su material.
Lo normal es que si queremos arrojar sombras utilicemos “deep shadow map”
- Shadow Softness (suavidad de las sombras): Vamos a utilizar en este ejemplo un valor
de 2
- Shadow Bias (gradiente de sombra): Podíamos definirlo como la cantidad de penumbra
que contiene una sombra. Vamos a utilizar un valor de 3
- Illumination (iluminación): Aquí podemos definir si queremos apagar la luz (off),
encenderla (on), que sea luz solamente difusa (difusse only), o solo especular
(specular only). Pongamos en este caso “on”
- Color (color): Color de la luz. En este caso para tener luz pura blanca dejaremos los
valores en 255,255,255
- Intensity (intensidad): Para hacer la luz mas o menos brillante. Aquí la reduciremos al
77%
- Spread Angle (ángulo de abertura): Con este deslizador indicaremos si queremos
abarcar mayor o menor área de iluminación. En este caso coloquemos 60.
-10-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Situar la cámara por defecto
!
Ahora que ya tenemos un poco de práctica con la cámara, podemos volver atrás
para ajustar la cámara por defecto y crear nuestro render.
!
Selecciona la cámara por defecto desde la pestaña
de vista (donde elegiste anteriormente la luz como
vista) y muevelá hasta el punto deseado.
Paso tres: Añadir una luz distante (Distant Light)
!
A pesar de que puedes crear y ajustar la luz distante con los mismos
procedimientos que has utilizando antes para crear la luz puntual, vamos ahora a
aprender una forma diferente. Esta vez, utilizarás la vista de la ventana para crear la luz y
situarla exactamente en el punto en el que esta dicha vista.
!
Elige desde el panel de vista, la vista en perspectiva y mueveté hasta mas o menos
como se indica la imagen de abajo.
-11-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Crear la luz distante
- Elige Create > New Distant Light. El cuadro de dialogo aparecerá.
- Renombra la luz por algo mas descriptivo.
- Ahora, click en Show Options. El cuadro se expandirá mostrando opciones adicionales.
- Haz clic, en Apply Active Viewport Transforms: <Perspective View> y haz clic en
Accept. Con esto conseguiremos que la luz creada este exactamente en la posición en
la que se encuentra la vista actual de la imagen.
Ajustando las propiedades de la luz
!
La luz es demasiado brillante, por lo tanto, vamos a ajustar sus propiedades,
incluyendo el color. Nos aseguramos de tener seleccionada la luz distante y nos vamos a
ver su pestaña de parámetros.
- Shadow Type: None. Esta luz no arrojará sombras.
- Shadow Softness: 0.0%
- Shadow Bias: 1
- Illumination: ON
- Color: 188,154,142
- Intensity: 80%
!
Cambia la vista a la cámara por defecto (Default Camera)
-12-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Paso cuatro: Añadir una luz omnidireccional (Point Light)
!
Ya sabemos que la luz omnidireccional ilumina en todas las direcciones. Elige
Create > New Point Light. Con Apply Defaults Settings, asigna un nombre si quieres y
haz clic en Accept.
!
Inicialmente, la luz se situará en el suelo, en el centro de la escena. Se representa
como una esfera de lineas blancas extendiéndose en todas las direcciones. Ahora, con la
luz omnidireccional seleccionada utiliza en la pestaña parámetros los deslizadores X, Y y
Z para ajustar su posición. Muevelá situándola sobre la cabeza de Victoria desplazada
ligeramente hacia su cara.
Paso cinco: Pruebas, trucos y flujo de trabajo.
!
Ahora es un buen momento de guardar la escena otra vez. Si lo deseas, haz
algunos renders de prueba para comprobar tu nueva iluminación y posición de la cámara
y haz los ajustes que sean necesarios. No hay reglas en el flujo de trabajo que deberías
seguir. Muchos de los buenos hábitos son beneficiosos cuando mueves tu trabajo de un
programa a otro. Sin embargo, aquí hay unas sugerencias generales que te pueden
ayudar a construir una imagen en cualquier programa 3D.
- Es siempre una buena idea parar de cuando en cuando y guardar tu trabajo. Recuerda
que estas trabajando con ordenadores y hay ocasiones en que siempre ocurre algo que
hace que las cosas vayan mal.
- Guarda tu progreso de trabajo cada vez que hagas cuatro o cinco cosas largas o justo
antes de realizar un render.
- Después de añadir y ajustar luces o materiales, ejecuta un render de prueba.
- Mientras el render esta en progreso, levántate y estira las piernas un poco. Ves a por un
café o un aperitivo.
- Mira tu render de forma crítica. Anota todo lo que debes rectificar y arreglaló antes de
continuar con otra cosa.
-13-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
- Después de haber realizado los cambios, renderiza otra vez. Puedes renderizar la
imagen completa o usar el render puntual (Spot Render) para calcular sólo un área
determinada.
Creando tus propias cámaras
!
Podemos crear una cámara nueva usando Create > New Camera. Cuando
utilizamos este comando se nos abrirá un nuevo cuadro de dialogo con varias opciones
que tu puedes seleccionar. Si no ves las opciones, haz clic en el botón Show Options en
la parte de abajo de la ventana.
Las opciones son las siguientes:
- Camera Name (Nombre de la cámara): Aquí ponemos el nombre que queramos.
- Apply Default Settings (Aplicar parámetros por defecto): Crea una nueva cámara con
los parámetros de la cámara por defecto
- Apply Active Viewport Transforms (Aplicar las transformaciones de la vista activa):
Crea una cámara nueva en la misma posición y orientación que la vista que tienes
activa.
- Copy Selected Item (Copiar objeto seleccionado): Copia los parámetros de una cámara
que tengas seleccionada en la pestaña “Scene”. Deberás haber seleccionado
previamente la cámara antes de utilizar el comando de crear una nueva, de otra manera,
este comando aparecerá desactivado.
- Create a Persistent Point At Target (Crear un punto persistente en el destino): Cuando
se selecciona, la cámara apunta a un objeto llamado nulo “null” y cuando este objeto se
mueve, la cámara rotará para continuar siempre a ese objeto. La imagen de abajo nos
enseña un ejemplo de cámara con destino.
-14-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Usando los parámetros de la cámara
!
Cuando tenemos una cámara seleccionada como nuestro objeto actual en la
pestaña “scene”, los parámetros de la cámara aparecen en la pestaña “Parameters”.
Mientras algunos de estos parámetros te permiten ajustar la cámara hay otros también de
interés. Existen tres grandes secciones dentro de estos parámetros.
- The transforms Section (Sección de transformaciones)
- The Misc Section (Sección de varios)
- The Camera Section (Sección de cámara)
La sección de transformaciones (transforms)
!
Los controles en la sección de transformaciones son comunes en prácticamente
todos los objetos de la escena.
-Translación: Esta barra mueve la cámara en todas las
direcciones. La barra X mueve la cámara a derecha e
izquierda. La barra Y mueve la cámara arriba o abajo y la
barra Z mueve la cámara hacia delante o hacia atrás.
-Rotación: La rotación hace girar la cámara en cualquier
dirección. Para los que no están acostumbrados en los
movimientos en los ejes de coordenadas, a veces les
resulta difícil pensar que eje es el que debemos utilizar
para realizar una determinada rotación. Una buena ayuda
suele ser pensar en que si la cámara estuviera atravesada
por una barra, como debería ser la barra para que la
cámara girara. Por ejemplo si quisiéramos hacer que la
cámara rotará hacia arriba o hacia abajo, la barra que
atravesaría esta cámara para permitir esa rotación seria
una barra que iría de derecha a izquierda. Por lo tanto
sería el eje X.
-Escala: Los deslizadores de escala modifican el tamaño
físico de la cámara en tu escena. No afecta a lo que la
cámara ve de ninguna forma.
La sección de varios (misc)
-Visible: Este botón activa o desactiva la
visibilidad de la cámara.
-Seleccionable (selectable): Este botón hace
que la cámara la podamos o no seleccionar
directamente en el panel de vista.
-Apunta A (Point At): Esta opción permite que
la cámara apunte directamente a un objeto en
nuestra escena.
-15-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
La sección de cámara (camera)
-Perspectiva (Perspective): Cuando esta
opción está habilitada, la cámara actúa como
una cámara con perspectiva. Cuando creas
una cámara por defecto esta viene activada.
Puedes desconectar esta opción para
convertirla en una cámara ortogonal.
-Longitud focal (Focal Length): La longitud
focal de una cámara normalmente viene
expresada en milímetros y sirve para abarcar
un mayor o menor ángulo de visión sin
movernos del sitio.
-Profundidad de campo (Depth of Field): La
profundidad de campo es la distancia desde la
cámara al objeto que deseamos que aparezca
con foco. Activar este parámetro nos permitirá
seleccionar posteriormente la distancia de foco.
- Distancia focal (focal distance): Mueve la distancia de foco alejándose o acercándose.
- F/Stop: Ajusta el diafragma de apertura de la cámara; el ratio luz/exposición
Pestaña escena (scene)
!
La pestaña escena que ya hemos estado utilizando, es para visualizar en forma
jerárquica cada uno de los objetos de nuestra escena con la excepción de las vistas por
defecto. Cada cámara creada por el usuario así como las luces, figuras, partes del cuerpo
y decorados aparecen aquí, dándote una vista centralizada de tu escena y de la relación
entre los objetos.
Jerarquía de escena y pestaña de controles
!
Tal y como se mencionaba
arriba, la pestaña escena nos
presenta una vista jerarquizada
de nuestra escena. Estas
relaciones son mostradas en
forma de árbol con múltiples
niveles de ramas, donde los
hijos aparecen en sub-ramas.
Como ejemplo útil es pensar en
un árbol real. El padre es el
tronco, os hijos son la ramas
mas grandes, con varios
niveles de hijos que son las
ramas pequeñas y las hojas.
-16-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
!
Los dos iconos que aparecen al lado de la lista de elementos representados por un
ojo y por una mano señalando son para hacer los objetos visibles o invisibles (con el ojo)
y seleccionables o no en la ventana de vista (con la mano señalando)
Renombrando objetos
!
Puedes renombrar objetos en la pestaña escena, para ello basta con que
selecciones primero el objeto en cuestión y vuelvas a realizar otro clic sobre el. Introduce
el nombre deseado y pulsa Enter.
Agrupando en un objeto null
!
Muchas veces desearías agrupar todas las luces en un grupo, o por cualquier otro
tipo de cosa. Un buen truco es crear un objeto nulo (null). Este es un objeto que no tiene
forma, digamos que no es visible y nos sirve para agrupar cosas o para que una cámara
apunte a un sitio determinado sin que se vea su destino. La forma mas rápida para
agrupar varios objetos en seleccionar primeramente todos los objetos que deseamos
agrupar y luego ir al comando Create > New Null y seleccionar la casilla Parent Selected
Item(s) to Null (Emparentar los objetos seleccionados a Null). De esta forma el objeto
Null será ahora el padre de todos los objetos que teníamos seleccionados.
¿Qué es el DAZ Studio 3D Bridge?
!
El DAZ Studio 3D Bridge para Photoshop le permite al usuario rápida y fácilmente
importar contenido 3D, el cual ha sido creado y renderizado en DAZ Studio, hacia
Photoshop. Una vez importado el contenido 3D en Photoshop puede ser integrado en
escenas digitales y usar las potentes herramientas de Photoshop para su edición. Los
mapas de imágenes 3D pueden ser modificados en el mismo Photoshop y
instantáneamente renderizados de nuevo usando DAZ Studio.
Versiones soportadas de Photoshop.
!
!
Macintosh - Photoshop CS2 o mayor
PC - Photoshop 7 o mayor
La pestaña de DAZ Studio 3D Bridge
!
Una vez que ha sido instalado es accesible por Photoshop a través de Archivo >
Automatizar > DAZ Studio 3D Bridge. Esto hará que se active el cuadro de dialogo de 3D
Bridge, tal y como se indica abajo, y lanzará DAZ Studio.
!
En Mac puede aparecer algún problema con la conexión automática de los dos
programas, si esto es así, ejecutar manualmente DAZ Studio y conectarlos los dos
mediante el comando Edit > 3D Bridge de DAZ Studio.
-17-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
-El botón Preview Image (imagen previa) crea
una imagen o capa en Photoshop usando la
vista activa de DAZ Studio.
-El botón Update Image (actualizar imagen)
refresca la imagen o capa en Photoshop con
la vista activa. Si la imagen ha sido modificada
en DAZ Studio, esto sincronizará la ventana
de Photoshop.
-El botón Enable Auto Update (activar
actualización automática) hace que photoshop
mantenga en la capa siempre la última
actualización que tengamos en DAZ Studio.
(En ordenadores MAC puede causar cuelgue
esta función por ahora)
-El botón Render to New Layer (renderizar
en capa nueva) hace uso del motor de
renderizado de DAZ Studio para tener el
resultado final de DAZ en una nueva capa.
-Import Scene to CS3X (Importar escena a
CS3X) nos trae la escena de DAZ Studio como
una capa U3D a Photoshop CS3 Extended. De forma que podamos utilizar directamente
los controles de Photoshop para su movimiento, rotación, escalado, etc.
- Import Image Maps (importar mapas de imágenes) importa imágenes a capas de
Photoshop para seleccionar mapas de texturas que son asociadas con DAZ Studio.
- Export Image Maps (exportar mapas de imágenes) guarda los mapas de imágenes
seleccionados para que DAZ Studio actualice la escena con los nuevos mapas.
Previsualizando una imagen
!
Para previsualizar una imagen, haz clic en el botón Preview Image. Aparecerá un
cuadro de diálogo con los campos ancho y alto (width y height) y las opciones de
importar en una capa (import to layer) o importar el mapa de imágenes (import image
maps).
El previo en vista previa bajo OpenGL será
importado a un nuevo documento o nueva capa
en Photoshop. Ten en cuenta que la imagen que
se importe viene dada por la cámara
denominada “camera 3d bridge”.
Renderizando en una nueva capa
-18-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
!
Una vez estas satisfecho con tu escena ya puedes usar el motor de renderizado de
DAZ Studio para producir una mayor calidad en la imagen final.
!
Para ello haz clic en Render to New Layer (renderizar en capa nueva). Se te
abrirá un cuadro de diálogo preguntándote las dimensiones del render. Si quieres utilizar
las dimensiones que vienen dadas por el propio DAZ Studio marca la casilla Link active
document to Daz Studio (enlazar el documento activo con DAZ Studio). Si una vez
renderizado ves que la imagen se encuentra en capa fondo y queríamos que la figura
estuviera sobre fondo transparente fijaté que en la historia de Photoshop el último paso a
sido acoplar capas. Ves un paso atrás para deshacer el acoplaje.
!
Un buen truco para el manejo fluido de 3D Bridge es primeramente trabajar con
una imagen de baja resolución pero manteniendo la relación de aspecto de nuestro
trabajo final. Una vez tengamos nuestro proyecto tal y como lo queremos en el proceso de
renderizado pongamos la resolución real que deseamos.
Importar una escena a CS3X
!
Cuando usamos 3D Bridge en conjunción con Photoshop CS3 Extendido, el plug-in
te permitirá exportar la escena entera 3D desde DAZ Studio a una capa U3D de
Photoshop.
!
Para importar una escena a Photoshop CS3 Extended como U3D.
- Carga la escena o crea una en DAZ Studio.
- Haz click en Import Scene to CS3X. Se abrirá un cuadro de diálogo.
-Selecciona las opciones oportunas: Resample maps
(reescalar mapas) permite que las imágenes sean
reescaladas a tamaños mas eficientes. Export Lights
(exportar luces) nos exportará la iluminación junto con
la escena. Export Cameras (exportar cámaras) nos
traerá también las cámaras a Photoshop para poder
seleccionarlas. Maximum Size (Tamaño máximo)
selecciona el tamaño máximo que pueden tener los
mapas de texturas y se reescalarán si es necesario.
Importar / Exportar Mapas de imágenes
!
Si quieres poder modificar los mapas de imágenes dentro de Photoshop, puedes
importar esos mapas. Por ejemplo en Photoshop tu podrías dibujar encima, cambiar
colores, etc. en los mapas de imágenes, posteriormente DAZ Studio renderizaría el
modelo 3D incorporando los cambios realizados.
!
Hay dos formas de importar mapas de imágenes en Photoshop.
-19-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
!
Puedes hacer clic en Preview Image y activar la opción Import
Image Maps, después haz clic en Import o clic directamente
en Import Image Maps
!
De cualquiera de las dos formas se te abrirá un nuevo
cuadro de diálogo con una lista de todos los mapas de imágenes utilizados en la escena.
Selecciona los mapas de imágenes deseados y haz clic en Import.
!
Haz los cambios oportunos en las imágenes pero no grabes los cambios. Una vez
estén realizados haz clic en Export Image Maps. Se abrirá un cuadro de diálogo con la
lista de las imágenes que habíamos importado. Seleccionalás y haz clic en Export.
Los mapas de imágenes serán exportados y
guardados en la carpeta original con un nuevo
nombre además de actualizarse directamente en
nuestra escena en DAZ Studio.
-20-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
Creación de nuestro plató virtual
El primer paso va a ser crearnos un plano con
el tamaño del estudio. Para ello iremos a:
!
CREATE > NEW PRIMITIVE
TYPE - PLANE
SIZE - 3m x 3m
Ahora vamos a crear todas las
luces que utilicemos normalmente.
Para ello iremos a: CREATE >
NEW SPOTLIGHT (le damos el
nombre que queramos)
Consejo: crear todas las luces
posibles y luego activar o
desactivar solo las necesarias
Por defecto las luces se sitúan en
-21-
Israel Luri. http://www.israelluri.es/blog
DAZ STUDIO 2.1 / DAZ STUDIO 3D BRIDGE
(x=0, y=0, z=0) siendo x=anchura o lados y=altura y z=profundidad
!
Seleccionamos desde la pestaña SCENE la luz
que queremos modificar y en PARAMETERS
cambiaremos sus propiedades.
Ejemplo: Si marcamos en SCENE el objeto LUZ
FONDO DERECHA y vamos a PARAMETERS
y en el deslizador X TRANSLATE ponemos la
cantidad de -100, moveremos la luz 1 metro a la
izquierda
Posteriormente podemos crear la luz ambiente
con CREATE > NEW DISTANT LIGHT
También es un buen truco el crear un objeto
básico como un cubo o una esfera con
CREATE > NEW PRIMITIVE > TYPE: CUBE o
SPHERE y utilizar este objeto para que las luces que creamos oportunas siempre apunten
a este objeto, seleccionando las luces y en su pestaña PARAMETERS buscar la opción
POINT AT y marcar el objeto al que queremos que apunten. De esta forma podemos
mover este cubo esfera a nuestro libre antojo y las luces siempre apuntarán a dicho
objeto. Una vez tengamos el lugar deseado podemos ir a la pestaña SCENE y hacer clic
en el ojo correspondiente a este objeto para que no aparezca en la escena o crear un
objeto “null” ya que este por defecto no se renderiza en la escena.
!
Una vez terminado todo nuestro estudio virtual podemos agruparlo dentro de una
rama en scene para poder utilizarlo de una forma mas cómoda si nos llevamos este plató
a otro archivo. Para ello primero seleccionaremos todos nuestros objetos desde SCENE y
luego crearemos un objeto NULL desde CREATE > NEW NULL. Podemos indicarle como
nombre por ejemplo PLATÓ VIRTUAL y marcaremos la opción PARENT SELECTED
ITEM(S) TO NULL.
!
Por último guardaremos nuestra escena desde FILE > SAVE AS > SCENE en la
carpeta que escojamos.
-22-
Israel Luri. http://www.israelluri.es/blog

Documentos relacionados