El beso de la princesa El beso de la princesa

Comentarios

Transcripción

El beso de la princesa El beso de la princesa
argentina
El beso
de la princesa
Adecuar los gráficos
a las necesidades de trabajo
Gabriela y Juank Asinsten
Versión 6.1 - Mar2009
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
El beso
de la princesa
El beso de la princesa
¿Y eso, para qué? ................................................................................................. 3
Recortar un gráfico con GIMP ............................................................................ 4
Capas, capas, capas... .......................................................................................... 5
En PaintShop Pro 4.12 ........................................................................................ 8
Tamaño del lienzo, o Canvas Size ....................................................................... 9
Ampliar o reducir un gráfico ............................................................................. 12
Achicar o agrandar imágenes en GIMP ............................................................. 12
Aspect Ratio ...................................................................................................... 13
En PaintShop Pro 4.12 ...................................................................................... 14
Tabla 1 - Cantidad de píxels, según dimensiones en mm y resolución ............. 15
Tabla 2 - Dimensiones en mm, según cantidad de pixels y resolución ............. 17
Cambiar la profundidad de color de un gráfico ................................................ 18
En GIMP ............................................................................................................ 18
Para reducir la profundidad de color en PSP 4.1 .............................................. 21
No sólo de GIFs vive el hombre... .................................................................... 23
Convertir entre formatos ................................................................................. 24
Conversion de formatos en GIMP ................................................................... 25
Formatos y extensiones reconocidos por GIMP .............................................. 26
Conversión de formatos en PaintshopPro ........................................................ 27
Los formatos vectoriales en PSP....................................................................... 29
PSP: el formato propietario de PaintShopPro................................................... 31
«Batch» conversión ........................................................................................... 32
Más automatización .......................................................................................... 33
Blaze Media converter ...................................................................................... 35
- 2
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 3
El beso de la princesa
Hace algunos años era habitual encontrar por allí, al cruzar algún
bosque, o en las cercanías del castillo, a una princesa abocada a la tarea
de convertir feos sapos en bellos y matrimoniables príncipes. Esa tarea
la cumplían, generalmente, mediante un mágico beso que producía la
transformación necesaria para ser felices y comer perdices.
Nosotros no propondremos faenas similares, habida cuenta de que la práctica de hechizar príncipes está algo pasada de moda, y andar besando sapos
por allí, hasta encontrar un príncipe encantado, puede convertirse en una
labor casi infinita, dada la escasez... Además, a nuestra edad, la monarquía ya
no tiene la imagen romántica de nuestra niñez, por lo menos en estos pagos
republicanos.
Pero, como con el beso mágico de la princesa, convertiremos gráficos
en otros gráficos, más adecuados a nuestra necesidades. Esos cambios se
pueden agrupar en tres tipos:
„
Cambiar el tamaño de un gráfico
„
Cambiar la profundidad de color (cantidad de colores
posibles)
„
Cambiar el formato gráfico.
¿Y eso, para qué?
Las princesas besaban sapos por necesidad: para conseguir marido. Y qué
mejor que un príncipe hechizado por alguna bruja envidiosa para eso...
Nosotros lo haremos por otros motivos, menos trascendentes pero, posiblemente, más útiles, que detallamos en la página siguiente, antes de entrar
«en materia»:
Toda la información referida a los conceptos que manejamos en este capítulo se encuentra
detallada en el documento multimedia El famoso píxel.
Allí se puede profundizar en los conceptos de profundidad de color y formatos gráficos,
necesarios para comprender los procesos que detallamos en este capítulo.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
CAMBIAR EL TAMAÑO
Cambiar el tamaño de un gráfico puede significar varias cosas diferentes:
„
Recortar las partes sobrantes del gráfico.
„
Achicar o agrandar todo el gráfico. Ampliarlo o reducirlo.
„
Agrandar la superficie de trabajo del gráfico, pero sin modificar el tamaño de la imagen que contiene.
„
Modificar el tamaño de impresión del gráfico.
CAMBIAR LA PROFUNDIDAD DE COLOR
Cambiar la profundidad de color, lo que llamamos habitualmente cambiar
la cantidad de colores de un gráfico, puede obedecer a diversas razones:
a) Aumentar la cantidad de colores. Esto se hace para poder
trabajar sobre el gráfico, pintarlo o aplicarle filtros. Los gráficos blanco y negro, por ejemplo, no aqdmiten ser pintados.
b) Disminuir la cantidad de colores. Esto suele hacerse para
achicar el tamaño de los gráficos. Los gráficos de 256 colores, por ejemplo, son por lo menos 3 veces más pequeños
que los de 16 millones.
CAMBIAR EL FORMATO
No todos los programas pueden leer cualquier formato. Por razones tecnológicas o comerciales, muchos programas reconocen sólo algunos. Si tenemos una hermosa ilustración en formato TIF, por ejemplo, y la queremos
utilizar para un puzzle, es muy probable que debamos trasformarla en BMP,
que es el formato que reconoce la mayor parte de los programas de hacer
rompecabezas.
Y ahora... manos a la obra..!
Recortar un gráfico con GIMP
Generalmente, cuando escaneamos, capturamos una superficie mayor
que la necesaria. Es muy difícil en la previsualización del escaner cortar exactamente lo necesario. Lo mismo sucede con muchas capturas de pantalla.
También puede ser que tengamos una foto de colección de la cual nos interesa sólo una porción.
En todos estos casos necesitaremos recortar el material sobrante.
Utilizaremos GIMP 2.2, nuestro graficador de cabecera, para todas estas acciones.
- 4
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
2
1
- 5
Vamos a recortar el
excedente (2) y conservar
lo que se encuentra dentro
del recuadro (1)
A esta operación llamamos
recortar o Crop, según el
programa.
La operación elimina
definitivamente del
archivo la zona excedente
(2)
2
2
1
Abrimos la imagen familiach.tif
De la paleta de
herramientas tomamos la de
cortar o crop.
Este ejercicio se puede
hace con cualquier
imagen
Capas, capas,
capas...
GIMP es un programa muy orientado al
trabajo con capas. Esto
hace que algunas operaciones simples requieran pasos adicionales, como en el caso de
los recortes.
Pero, cuando avancemos en la utilización
y aprovechamento de la
potencialidad de las capas, estas pequeñas
molestias serán recompensadas.
2
A
B
1) Colocamos el cursor en
uno de los vértices de la
zona a cortar (A).
Podemos hacer esta
operación con
tranquilidad, ya que
podemos mover
posteriormente ese
punto.
2) Manteniendo presionado
el botón principal del
mouse, arrastramos al
puntero desde (A) hasta
(B).
Aunque....
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 6
3
1
1) En cuanto hacemos clic
sobre la imagen se abre
una pantalla de
configuración numérica
del recorte.
2) Esta pantalla se coloca
sobre la zona de la
imagen, impidiendo que
completemos
manualmente la
operación.
3) De manera que
deberemos hacer lo
indicado en el paso
siguiente.
4
1
1) Hacemos clic sobre la
barra del título de la
imagen para que sea la
ventana activa.
2) Colocamos el cursor en el
vértice inferior del
rectángulo, hasta que...
3) ...aparece la doble flecha
de mover el punto para
achicar o agrandar la
zona de recorte.
4) Entonces, sí, podemos
completar la operación.
3
2
5
A
C
2
C
B
1) Observemos que la zona
a cortar aparece oscura,
para que la distingamos
fácilmente.
2) La zona de recorte puede
ser modificada o movida,
para ajustar el tamaño o
posición.
3) Los puntos de los vértices
(A) y (B) sirven para
redimensionar.
4) Los puntos de los vértices
(C) para mover.
5) Con doble clic sobre la
zona clara de la imagen,
o con el botón recortar
de la pantalla de control,
se produce el recorte.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 7
6
1
1) La imagen se recortó,
según la dimensión
indicada. Pero aparece
sobre una superficie
mayor, transparente (la
zona cuadriculada en
gris).
Esto ocurre porque GIMP
es un programa muy
orientado al trabajo con
capas.
Necesitaremos entonces
hacer un paso más.
7
1
1) En el menú Imagen,
elegimos la opción
Ajustar lienzo a las
capas.
Eso elimina la parte de
lienzo (fondo) que no
necesitamos.
Listo...
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 8
En PaintShop Pro 4.12
1
Tomamos la herramienta
de selección y nos
aseguramos en el panel de
control que esté establecida
la forma Rectangle.
2
Manteniendo presionado el
botón principal del mouse,
trazamos un rectángulo
desde A hasta B
A
Cuando soltemos el botón,
quedará dibujado el clásico
caminito de hormigas
que marca la selección.
B
3
1
1) Vamos al menú Image
2) Elegimos la opción Crop
3) Obtenemos entonces
nuestra fotografía
recortada.
2
Si la versión completa de la
fotografía o el gráfico que
acabamos de recortar no
nos interesa, bastará con
guardar el cambio.
Pero si nos interesa
conservarla, deberemos
hacer un Guardar como...
(File/Save as...) para
guardar la versión recortada
con otro nombre, y tener
así las dos versiones.
3
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 9
Otra forma de no perder el original completo, es utilizar los botones de
copiar y pegar de PaintShop Pro. Una vez realizada la selección de la manera
que indicamos en los pasos 1 y 2, se presionan alternativamente los botones
de copiar y el de pegar. PSP creará automáticamente un gráfico nuevo con el
contenido de la selección, obteniendo el mismo resultado que con la operación de Crop. Deberemos guardar este nuevo gráfico con otro nombre.
LA HERRAMIENTA CROP
Las versiones posteriores de Paint Shop Pro y muchos otros programas
tienen una herramienta especializada para la función de recortar. El trazado
es similar que el que mostramos antes, pero la diferencia fundamental es que
las líneas de corte pueden moverse, una vez dibujado el rectángulo.
Una vez trazado el
rectángulo, podemos tomar
cualquiera de las líneas y
ajustar su posición,
mediante el puntero del
mouse. Cuando el puntero
se encuentra sobre una
línea, se convierte en una
flecha doble.
Una vez ajustado el tamaño,
se hace doble clic dentro de
la superficie del rectángulo
y se produce el recorte.
Tamaño del lienzo, o Canvas Size
La palabra canvas significa algo así como el lienzo del pintor, o el papel
sobre el que dibujamos. El tamaño del canvas puede modificarse, sin afectar
el tamaño de la imagen que contiene. En el caso de que agrandemos el canvas,
esto puede semejarse a pegar más papel alrededor del
dibujo.
1
1) Imagen original
2) Imagen con el canvas
agrandado. La zona que
se agregó es la de color
verde.
El tamaño de la imagen
se mantuvo igual.
2
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
„
Anexo Unidad 4: El beso de la princesa
Agrandar el canvas
Significa agregar superficie, pero sin modificar el tamaño del gráfico original.
Se utiliza cuando hay que agregar elementos de mayor
tamaño o que por su posición no entran en el gráfico
original.
„ PSP 4.12 no posee herramientas de agrandar el canvas.
„
- 10
Insistimos: los mismos
resultados pueden
obtenerse mediante
diversos procedimientos.
Achicar el canvas.
Como el tamaño de la imagen original no varía, al achicar el canvas se produce un recorte, de efectos idénticos al del recortar o crop.
„ En PSP 4.12, la diferencia consiste en que
crop es una operación que se hace con control visual exclusivamente, mientras que achicar el canvas se realiza mediante una pantalla
que introduce valores numéricos. Esto sirve
cuando tenemos que producir un recorte
exacto.
„ En GIMP es la misma operación, ya que la
introducción de valores numéricos está incluida en la herramienta de recortar.
De cualquier manera, GIM incluye una herramienta muy precisa de modificación del
canvas.
1
1
1) Vamos al menú Imagen
2) Elegimos la opción
Tamaño del lienzo.
2
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 11
2
1
1) Aparece la ventana de
control de la herramienta.
2) El botón link vincula las
modificaciones de ancho
y alto. Si queremos que el
aumento sea
proporcional, lo dejamos
activo. Si queremos
modificar cada medida
individualmente, lo
desactivamos.
2
3
4
5
7
6
5
6
8
3) Para modificar el ancho
del lienzo (canvas).
4) Para modificar el alto del
lienzo (canvas).
5) Para desplazar la posición
de la imagen dentro del
lienzo. Horizontalmente,
de izquierda a derecha.
6) Para desplazar la posición
de la imagen dentro del
lienzo. Verticalmente, de
arriba a abajo.
7) Para centrar la imagen en
el lienzo.
8) Para aplicar los cambios.
3
TRABAJO TERMINADO.
Observemos que la
superficie agregada es
transparente (cuadriculado
gris).
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 12
Ampliar o reducir un gráfico
Los gráficos basados en pixels pueden ampliarse o achicarse, según nuestras necesidades. Esta operación suele producir una pequeña pérdida de calidad. En este caso, el conjunto de la imagen modifica su tamaño.
Esta operación se realiza, normalmente, para adecuar el tamaño del gráfico a un espacio determinado, mayor o menor, según el caso, al tamaño
original del gráfico.
IMAGEN
ORIGINAL
IMAGEN
AGRANDADA
IMAGEN
REDUCIDA
Achicar o agrandar imágenes en GIMP
1
Vamos a agrandar una
imagen de 709x468 píxels,
haciéndola de 900 píxels de
ancho.
1) Menú Imagen.
2) Opción Escalar la
imagen...
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 13
2
Aparecerá la ventana de
escalar imágenes.
1) Nos aseguramos que el
botón link esté activo,
para que las
modificaciones
mantengan la
proporcionalidad del
gráfico (ver recuadro al
pie de página).
2) Colocamos el ancho
deseado (900 píxels).
3) Haciendo clic sobre el
recuadro del alto, el
mismo se actualiza
automáticamente.
4) Modificamos la
resolución, si fuera
necesario. Para trabajar
en pantalla es suficiente
con 75 píxeles por
pulgada, lo que achica
notablemente el peso del
gráfico.
5) Configuramos para
interpolación cúbica,
para tener la mejor
calidad.
6) Aprobamos con el botón
Escala.
7) Nuestro gráfico con el
tamaño modificado.
Aspect Ratio
Esta expresión la encontraremos en todas las opciones de modificar
gráficos de los diferentes programas especializados.
Aspect ratio significa algo así como la relación entre el ancho y el
alto de un gráfico. Cuando le decimos que mantenga esa relación, la
imagen no modificara su aspecto al achicarse o agrandarse.
MODIFICACION
PROPORCIONAL
MODIFICACION NO PROPORCIONAL
En GIMP la casilla de
Aspect ratio es
reemplazada por el botón
link, que vincula ambas
dimensiones
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 14
3
Para reducir el gráfico (por
ejemplo a 500 píxels de
ancho) se procede de la
misma manera
En PaintShop Pro 4.12
PaintShop Pro tiene dos comandos para realizar esta acción: Resample y
Resize. Ambos producen el mismo resultado, con diferente calidad. Esto
tenía sentido en su momento, ya que la mayor calidad requiere cálculos más
complejos, que en las computadoras de hace algunos años ocupaban mucho
más tiempo. En la actualidad no tiene sentido utilizar el comando Resize, que
produce una calidad sensiblemente inferior, dado que la diferencia de tiempo
de ejecución con Resample es imperceptible. De manera que ignoraremos
la existencia de Resize y nos concentraremos en Resample.
Desde luego que el dato inicial, es la medida que deseamos o necesitamos que tenga nuestro gráfico. Esa medida la necesitamos en pixels, ya que
es la única unidad que aparece en la ventana Resample de PSP4.
1
Teniendo abierto el archivo
a modificar, vamos al menú
Image y allí se elige la
opción Resample.
1
2
PÍXELS Y
CENTÍMETROS
Los píxels nos sirven para
manejarnos con imágenes
destinadas a la pantalla (que
se mide en píxels).
Cuando trabajamos con
gráficos que imprimiremos necesitamos su medida en cm.
La relación está mediada
por la resolución. Por separado ofrecemos una tabla
de equivalencias
2
4
3
1) Aparecerá la ventana
Resample
2) Elegimos la opción
Custom Size
3) Mantenemos tildada la
casilla Maintain aspect
ratio, que garantiza la
proporcionalidad.
4) Colocamos el valor del
alto o el ancho. El otro se
actualiza
automáticamente.
La casilla izquierda es
para el ancho y la
derecha para el alto.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
Las siguientes tablas pueden ayudarnos a resolver qué cantidad de
píxels debemos colocar en la ventana de Resize. También nos sirve para
tomar decisiones al escanear.
Tabla 1 - Cantidad de píxels, según dimensiones
en mm y resolución
Los decimales se colocan en función del cálculo, pero la cantidad de
píxels siempre es un número entero.
RESOLUCIÓN, EN DPI (PUNTOS POR PULGADA)
mm
72
100
120
150
180
200
250
300
1
2,8
3,9
4,7
5,9
7,1
7,8
9,8
11,8
5
14,1
19,7
23,6
29,5
35,4
39,4
49,2
59,0
10
28,3
39,4
47,2
59,1
70,9
78,7
98,4
118,1
25
70,9
98,4
118,1
147,6
177,2
196,8
246,1
295,3
50
141,7
196,8
236,2
295,3
354,3
393,7
492,1
590,6
75
212,6
295,3
354,3
442,9
531,5
590,6
738,2
885,8
100
283,5
393,7
472,4
590,5
708,6
787,4
984,2
1181,1
150
425,2
590,5
708,6
885,8
1063,0 1181,1
1476,4
1771,7
200
566,9
787,4
944,9
1181,1
1417,3 1574,8
-
-
250
708,7
984,3
1181,1
1476,4
1771,7
-
-
-
300
850,4
1181,1
1417,3
1771,6
2126,0
-
-
-
- 15
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 16
CÓMO USAR LA TABLA
Supongamos que necesitamos un gráfico que mida 120 mm (12 cm) de
ancho. Si el gráfico lo imprimiremos con una impresora de chorro de tinta, la
resolución puede estar entre 100 y 150 dpi. Para el ejemplo decidiremos 120
dpi. La medida en píxels que deberemos colocar en Resample es:
para 100 mm
=
para 20 mm
=
total 120mm
=
472,4 pixels
94,4 pixels (47.2 x 2; dos veces el valor para 10 mm)
567,0 pixels (566.8 la cantidad debe ser un número entero)
Otro ejemplo: supongamos que necesitamos un gráfico que mida 175 mm (17,5 cm) de ancho.
Trabajaremos a 150 dpi.
para 100 mm
=
590,5 pixels
para 50 mm
=
295,3 pixels
para 25 mm
=
147,6 pixels
total 175mm
=
1033,0 pixels (1033.4 la cantidad debe ser un número entero)
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
Tabla 2 - Dimensiones en mm, según cantidad de
pixels y resolución
RESOLUCIÓN, EN DPI (PUNTOS POR PULGADA)
PIX
72
100
120
150
180
200
250
300
10
3,5
2,5
2,1
1,7
1,4
1,3
1,0
0,8
20
7,0
5,1
4,2
3,4
2,8
2,5
2,0
1,7
25
8,8
6,3
5,3
4,2
3,5
3,2
2,5
2,1
50
17,6
12,7
10,6
8,5
7,0
6,3
5,1
4,2
100
35,3
25,4
21,2
16,9
14,1
12,7
10,2
8,5
200
70,6
50,8
42,0
33,9
28,2
25,4
20,3
16,9
500
176,4
127,0
105,8
84,7
70,6
63,5
50,8
42,3
1000
352,8
254,0
211,6
169,3
141,1
127,0
101,6
84,7
1500
-
381,0
317,5
254,0
211,7
190,5
152,4
127,0
3000
-
-
-
508,0
423,3
381,0
304,8
254,0
5000
-
-
-
-
-
635,0
508,0
423,0
Esta tabla es similar a la anterior. Una de las entradas es la resolución y la
otra la cantidad de pixels. La tabla nos informa las dimensiones en mm de un
gráfico, a partir de esos datos. Se utiliza del mismo modo que la tabla anterior.
- 17
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 18
Cambiar la profundidad de color de un gráfico
En la multimedia El famoso píxel se trata detenidamente el tema de la
profundidad de color, el aspecto que toma una fotografía o gráfico en cada
caso. En este apartado veremos cómo pasar un gráfico de una profundidad a
otra, que es lo más sencillo. Y algunos criterios para tomar decisiones al
respecto, tema bastante más extenso y complejo.
En GIMP
GIMP tiene un modo simplificado de trabajar la profundidad de color.
1) Llama RGB a los gráficos
de 24 bits, 16 millones
de colores.
2) Los gráficos de escala de
grises son de 8 bits (256
grises). Como todos los
programas gráficos.
3) Llama indexados a los
gráficos de hasta 256
colores. Pero incluye en
esta categoría gráficos de
1 bit (blanco y negro).
1
2
3
1
2
3
Para reducir la profundidad
de color de un gráfico de 16
millones de colores
1) En el menú Imagen
2) Elegir la opción Modo
3) Elegir entre las dos
opciones posibles:
- Escala de grises
- Indexado
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Gabriela y Juan Carlos Asinsten
Anexo Unidad 4: El beso de la princesa
- 19
La transformación en escala
de grises no tiene
parámetros.
Se aplica directamente.
La transformación en
indexado convoca a una
ventana de diálogo para
elegir entre varias opciones.
1
2
3
4
5
1) Paleta optimizada. Elige
los 256 colores que
mejor representan la
gama de tonos del
gráfico.
2) Utiliza la paleta segura de
Internet.
3) Convierte el gráfico en
blanco y negro. Ver
página siguiente.
4) Permite usar una paleta
personalizada.
5) Compone colores
utilizando puntos, para
simular una gama de
colores más completa.
Ver muestras en la
página siguiente.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
16 MILLONES DE COLORES
Anexo Unidad 4: El beso de la princesa
- 20
INDEXADO - 256 COLORES
1) Aunque GIMP no lee
archivos de 1 bit (Blanco
y negro), ya que los
convierte
automáticamente en
imágenes de escala de
grises, sí puede guardar
en ese formato.
2) Lo hace utilizando las
posibilidades de
difuminado.
3) El resultado, usando
difuminado, es una
imagen que simula con
puntos los tonos de
grises. Y es ocho veces
más pequeña que una
de ese tipo.
1
2
3
En las páginas siguientes
se aborda más en
detalle el tema de la
profundidad de color,
utilizando PSP 4.12, que
ofrece prestaciones más
completas, similares a
las de los programas
profesionales.
Sin embargo, para uso
educativo, GIMP es más
que suficiente.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 21
Para reducir la profundidad de color en PSP 4.1
1
3
2
3
1
3a
3b
3c
Con el gráfico abierto y
activo...
1) Menú Colors
2) Decrease colors
3) Se elige una de las
opciones posibles.
Las opciones habilitadas
son las de menos colores
que los que tiene el
gráfico. Para uno de 256
colores, por ejemplo,
aparecerán habilitadas
sólo las opciones de 16 y
2 colores.
Cada opción abre paletas
de configuración que
veremos a continuación.
BAJAR A 2
COLORES
3
1) Permite elegir el canal
que se usará para la
reducción. Normalmente
se usa el de componentes
de luminosidad (Grey
values).
2
3a
3b
3c
07-color-10.tif
2) La opción Weighted
produce bordes más
duros, sin dithering
(puntos) de transición.
Non-weighted,
transiciones más suaves.
El ejemplo, un detalle de
la fotografía de las frutas,
no muestra diferencias
notables.
3) Modos de la reducción
3a) Tipo «fotocopia». Una
parte va a blanco y otra a
negro.
3b) Simulación de grisados.
3c) Simulación de grisados.
Otros métodos.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
BAJAR A 16
COLORES
5
1
2
- 22
3
4
1
07-color-11.tif
2
07-color-12.tif
3
07-color-13.tif
4
07-color-14.tif
1) Utiliza una paleta
optimizada (lo más
parecida posible al
original)
2) Utiliza la paleta de 16
colores de Windows.
3) «Acercarse al color»
Colores planos
aproximados
4) Simula los colores con
puntos.
5) Mejora la calidad,
aunque en las pruebas no
encontramos diferencias
perceptibles.
No tiene mucho sentido
usar estas opciones en
imágenes de sólo 16
colores.
BAJAR A 256
COLORES
1
2
1
3
3
5
4
07-color-16.tif
2
07-color-17.tif
1) Utiliza una paleta
optimizada (los colores
más parecidos posibles a
los del original).
2) Utiliza la paleta de 256
colores standard de
Windows. Si se van a
usar una serie de gráficos
en una presentación, es
conveniente utilizar esta
opción, para que todos
los gráficos tengan la
misma paleta.
Los resultados son de
inferior calidad que la
primera opción.
3) Utiliza colores lo más
aproximados posibles al
original.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
4a
07-color-16.tif
Anexo Unidad 4: El beso de la princesa
4b
07-color-19.tif
No sólo de GIFs vive el hombre...
Cuando pensamos en archivos gráficos de 256 colores, inmediatamente lo asociamos con el formato GIF. Puede haber casos en que sea conveniente (u obligatorio) usar
otros formatos. Es muy común encontrar programas que
sólo admiten una limitada cantidad de formatos. Por ejemplo, BMP. No debemos olvidar que un BMP de 256 colores es tres veces más pequeño que el mismo gráfico con
16 millones. Y la calidad puede ser apenas inferior.
- 23
4) Además de lo anterior,
simula otros colores con
puntos.
4a) Con paleta optimizada
4b) Con paleta standard
Cuando se utiliza una
paleta standard
obligadamente (el caso
de muchos gráficos para
internet) esta opción es
muy conveniente:
comparemos el gráfico
(2) con el (4b)
5) Puede haber colores que
ocupen una porción muy
pequeña del gráfico o
fotografía, pero cuyo
papel sea muy
significativo.
En ese caso, para evitar
que la reducción los
elimine totalmente, se
selecciona (previamente)
el área que los contiene y
se tilda la opción boost.
Todo esto según el
manual. No obtuvimos
resultados visibles en las
pruebas.
BAJAR A 32.000 O
64.000 COLORES
1) Utiliza colores lo más
parecidos posibles al
original
2) Simula otros colores con
puntos.
Estas dos opciones no son de
uso habitual. La calidad es
casi idéntica a los gráficos de
24 bits (16.000.000 de
colores) y su tamaño algo
menor.
AUMENTAR LA
CANTIDAD DE
COLORES
Las opciones son sólo tres.
Ninguna tiene pantallas de
configuración, ya que sólo se
aumenta la capacidad de
tener más colores.
Los gráficos convertidos
tendrán, inmediatamente
después, el mismo aspecto
que antes del cambio.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
1) El gráfico en 1 bit (2
colores).
2) El gráfico convertido a 16
millones de colores (24
bits).
El aspecto es el mismo.
Pero se puede pintar,
aplicar filtros, etc.
3) Cuando se pasa a 256
colores, la paleta que
adopta es de escala de
grises. Se puede pintar en
cualquiera de los 256
tonos de gris, aplicar
filtros, etc.
2
1
- 24
para pruebas-ByN.tif
3
para pruebas-ByN-16m.tif
para pruebas-ByN-gris.tif
Convertir entre formatos
Los programas que utilizan gráficos, no reconocen cualquier formato de
las imágenes. Por ejemplo, Clic utiliza sólo gráficos en formatos GIF y BMP.
En Internet los gráficos pueden ser sólo JPG, GIF o PNG. De allí surge la
necesidad de la conversión entre formatos. Por ejemplo, transformar una
fotografía en formato JPG en BMP, para poder usarla en un proyecto con
Clic.
En algunas circunstancias, la necesidad de la conversión surge de las limitaciones técnicas de los formatos. No todos los formatos aceptan la aplicación de procedimientos y modificaciones que podemos necesitar. Por ejemplo, el formato GIF no acepta la aplicación de filtros (ningún gráfico indexado
lo hace).
En muchos programas gráficos, esta operación es tan sencilla como abrir
el gráfico original y guardarlo con el formato deseado. Lo único necesario es
establecer las características o variante del formato de destino, si es que las
tuviera.
GIMP lee y graba en una gran cantidad de formatos. Muchos más que los
que utilizamos habitualmente, y algunos realmente extravagantes.
PaintShopPro es, desde sus orígenes, un potente conversor entre formatos gráficos. PaintShopPro 4.14 lee 37 formatos gráficos diferentes, y puede
grabar en 28 formatos.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 25
Conversion de formatos en GIMP
Como digimos, la operación de conversión en GIMP es tan sencilla como
abrir el gráfico original y utilizando Guardar como... grabarlo con el formato
deseado.
1
En el menú Archivo del
gráfico a convertir, elegimos
la opción Guardar como...
2
1
3
4
2
1) Mantenemos o
cambiamos el nombre.
2) Si sabemos cuál es la
extensión del nuevo
formato, la escribimos.
GIMP lo reconoce.
3) Seleccionamos la carpeta
donde guardaremos el
gráfico convertido (o
dejamos la misma)
4) Abrimos la lista de
formatos (si no
cumplimos con el paso 2)
3
En la lista de formatos
seleccionamos el que
necesitamos.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
Formatos y extensiones reconocidos por GIMP
- 26
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 27
Conversión de formatos en PaintshopPro
La pantalla de guardar
como... (save as...) de PSP
4.14 es similar ala de
cualquier programa
windows.
1
2
3
5
4
1) Carpeta abierta
2) Nombre del archivo que
se guarda
3) Lista desplegable de tipos
de archivos. Muestra los
tipos principales. Las
variantes se seleccionan
con la lista desplegable
Sub Type (4) o el botón
Options (5).
4) Lista desplegable de subtipos de archivos Aparece
en el caso que existen
dichos subtipos).
5) Opciones de
configuración del
formato.
2
3
4
5
El botón Options... abre
una ventana de
configuración para varios
formatos, a la que también
se llega desde el menú File/
Preferencies/File Format
Preferences.
PARA EL
FORMATO GIF
1
2
3
4
5
Establece las zonas
transparentes del gráfico:
1) Mantiene la información
original de transparencia
que pueda tener el
archivo.
2) No guarda información
de transparencia
3) Establece como valor de
transparencia el color de
fondo del tintero de PSP.
4) Establece como color de
transparencia uno de los
colores de la paleta
5) Muestra las zonas
transparentes del
gráfico.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 28
FORMATO JPG
1) Resolución con que se
guarda el archivo.
2) Nivel de compresión (a
mayor nivel, menos
calidad del gráfico)
1
2
FORMATO KODAK
PHOTO CD
1) Tamaño del gráfico
1
FORMATO PCX
1) Resolución con que se
guarda el archivo.
1
FORMATO PNG
1
2
3
4
5
1) Mantiene la información
original de transparencia
que pueda tener el
archivo.
2) No guarda información
de transparencia
3) Establece como valor de
transparencia el color de
fondo del tintero de PSP.
4) Establece como color de
transparencia uno de los
colores de la paleta
5) Muestra las zonas
transparentes del gráfico.
FORMATO RAW
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 29
FORMATO TIF
1) Resolución con que se
guarda el archivo.
1
FORMATO WPG
1) Resolución con que se
guarda el archivo.
1
FORMATO WMF
No sólo para guardar sino
para abrir.
1) Pregunta en qué tamaño
se debe abrir el archivo.
2) Usa la info del header
(imagen de pantalla) para
abrir el archivo.
3) Tamaño que usará si está
activa la opción anterior,
y el gráfico no tuviera
info de header.
1
2
3
Los formatos vectoriales en PSP
PaintShop Pro asegura que abre varios formatos vectoriales (ver págs. siguientes). Esto
no resulta cierto completamente, ya que depende del tipo de información que contengan
esos gráficos. Al mismo tiempo, debemos tener en cuenta que PSP 4.13 es un programa que
ya tiene sus años, por lo que, seguramente, los archivos CDR (por ejemplo) que puede abrir
se refieren a la versión de Corel vigente en ese momento (los archivos CDR no son iguales en
cada versión de Corel).
En realidad, PSP no abre archivos vectoriales. Lo que hace es convertirlos a imágenes pixeladas. Esto puede resultar útil en ocasiones. Las imágenes pueden editarse como
pixeladas, pero los objetos desaparecen, la resolución de impresión pasa a ser fija, etc.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 30
FORMATOS GRAFICOS BASADOS EN PIXELS
SOPORTADOS POR PAINT SHOP PRO 4.14
= Paint Shop Pro puede abrir archivos / = Paint Shop Pro puede guardar archivos
Formato Sub-Formato
Origen/Norma
Bits por Pixel y tipo de color
Descripción
1
4
8
8
16
24
32
Grey Color
BMP
BMP
BMP
CLP
CLP
CUT
DIB
DIB
DIB
EPS
GIF
GIF
GIF
GIF
IFF
IFF
IMG
IMG
JIF
JPG
JPG
LBM
LBM
MAC
MAC
MSP
MSP
PBM
PCD
PCT
PCX
PCX
PCX
PCX
PGM
PIC
PNG
PPM
PSD
RAS
RAW
RLE
RLE
RGB encoded
RGB encoded
RLE encoded
Bitmap
Device Independent Bitmap
RGB encoded
RGB encoded
RLE encoded
Image only
Ver. 87a (interlaced)
Ver. 87a (non-interlaced)
Ver. 89a (interlaced)
Ver. 89a (non-interlaced)
Compressed
Uncompressed
Old Style
New Style
Huffman compressed
Huffman compressed
Progressive
Compressed
Uncompressed
With header
Without header
New version
Old version
Portable Bitmap
Macintosh PICT format
Version 0
Ver. 2 (with palette info.)
Ver. 3 (without palette info.)
Version 5
Portable Graymap
Portable Network Graphics
Portable Pixelmap
RGB or indexed
Type 1 (Modern Style)
Un-encoded pixel data
CompuServe
Windows
OS/2
Microsoft Windows
Microsoft Windows
Windows Clipboard
Windows Clipboard
Dr. Halo
OS/2
Microsoft Windows
Microsoft Windows
Adobe
CompuServe
CompuServe
CompuServe
CompuServe
Electronic Arts
Electronic Arts
GEM Paint
GEM Paint
Joint Photo. Expert Group
Joint Photo. Expert Group
Joint Photo. Expert Group
Deluxe Paint
Deluxe Paint
MacPaint
MacPaint
Microsoft Paint
Microsoft Paint
UNIX
Kodak Photo CD
Apple
ZSoft Paintbrush
ZSoft Paintbrush
ZSoft Paintbrush
ZSoft Paintbrush
UNIX
Pictor/PC Paint
UNIX
Photoshop
Sun Microsystems
CompuServe
Microsoft Windows
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 31
FORMATOS GRAFICOS BASADOS EN PIXELS
SOPORTADOS POR PAINT SHOP PRO 4.14
= Paint Shop Pro puede abrir archivos / = Paint Shop Pro puede guardar archivos
Formato Sub-Formato
Origen / Norma
Bits por Pixel y tipo de color
Descripción
1
4
8
8
16
24
32
Grey Color
TGA
TGA
TIFF
TIFF
TIFF
TIFF
TIFF
TIFF
WPG
WPG
WPG
No compression
Compressed
Huffman compressed
No compression
Pack bits compressed
LZW compressed
Fax Group 3 compressed
Fax Group 4 compressed
Version 5.0
Version 5.1
Version 6.0
Truevision
Truevision
Aldus Corporation
Aldus Corporation
Aldus Corporation
Aldus Corporation
Aldus Corporation
Aldus Corporation
WordPerfect
WordPerfect
WordPerfect
FORMATOS GRAFICOS VECTORIALES
SOPORTADOS POR PAINT SHOP PRO 4.14
Formato
Origen / Norma
CDR
CGM
DRW
DXF
GEM
HGL
PCT
PIC
WMF
WPG
CorelDRAW!
Computer Graphics Metafile
Micrografx Draw
Autodesk
Ventura/GEM
Hewlett-Packard Graphics Language
Apple
Lotus Development Corp.
Microsoft Windows Metafile
WordPerfect
Can open files of this format
Can save files to this format, the files contain raster data only.
Abre / Guarda
PSP: el formato propietario de PaintShopPro
Se llaman «formatos propietarios» a aquellos que son «de uso exclusivo» de un programa. Por ejemplo, los archivos *.cdr son del formato propietario de CorelDraw. A partir de la
versión 5, PaintShopPro posee el suyo, llamado PSP (PaintShop Pro Image). Es el que aparece preselecionado cuando se abre la pantalla de Save as... (Guardar como...). Salvo que se
piense trabajar luego en PaintShopPro sobre ese archivo, conviene guardar el trabajo en
formatos que puedan ser leídos y cargados por otras aplicaciones, como el TIF, BMP, PCX,
JPG o GIF.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 32
«Batch» conversión
Si bien abrir varios archivos y guardarlos con otro formato no es una
tarea que mate a nadie, los programadores de Jasc, la empresa autora de
PSP, desarrollaron una opción de hacer esa conversión automáticamente.
Esto es muy útil cuando se preparan paquetes de gráficos para Internet o
multimedia.
PaintShop Pro fue
adquirido hace poco por
Corel Inc
1
Se accede a la utilidad de
conversión de conjuntos de
archivos, desde el menú
File/Batch Conversion...
2
1
2
10
3
4
5
6
8
7
9
Los archivos originales quedan
como estaban. El programa crea
nuevos archivos, con idéntico
nombre, y la extensión
correspondiente al nuevo
formato.
La pantalla de conversión:
1) Carpeta donde se
encuentran los gráficos
que deseamos convertir.
2) Lista de todos los gráficos
que hay en la carpeta.
3) Archivos que se van a
convertir. Puede hacerse
la lista de dos maneras:
a) Seleccionando en la
ventana (2) los archivos.
b) usando comodines
para indicar todos los
archivos de determinada
extensión. Por ejemplo:
*.tif, seleccionará a todos
los archivos de formato
TIF.
4) Permite decidir qué tipo
de archivos se verán en la
ventana (2). Util cuando
los gráficos están
mezclados con otros tipos
de archivos.
5) Selecciona todos los
archivos que hay en la
carpeta.
6) Se elige el formato de
archivo de salida.
7) Se elige el subtipo del
formato, si hubiera.
8) Se cambian las opciones
del formato, si tiene.
Estas opciones son las
mismas que vimos en las
páginas anteriores.
9) Para elegir la carpeta
donde se guardarán los
archivos convertidos
10) Para ordenar el comienzo
de la operación.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 33
3
Pantalla que muestra el
avance de la conversión.
1) Mensaje de trabajo
concluido
2) Permite guardar las
características de la
conversión (seteos).
3) Botón para interrumpir el
proceso de conversión.
4) Cierra la ventana.
1
4
3
2
Más automatización
Jasc, la empresa ex-propietaria de PaintShop Pro, tiene (tuvo...) un pequeño programita que automatiza, no sólo la conversión entre formatos, sino
también muchas otras de las acciones que pueden realizarse a un gráfico. Se
puede bajar de Internet, de la web de Jasc y varios otros sitios.
1
El programa se llama Jasc
BatchMaster.
2
Cuando arranca presenta
una placa recordando que
se trata de un programa
shareware. Se continúa con
el botón Start...
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
3
Anexo Unidad 4: El beso de la princesa
PANTALLA PRINCIPAL DE JASC BATCHMASTER
1
1
3
4
5
2
6
7
10
9
8
La pantalla principal sirve para
configurar las acciones o comandos que
se aplicarán.
1) Lista de comandos disponibles. Allí
se seleccionan los comandos. de a
uno.
2) Botón para agregar los comandos
seleccionados al script (lista de
comandos a aplicar) que determiná
qué se hará.
Cada comando, al agregarse,
muestra su ventana de
configuración, si la posee.
3) Delete. Borra los comandos
seleccionados de la ventana del
script (2)
4) Las acciones se producen
secuencialmente, de arriba a abajo.
Algunas acciones es necesario
producirlas antes que otras. Los
botones Move Up y Move Down
permiten cambiar el orden de la
lista de comandos.
5) Edit. Abre la ventana de
configuración del comandos
seleccionado en la ventana del
script.
6) Ejecutar comando.
7) Probar el script.
8) Muestra la configuración del
comando seleccionado de la
ventana del script.
9) Imagen de prueba
10) Comenzar proceso... En realidad
pasa a la ventana siguiente.
- 34
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
Anexo Unidad 4: El beso de la princesa
- 35
3
1
2
3
7
4
5
6
La segunda pantalla sirve
para seleccionar los archivos
a los que se les aplicarán los
comandos definidos en la
pantalla anterior..
1) Carpeta seleccionada
2) Lista de archivos
existentes en la carpeta.
3) Lista de archivos
seleccionados. Se pueden
elegir de la lista o usar
comodines.
4) Lista desplegable de tipos
de archivo que muestra la
ventana (2)
5) Botón de seleccionar
todos los archivos que
hay en la carpeta.
6) Si está tildada se detiene
y muestra un mensaje de
error cuando lo hay.
7) Pasar al siguiente paso.
4
1
2
6
3
4
5
La tercera pantalla sirve para
seleccionar la carpeta de
destino y el formato gráfico
de los archivos a los que se
les aplicarán los comandos
establecidos.
1) Carpeta seleccionada
2) Lista de archivos
existentes en la carpeta.
3) Lista desplegable de
formatos gráficos de
salida. Si no se desea
modificar el formato, hay
que elegir el mismo que
el de origen.
4) Subtipo de formato
gráfico.
5) Opciones del formato.
6) Terminar. Comienza el
proceso de aplicación de
los comandos.
Blaze Media converter
Otro programa conversor
que automatiza las acciones
es Blaze MediaConvert.
Entre sus varias funciones
está la de convertir entre
formatos gráficos.
Se convoca con el botón
Image de la interface
general, de diseño nada
convencional.
Gabriela y Juan Carlos Asinsten
Virtual Educa
01 - LLaa comunicación en entornos virtuales
1
2
Anexo Unidad 4: El beso de la princesa
9
3
4
5
6
7
8
...Y colorín, colorado,
el cuento de la princesa
ha terminado.
E
- 36
Pantalla de conversión de
formatos.
1) Cargar archivos a
convertir.
2) Eliminar de la lista de
archivos a convertir los
seleccionados en la
ventana 3.
3) Ventana con la lista de
archivos a convertir.
4) Lista desplegable de
formatos de archivo de
destino.
5) Calidad de compresión si
se elige como salida el
formato JPG.
6) Profundidad de color.
7) Si está tildada usa la
misma carpeta de origen
para los nuevos archivos
convertidos.
8) Si está tildada, borra los
archivos de origen
después de haberlos
convertido.
9) Botón: convertir.

Documentos relacionados