PROGRAMACIÓN EN VISUAL FoxPro

Comentarios

Transcripción

PROGRAMACIÓN EN VISUAL FoxPro
E.M.P 3º S.
PROGRAMACIÓN
En la definición de campos se introduce el
nombre del campo, el tipo de dato, el tamaño,
decimales permitidos y el índice. El índice es
una serie de punteros o indicadores ordenados
lógicamente por los valores de una clave. Los
índices ofrecen acceso rápido a datos y pueden
exigir datos únicos en las filas de una tabla. Los
índices de Visual FoxPro se mantienen en un
archivo de índice. Puedes agregar un índice
ascendente o descendente.
El formato es la forma en que se muestra
el campo, un formato proporciona una máscara
de salida que determina la manera en que se
presenta el valor de un campo en un formulario,
una ventana Examinar o un informe.
Una máscara de entrada, define la
puntuación, el espacio y otros atributos de
formato de valores que se introducen en el
campo. Los valores se almacenan de una
forma uniforme, así puedes reducir
los errores de entrada de datos,
haciendo que se procesen de
forma más eficaz. Por ejemplo, al
agregar una máscara a un campo
numérico que almacena números
de teléfono ayuda al usuario a
rellenar rápidamente el campo
porque la puntuación y los espacios
ya los proporciona la máscara, o
por ejemplo los puntos de los miles
en el número de cédula.
Semana 05
mensaje, el cual aparecerá cuando hace efecto
la regla de validación.
Crear programas
Crear un índice
1. En el Administrador de proyectos,
selecciona la tabla a la que quieres agregar un
índice y, a continuación, selecciona Modificar.
2. En el Diseñador de tablas, selecciona la
opción Índices.
3. En el cuadro Nombre, Escribe un nombre
para el índice.
4. En la lista Tipo, selecciona un tipo de
índice.
Un programa de Visual FoxPro es un
archivo de texto que contiene una serie de
comandos. Los comandos se pueden utilizar
en un programa o en la ventana de comandos.
Puedes crear un programa en Visual FoxPro de
la siguiente manera:
• En el Administrador de proyectos,
selecciona Programas en la opción Código.
• Selecciona Nuevo.
O también
• En el menú Archivo, selecciona Nuevo.
• En el cuadro de diálogo Nuevo, selecciona
Programa.
• Selecciona Nuevo archivo.
Otra forma podría ser
• En la ventana Comandos, Escribe:
MODIFY COMMAND.
Visual FoxPro abrirá una nueva ventana
denominada Programa1. Podrás entonces
escribir tu programa en esta ventana.
Una vez creado un programa, asegúrate de
guardarlo de la siguiente manera:
• En el menú Archivo, selecciona Guardar.
Puedes elegir entre cuatro tipos de índices:
•
Principal
•
Candidato
•
Normal
•
Único
Si intentas cerrar un programa sin antes
guardarlo, aparecerá un cuadro de diálogo que
te preguntará si deseas guardar o descartar los
cambios realizados en el mismo.
Si guardas un programa creado a partir del
20
E.M.P 3º S.
PROGRAMACIÓN
EN VISUAL FoxPro
Puedes incorporar un valor por defecto en
el campo a través del Valor predeterminado,
siempre considerando el tipo de dato del
campo.
El Título es un texto que puede
aclarar o mejorar el encabezado
predeterminado del campo.
Las reglas de validación permiten controlar los datos introducidos
en los campos y registros de las
tablas de base de datos. Las reglas a nivel de
campo y a nivel de registro, comparan los valores introducidos con expresiones definidas previamente. Si el valor introducido no satisface los
requisitos de la regla, se rechazará el valor. Las
reglas de validación sólo pueden darse para las
tablas de base de datos. Es posible introducir un
PROGRAMACIÓN
Semana 14
67
Administrador de proyectos, el programa se
agregará al proyecto.
Si intentas guardar un programa al que
todavía no has asignado un nombre, se abrirá
el cuadro de diálogo Guardar como, en el que
podrás especificar el nombre del programa.
Después de guardar el programa, podrás
ejecutarlo o modificarlo. En primer lugar, abre el
programa de la siguiente manera:
Si el programa forma parte de un proyecto,
selecciónalo en el Administrador de proyectos y
señala Modificar.
O bien
En el menú Archivo, selecciona Abrir.
Aparecerá un cuadro de diálogo que muestra
una lista de los archivos disponibles. En la lista
Archivos de tipo, selecciona Programa. En la
lista de archivos, indica el programa que deseas
modificar y selecciona Abrir.
También lo puedes hacer
En la ventana Comandos, Escribe el nombre
del programa que deseas modificar:
MODIFY COMMAND miprograma
O bien
En la ventana Comandos, Escribe:
MODIFY COMMAND ?
Cuando aparezca la lista de archivos,
selecciona el programa que deseas modificar y
a continuación selecciona Abrir.
E.M.P 3º S.
PROGRAMACIÓN
Después de abrir el programa, podrás
realizar cambios en el mismo. Cuando hayas
terminado de introducir los cambios, asegúrate
de guardar el programa.
Luego de crear un programa, podrás
ejecutarlo.
Si el programa forma parte de un proyecto,
Selecciónalo en el Administrador de proyectos y
señala Ejecutar.
O bien, en el menú Programa, selecciona
Ejecutar. Cuando aparezca la lista de programas,
selecciona el programa que desea ejecutar y a
continuación selecciona Ejecutar.
También en la ventana Comandos, Escribe
DO y el nombre del programa que desea
ejecutar.
Conceptos básicos de programación
Cuando programamos, se almacenan
y manipulan datos mediante una serie de
instrucciones. Los datos y los contenedores en
los que se almacenan los datos constituyen
la materia prima de la programación. Las
herramientas utilizadas para manipular esta
materia prima son comandos, funciones y
operadores.
Los datos con los que trabajas
probablemente incluyen períodos de tiempo,
dinero y elementos contables, así como fechas,
nombres, descripciones. Cada dato corresponde
a un determinado tipo, es decir, pertenece a una
categoría de datos que se manipula de manera
similar. Visual FoxPro aporta numerosos
contenedores de almacenamiento con el fin de
ampliar su capacidad para manipular fácilmente
los datos.
Semana 14
Semana 05
caracteres. Puedes imprimir caracteres en
mayúsculas, pero no puedes imprimir números
en mayúsculas. Al principio de este módulo
tienes información detallada sobre los tipos de
datos, revísalo cuando tengas dudas.
Los contenedores de datos te permiten
realizar las mismas operaciones con varios datos.
Por ejemplo, sumar las horas que ha trabajado
un empleado, multiplicarlas por el salario por
hora y restar los impuestos para determinar el
sueldo que ha percibido el empleado. Deberás
realizar estas operaciones para cada empleado
y para cada período de pago. Si almacenas
esta información en contenedores y realizas las
operaciones sobre éstos, bastará con sustituir
los datos antiguos por los nuevos datos y volver
a ejecutar el mismo programa. Los contenedores
que maneja Visual FoxPro son los registros,
matrices y variables.
Los operadores se utilizan para vincular
los datos, clasificados en numéricos, lógicos,
de carácter y relacionales. Al principio de este
módulo hay información detallada sobre los
operadores.
PROGRAMACIÓN
E.M.P 3º S.
TABLAS, ÍNDICES
Y DESENCADENANTES
Crear tablas
Puedes crear una tabla en una base de datos o una tabla libre que no esté asociada a ninguna base
de datos. A medida que creas la tabla puedes crear nombres largos de tabla y de campo, y aprovechar
las posibilidades del diccionario de datos para tablas de base de datos, nombres largos de campo,
valores de campo predeterminados, reglas a nivel de campo y a nivel de registro, y desencadenantes.
Las tablas de Visual FoxPro, o archivos .dbf, pueden existir en dos estados: como tabla de base de
datos (una tabla asociada a una base de datos) o como una tabla libre no asociada a ninguna base de
datos. Las tablas asociadas a una base de datos cuentan con ciertas ventajas sobre las tablas libres.
En el Administrador de proyectos selecciona la página Datos, luego la base de datos, selecciona
Tablas y, a continuación, Nuevo para abrir el Diseñador de tablas.
También con el diseñador de base de datos activo puedes seleccionar en la barra de herramientas
de Base de datos la opción Nueva Tabla.
Tipos de
datos
Comandos de Visual FoxPro
Definición de
Un comando hace que se realice una
determinada acción. Cada comando dispone de
una sintaxis específica que indica lo que debes
incluir con el fin que se ejecute correctamente
el comando. Hay también cláusulas opcionales
asociadas a los comandos que permiten
especificar de forma más detallada la acción
que se deseas realizar.
campos
Definición del
formato de entrada
Por ejemplo, el comando USE permite abrir
y cerrar tablas:
Los tipos de datos determinan la manera en
que se almacenan los datos y la forma en que
se pueden utilizar tales datos. Puedes multiplicar
dos números, pero no puedes multiplicar
Definición de reglas
de validación de los
campos
68
19
E.M.P 3º S.
PROGRAMACIÓN
Semana 04
Cuando crees una nueva base de datos aparecerá una ventana Diseñador de bases de datos vacía
junto con la barra de herramientas Diseñador de bases de datos.
PROGRAMACIÓN
Semana 14
Sintaxis de USE
USE
Descripción
(sin indicar un nombre de tabla)
USE Clientes
USE Clientes IN 0
USE Clientes IN 0 ;
ALIAS miCliente
E.M.P 3º S.
Cierra la tabla que aparece en el área de trabajo actual.
Abre la tabla Clientes en el área de trabajo actual y cierra cualquier tabla que ya esté
abierta en el área de trabajo.
Abre la tabla Clientes en la siguiente área de trabajo disponible.
Abre la tabla Clientes en la siguiente área de trabajo disponible y asigna al área de
trabajo el alias miCliente.
A continuación se muestran algunos comandos utilizados
Comando
DELETE
REPLACE
GO
GO TOP
GO BOTTOM
SET DEFAULT TO Ruta
CLEAR
DIR
La barra de herramientas de Base de datos contiene las siguientes opciones.
SET DATE TO
QUIT
CANCEL
OPEN DATABASE
CLOSE DATABASE
CLOSE TABLES
APPEND BLANK
Agregar
Tabla
Nueva
Tabla
Eliminar
Tabla
Nueva Vista
Remota
DELETE
Nueva
Vista Local
Modificar
Tabla
RECALL
PACK
ZAP
SKIP
Administrador
de Proyectos
Conexiones
SELECT
Examinar
Tabla
SELECT
Crea una base de datos denominada Datos de Control dentro del proyecto “Control de
estudiante”.
18
USE
SET ORDER TO
69
Descripción
Selecciona registros especificados de una tabla para su eliminación.
Sustituye el valor almacenado en el campo del registro por un nuevo valor.
Coloca el apuntador de registro en una posición específica de la tabla, ejemplo: GO 20
Ir al primer registro de la tabla.
Ir al último registro de la tabla.
Cambiar de directorio de trabajo, ejemplo:
SET DEFAULT TO C: \Sistemas\Clientes
Limpiar la pantalla
Mostrar los archivos del directorio, ejemplo:
DIR C: \Sistemas\Clientes
Cambiar el formato de fecha.
Salir de Visual FoxPro
Cancelar la ejecución de un programa
Abrir base de datos, ejemplo OPEN DATABASE Ventas
Cerrar base de datos
Cerrar todas las tablas
Agregar un registro en blanco
Eliminar registros, ejemplo:
DELETE ALL, borrar todos.
Recuperar registros marcados como borrados, ejemplo:
RECALL ALL, recuperar todos.
Eliminar registros marcados como borrados.
Eliminar todos los registros sin poder recuperarlos.
Brincar o saltar registros.
Cambiar de área de trabajo, ejemplo:
SELECT Clientes
Abrir una o varias tablas, ejemplo:
SELECT A
USE Clientes
SELECT B
USE Ventas
Establecer el índice de trabajo.
E.M.P 3º S.
SET FILTER TO
LOCATE FOR
SEEK
BROWSE
LIST
MODIFY STRUC
DISPLAY STRUC
MODIFY REPORT
REPORT FORM…TO
PRINT
REPORT FORM…
PREVIEW
PROGRAMACIÓN
Semana 14
PROGRAMACIÓN
Semana 04
E.M.P 3º S.
Crear una base de datos con el Asistente para bases de datos
Establecer filtros de condición, ejemplo:
SET FILTER TO Sueldo>405000
Buscar información sin índice activo, ejemplo:
1. En el Administrador de proyectos, selecciona la opción Datos y, a continuación, selecciona
Bases de datos.
LOCATE FOR Empleado = “10.598.852”
Buscar información con índice activo, ejemplo:
2. Selecciona Nuevo.
SEEK 32564
Examinar la información, ejemplo:
3. Selecciona el botón Asistente para bases de datos.
USE Empleado
4. Sigue las instrucciones que aparecen en la pantalla del asistente.
BROWSE
Listar registros en pantalla
Modificar estructura de una tabla
Desplegar en pantalla la estructura de una tabla
Modificar un reporte, ejemplo:
También puedes tener acceso al asistente para bases de datos desde el menú si eliges Nuevo en
el menú Archivo, selecciona Base de datos y, a continuación, selecciona la opción Asistente para bases
de datos.
MODIFY REPORT Productos
Imprimir reporte, ejemplo:
El asistente proporciona plantillas para tablas y
vistas, índices, claves principales y relaciones que
puedes elegir o modificar.
REPORT FORM Productos TO PRINT
Ver reporte en vista preliminar, ejemplo:
REPORT FORM Productos PREVIEW
Muestra las opciones de impresión antes de imprimir, ejemplo: REPORT FORM Productos
REPORT FORM…PROMPT
PROMPT
Instrucciones de control
Bucles
Un bucle te permite ejecutar una o más líneas
de código tantas veces como sea necesario. En
Visual FoxPro hay tres comandos que permiten
realizar bucles:
SCAN ... ENDSCAN
FOR ... ENDFOR
DO WHILE ... ENDDO
SCAN
Utiliza SCAN cuando realizas una serie de
acciones para cada uno de los registros de una
tabla. El bucle SCAN permite escribir el código
una vez y ejecutarlo para cada registro a medida
que el puntero de registro se desplaza por la
tabla.
Ejemplo:
SCAN FOR UPPER(Ciudad) = ‘CARACAS’
? Contacto, Compañía, Ciudad
ENDSCAN
FOR
Crear una nueva base de datos
1. En el Administrador
selecciona Bases de datos.
de
proyectos,
2. Selecciona Nuevo.
Utiliza FOR cuando sepas cuántas veces
debes ejecutar la sección de código.
Luego deberás colocar un nombre a la base de datos cuando aparezca la siguiente ventana.
Ejemplo:
FOR Contador = 1 TO 10
Instrucciones a procesar
NEXT Contador
ENDFOR
DO WHILE
Utiliza DO WHILE cuando desees ejecutar
una sección de código mientras cumpla una
determinada condición. Tal vez no sepas
cuántas veces debe ejecutarse el código, pero
sí sabes cuándo debe detenerse la ejecución.
Por ejemplo, supongamos que dispones de
una tabla en la que figuran los nombres y las
iniciales de una serie de personas y deseas
utilizar las iniciales para consultar los nombres
de las personas. Surgiría un problema la primera
vez que intentes agregar una persona cuyas
iniciales fuesen las mismas que las de otras
70
17
E.M.P 3º S.
PROGRAMACIÓN
Semana 04
BASE DE DATOS Y TABLAS
Las bases de datos son conjuntos
o contenedores de tablas, normalmente
relacionadas entre sí mediante campos
comunes. Como soporte para las tablas y las
relaciones, también puedes incluir en la base
de datos vistas, conexiones, procedimientos
almacenados,
reglas
de
negocios
y
desencadenantes. Las bases de datos se crean
con el Diseñador de bases de datos. Se guarda
con extensión DBC.
encabezados en ventanas Examinar y en
columnas de cuadrícula.
• Valores predeterminados en campos.
• La clase de control predeterminada usada
en formularios.
• Máscaras de entrada y formatos de
presentación para campos.
• Claves principales y candidatas.
• Relaciones persistentes entre tablas de
bases de datos.
• Nombres largos para tablas y campos.
PROGRAMACIÓN
personas contenida en la tabla. Para resolver
este problema, podrías agregar un número a las
iniciales. Por ejemplo, el código de identificación
de Miguel Suárez podría ser MS. La siguiente
persona cuyas iniciales fuesen las mismas,
Margarita Sánchez, sería MS1. Si a continuación
agregas María Sanz a la tabla, su código de
identificación sería MS2. Un bucle DO WHILE Te
permite localizar el número correcto que debes
adjuntar a las iniciales.
En el ejemplo siguiente se calcula el número
total de productos en existencias cuyo precio
supera los 2000 Bolívares en el bucle DO
E.M.P 3º S.
WHILE hasta llegar al final del archivo (EOF). Se
sale del bucle DO WHILE y se muestra el total.
DO WHILE .T. && Comienza el bucle.
IF EOF( )
EXIT
ENDIF
IF precio_unidad < 2000
SKIP
LOOP
ENDIF
StockTot = StockTot + en_existencias
SKIP
ENDDO
&& Termina el bucle.
• Reglas a nivel de campo y reglas a nivel
de registro.
Al crear una base de datos, reúnes tablas en
un conjunto y aprovechas las características de
diccionario de datos.
Un diccionario de datos proporciona mayor
flexibilidad al diseñar y modificar la base de datos
y te ahorra tener que escribir código para crear
validación a nivel de campos y a nivel de filas o
para asegurar la unicidad de valores en campos
de clave principal. El diccionario de datos de
Visual FoxPro te permite crear o especificar:
Semana 14
• Desencadenantes.
• Procedimientos almacenados.
1. Crea una instrucción de control de la ventana de comandos, donde sume un valor hasta 5
veces.
• Conexiones a orígenes de datos remotos.
• Vistas locales y remotas.
• Comentarios para cada campo, tabla y
base de datos.
Algunas características del diccionario
de datos, como nombres de campos largos,
claves principales y candidatas, valores
predeterminados, reglas a nivel de campo
y a nivel de registro y desencadenantes se
almacenan en el archivo .dbc, pero se crean
como parte del proceso de generación de una
tabla o una vista.
• Títulos de campos que aparecen como
Condicional
Tenemos dos instrucciones verdaderamente importantes al momento de ejecutar una condición, la
instrucción IF y la instrucción DO CASE.
DECISIONES /
CONDICIONALES
Recordando la célebre canción
de Rubén Blades, “Decisiones”, las
instrucciones condicionales sirven
para tomar “Decisiones” sobre una
o varias preguntas, y determinarán
una acción en el programa.
BASE DE DATOS
Conjunto o contenedores de tablas que guardan
gran cantidad de información de una manera ordenada.
Su acceso y consulta se realiza de una forma rápida y
práctica.
16
71
E.M.P 3º S.
PROGRAMACIÓN
IF
Semana 14
DO CASE
Ejecuta condicionalmente un conjunto de
comandos dependiendo del resultado de una
expresión lógica.
Ejemplo:
Pregunta por varios posibles valores para
una variable o campo, sustituye el uso continuo
de IF THEN.
DO CASE
CASE Edad<12
WAIT WINDOW “Alumno menor de edad”
CASE Edad>12 .and. Edad<18
WAIT WINDOW “Alumno adolescente”
CASE Edad>18
WAIT WINDOW “Alumno adulto”
ENDCASE
2. A modo de lecturas complementarias; lee temas relacionados con lógica de programación
y el uso de condiciones y controles.
Para agregar comentarios dentro de un
programa, se coloca un asterisco (*) antes del
texto informativo o se coloca && antes del texto
informativo.
*Abrir la base de datos
OPEN DATABASE Cliente
de datos Clientes
Usar
procedimientos
definidas por el usuario.
El Administrador de proyectos permite compilar la aplicación completa. En la fase de programación
de la aplicación, el Administrador de proyectos facilita el diseño, la modificación y la ejecución de los
componentes individuales de su aplicación.
• Modificar y ejecutar partes de tu aplicación (formularios, menús, programas) con tan sólo
algunos clics.
• Arrastrar clases, tablas y campos desde el Administrador de proyectos hasta el Diseñador de
formularios o el Diseñador de clases.
• Arrastrar clases entre bibliotecas de clases.
• Ver y modificar fácilmente sus tablas y bases de datos.
• Agregar descripciones para los componentes de la aplicación.
• Arrastrar y colocar elementos entre proyectos.
sola vez, no varias veces como ocurre en un
programa.
Ejemplo de procedimiento:
PROCEDURE miproceso
* En esta área puedes incluir el Código
ejecutable de procesos frecuentes “ENDPROC”
Ejemplo:
&& Abrir base
y
funciones
Las actividades repetitivas o recurrentes
pueden generar gran cantidad de códigos, los
procedimientos y funciones permiten mantener
en un único lugar el código que utilizas con
frecuencia y llamarlo a través de su aplicación
siempre que lo necesites. Esto hace que tu
código sea más fácil de leer y mantener, ya que
en un procedimiento el cambio se realiza una
E.M.P 3º S.
Con el Administrador de proyectos, podrás:
1. Crea una instrucción condicional en la ventana de comandos, donde compare dos valores e
indique el valor mayor.
Comentarios
PROGRAMACIÓN
La siguiente figura muestra el administrador de proyectos:
Ejemplo:
IF Edad < 18 THEN
WAIT WINDOW “Alumno menor de
edad”
ELSE
WAIT WINDOW “Alumno mayor de
edad”
ENDIF
Semana 03
Tradicionalmente, los procedimientos contienen código que escribes para realizar una
operación, así como funciones que calculan y
devuelven un valor. En Visual FoxPro, las funciones son similares a los procedimientos:
Ejemplo de función:
FUNCTION mifunción
* Esto es un comentario, pero podría ser
código ejecutable “ENDFUNC”
Crea un nuevo proyecto denominado “Control Estudiante”.
Puedes incluir procedimientos y funciones
en un archivo de programa distinto o al final
de un archivo de programa que contenga
72
15
E.M.P 3º S.
PROGRAMACIÓN
Semana 03
Usar el Administrador de Proyectos
Un proyecto es un conjunto de formularios, menús, informes, vistas, base de datos que forman
parte del sistema que estás desarrollando, este conjunto de objetos se guardan como un archivo con
extensión “pjx”
La siguiente figura muestra la ventana principal o entorno de desarrollo de Visual FoxPro:
ipal
Princ
Menú isual
de V o
r
FoxP
Semana 14
PROGRAMACIÓN
código normal de programa. En un archivo de
programa, no puedes tener código ejecutable de
programa a continuación de los procedimientos
y las funciones.
Si incluyes tus procedimientos y funciones
en un archivo de programa distinto, podrás hacer
accesibles estos procedimientos y funciones
desde tu programa si utilizas el comando SET
PROCEDURE TO. Por ejemplo:
Para un archivo llamado PROCESO.PRG,
utiliza el siguiente comando en la ventana
Comandos:
SET PROCEDURE TO proceso.prg
Hay dos formas de llamar a un procedimiento
o a una función en los programas:
Utilizar el comando DO. Por ejemplo:
ador
inistr
Adm yectos
o
r
P
de
DO miproc
na de
Venta dos
an
Com
O bien
Incluir después del nombre de la función un
par de paréntesis. Por ejemplo:
La ventana de comandos sirve para manipular comandos de forma interactiva, para efectuar tareas
de revisión o mantenimiento, representa una gran ventaja ya que permite hacer más fluida las tareas de
revisión o mantenimiento. Si no se encuentra visible se puede activar con las teclas “Control + F2”.
Como la ventana Comandos es una ventana de edición, puedes modificar comandos con las
herramientas disponibles en Visual FoxPro. Puedes modificar, insertar, eliminar, cortar, copiar o pegar
texto en la ventana Comandos.
La ventaja de escribir código en la ventana Comandos radica en el hecho de que las instrucciones
se ejecutan de inmediato. No es necesario guardar un archivo y ejecutarlo como un programa.
Además, las opciones que eliges en los menús y los cuadros de diálogo aparecen en la ventana
Comandos como comandos. Puedes copiar y pegar estos comandos en un programa de Visual FoxPro
y a continuación ejecutar el programa repetidamente, lo cual facilita la ejecución de miles de comandos,
una y otra vez.
mifunción( )
Cada uno de estos métodos puede
ampliarse enviando o recibiendo valores desde
el procedimiento o la función.
Para enviar valores a procedimientos o
funciones, se incluyen parámetros. Por ejemplo,
el procedimiento siguiente acepta un solo
parámetro:
PROCEDURE miproc (cString)
* La línea siguiente muestra un mensaje
MESSAGEBOX (“miproc” + cString)
ENDPROC
Los parámetros funcionan de manera
idéntica en una función. Para enviar un valor
como un parámetro de este procedimiento o a
14
73
E.M.P 3º S.
una función, podrías utilizar una cadena o una
variable que contenga una cadena, como se
muestra en los siguientes ejemplos:
Ejemplo1: DO miproc WITH cTestString
Ejemplo2: DO miproc WITH “cadena
de datos”
Ejemplo3:
datos”)
mifunción(“cadena
de
Ejemplo4:mifunción(cTestString)
Puedes enviar múltiples valores a un
procedimiento o función si los separa mediante
comas. Por ejemplo, el siguiente procedimiento
espera tres parámetros: una fecha, una cadena
de caracteres y un número.
PROCEDURE miproc (dDate, cString,
nTimesToPrint)
FOR nCnt = 1 to nTimesToPrint
? DTOC(dDate) + “ “ + cString
+ “ “ + STR(nCnt)
ENDFOR
ENDPROC
Podrías llamar a este procedimiento
mediante la siguiente línea de código:
DO miproc WITH DATE(), “Hola”, 10
Variables
Una variable es una ubicación en la memoria
del computador donde se almacenan los datos.
Puedes cambiar el contenido de una variable,
pero su nombre y su área de almacenamiento
están reservados hasta que termines la sesión
de Visual FoxPro o liberes la variable. Las
variables y sus valores se pierden a menos que
las guardes antes de salir de Visual FoxPro. Las
variables se usan con el fin de guardar valores
de forma temporal. Estos valores pueden variar
a lo largo del funcionamiento del programa.
E.M.P 3º S.
Semana 14
PROGRAMACIÓN
Al crear una variable debes usar una
palabra clave según su uso (LOCAL, PUBLIC,
PRIVATE), ejemplo:
PUBLIC Datos1
Esta variable es utilizada en todo el ámbito
de la aplicación.
E.M.P 3º S.
LOCAL Datos3
Esta variable sólo se
procedimiento donde se crea.
emplea
en
el
APLICACIONES
Para liberar la memoria utilizada por las
variables se utiliza la instrucción RELEASE,
ejemplo:
PRIVATE Datos2
Oculta al programa actual las variables o
matrices de memoria definidas en un programa
ejecutado previamente. Ocultar variables
creadas en programas de nivel superior, permite
manipular en el programa actual variables
privadas con el mismo nombre que las variables
ocultas. Una vez que terminas el programa que
contiene PRIVATE, todas las variables y matrices
de memoria privadas que se declararon vuelven
a estar disponibles.
PROGRAMACIÓN
Semana 03
RELEASE Datos1.
Compilar una aplicación
Cuando llegues a este nivel con seguridad
has creado una aplicación orientada a objetos
controlada por eventos, realizando diferentes
módulos. Este enfoque modular te permite
comprobar la funcionalidad de cada componente
a medida que lo has elaborado. Cuando hayas
creado todos los componentes funcionales,
podrás compilarlos en una única aplicación,
que ensamblará los componentes ejecutables
del proyecto (formularios, informes, menús,
programas) en un único archivo que podrás
distribuir a los usuarios junto con los datos.
Creación de aplicaciones
Una
aplicación
de
Visual
FoxPro
normalmente está estructurada por una base de
datos, un programa principal que configura todo
el sistema, una interfaz de usuario compuesta
por formularios, barras de herramientas y
menús, las consultas y los informes o reportes
que genera el sistema.
Diseño de la aplicación
Es necesario antes de comenzar a
involucrarse con FoxPro, realizar un diseño
apropiado de la aplicación. Para el éxito de
este diseño es vital incorporar a los usuarios,
recabando completamente la información
requerida. Es preferible pensar desde el inicio
que tu aplicación será usada por múltiples
usuarios y que deberá soportar una importante
COMPILAR
Compilar es similar a reunir o agrupar todas las
ideas de un grupo sobre un tema y establecer un criterio
único de trabajo para el desarrollo del mismo.
PROGRAMACIÓN
A NIVEL
MULTIUSUARIO
Una aplicación típica de base de datos consta de estructuras de datos, una interfaz de usuario,
opciones de consulta y funciones de generación de informes. Una aplicación ensamblada de Visual
FoxPro suele presentar al usuario un menú y uno o más formularios para introducir o mostrar datos.
Para ofrecer determinada funcionalidad, mantener la integridad y la seguridad de los datos se le agrega
código a determinados eventos. Las consultas y los informes permiten que los usuarios extraigan
información de la base de datos.
Todo programa o aplicación debes
diseñarlo pensando en que podrá ser
usado por múltiples usuarios al mismo
tiempo.
Todos los componentes que has realizado de alguna u otra manera están vinculados, por lo tanto
tendrás que establecer un punto inicial para la aplicación con un archivo principal. El archivo principal
74
13
cantidad de datos. Revisa con frecuencia las
actividades comunes que la aplicación debe
facilitar a los usuarios, ya que debes pensar en
el rendimiento de tu aplicación al manejar gran
cantidad de datos. Una aplicación se diseña con
la idea de facilitar las tareas o actividades de los
usuarios en el manejo de la información.
El proceso de crear aplicaciones es
repetitivo, probablemente definirás prototipos
y refinarás algunos componentes varias
veces hasta obtener el producto final; las
expectativas de los usuarios también pueden
cambiar o pueden generarse a lo largo de
la creación requerimientos novedosos que
harán interminable tu aplicación si no defines
correctamente el alcance de la misma. Además
ya adquiriste un gran compromiso con el proceso
de depuración, pruebas y rediseño.
E.M.P 3º S.
PROGRAMACIÓN
Semana 02
Operadores relacionales
Los operadores relacionales funcionan con todos los tipos de datos y devuelven un valor Lógico. La
siguiente tabla muestra los operadores relacionales.
Operador
Acción
Ejemplo de Código
<
Menor que
? 23 < 54
>
Mayor que
?1>2
=
Igual que
? cVar1 = cVar
<>, #, !=
Distinto de
? .T. <> .F.
<=
Menor o igual que
? {^1998/02/16} <= {^1998/02/16}
>=
Mayor o igual que
? 32 >= nEdad
==
Comparación de cadenas de
caracteres
? status == “Abrir”
Semana 14
PROGRAMACIÓN
sirve como punto de partida para la ejecución de
tu aplicación y puede constar de un programa
o formulario. Cuando los usuarios ejecuten
la aplicación, Visual FoxPro inicia el archivo
principal de la aplicación que, a su vez, ejecuta
todos los demás componentes a medida que
se vayan necesitando. Todas las aplicaciones
deben tener un archivo principal. La mejor
elección suele ser crear un programa principal
en la aplicación. Sin embargo, puedes combinar
las funciones del programa principal y la interfaz
inicial de usuario si usas un formulario como
programa principal.
E.M.P 3º S.
Siempre es conveniente guardar los valores
iniciales del entorno y configurar un entorno
específico para la aplicación en un programa
propio.
Si utilizas un Asistente para crear la aplicación, puedes permitir que el asistente cree un
programa de archivo principal de forma automática. No es necesario que especifiques un archivo principal a menos que desees cambiarlo una
vez finalizadas las acciones del asistente.
Para establecer un archivo principal dentro
de una aplicación, en el administrador de
proyectos haz lo siguiente:
1. Selecciona Todos.
2. Selecciona Código.
3. Selecciona Programas.
4. Presiona el botón Nuevo.
5. Guarda el archivo con el nombre
Principal.
6. Presiona el botón derecho del ratón
sobre el archivo y activa la opción “Establecer
Principal”.
1. Realiza una lista de mercado con al menos 10 artículos.
2. Organiza y clasifica en una tabla los siguientes datos: artículo, cantidad y precio.
12
Cuando hayas creado un archivo principal,
utilízalo para configurar el entorno de tu
aplicación. Puede que el entorno de desarrollo
predeterminado de Visual FoxPro no sea el
entorno más adecuado para la aplicación. El
entorno predeterminado establece determinados
valores para los comandos SET y las variables
de sistema en el momento de abrir Visual
FoxPro.
75
Puedes capturar los comandos del entorno
actual y llevarlos a la ventana de comandos
realizando lo siguiente:
•
En el menú selecciona Herramientas
•
Selecciona Opciones
• Presiona la tecla Mayúscula (Shift) y
presiona Aceptar
• Luego podrás copiar
información a otro programa.
y
pegar
Podrás ver los comandos SET
configuración, algunos se activan o
colocándole al lado ON / OFF, ejemplo:
SET TALK ON
SET NOTIFY ON
SET CLOCK OFF
SET COMPATIBLE OFF
SET PALETTE ON
SET BELL ON
SET BELL TO ‘’, 1
SET SAFETY ON
SET ESCAPE ON
la
de
no
E.M.P 3º S.
PROGRAMACIÓN
Semana 14
Operadores para el tipo Numeric
Es útil guardar los valores predeterminados en variables públicas, en una clase personalizada
o como propiedades de un objeto Application para que puedas restaurar estos valores al salir de la
aplicación.
La siguiente tabla muestra los operadores para el tipo Numeric en orden de preferencia.
Operador
Acción
Ejemplo de Código
()
Agrupación de valores
(4-3) * (12/nVar2)
**, ^
Exponenciación, potencia
*, /
Multiplicación y división
%
Módulo (resto)
? 15 % 4
+, -
Suma y resta
? 4 + 15
Utilizando las instrucciones previas para capturar los comandos del entorno actual, crea un
programa denominado INIENTORNO.PRG en el cual coloques todos los comandos capturados del
entorno inicial.
Puedes utilizar este programa cuando quieras recuperar el entorno inicial de Visual
FoxPro.
• Inicializar variables.
• Establecer una ruta predeterminada. Por
ejemplo si los archivos que se van a utilizar
se encuentran en el directorio C:\programas\
transmisión\datos, escribiremos el comando
SET de la siguiente forma: SET DEFAULT TO C:
\programas\transmisión\datos.
• Abrir las bases de datos, las tablas libres y
los índices necesarios. Si la aplicación requiere
acceso a datos remotos, también se puede
solicitar al usuario la información de inicio de
sesión necesaria en la rutina de inicialización.
• Hacer referencia a archivos externos de
biblioteca y procedimientos.
• La interfaz inicial de usuario puede ser un
menú, un formulario o cualquier otro componente
de usuario. Normalmente una aplicación
mostrará una pantalla de inicio de sesión o un
cuadro de diálogo de inicio antes de mostrar el
menú o formulario inicial.
• Para iniciar la interfaz de usuario en el
programa principal puedes usar un comando DO
para ejecutar un menú o un comando DO FORM
para ejecutar un formulario.
E.M.P 3º S.
Operadores de Visual FoxPro
SET LOGERRORS ON
SET KEYCOMP TO WINDOWS
SET CARRY OFF
SET CONFIRM OFF
En un entorno específico de la aplicación
o dentro del archivo Principal, podrías incluir
código para:
PROGRAMACIÓN
Semana 02
• Cuando el entorno esté configurado y se
muestre la interfaz de usuario inicial, podrás
establecer un bucle de eventos para esperar la
interacción del usuario.
? 3 ** 2
?3^2
?2*7
? 14 / 7
Operadores para caracteres
La siguiente tabla muestra los operadores de expresión de caracteres en orden de preferencia.
• Para controlar el bucle de eventos.
• Ejecuta un comando READ EVENTS, que
hace que Visual FoxPro comience a procesar los
eventos de usuario, como los clics del ratón y las
pulsaciones de teclas.
Es importante situar correctamente el
comando READ EVENTS en el archivo
principal, porque todo el proceso de este
archivo se suspende desde el momento en que
se ejecuta el comando READ EVENTS hasta
que se ejecuta un comando CLEAR EVENTS.
Por ejemplo, podrías ejecutar un comando
READ EVENTS como el último comando de un
procedimiento de inicialización, que se ejecutaría
después de inicializar el entorno y mostrar la
interfaz de usuario. Si no incluyes el comando
READ EVENTS, la aplicación volverá al sistema
operativo después de la ejecución.
Operador
Acción
Ejemplo de Código
+
Concatenación. Combina dos cadenas, una cadena
y un campo, o una cadena y una variable.
? ‘Buenos ‘ + ‘días’
-
Concatenación. Quita los espacios finales del
elemento anterior al operador y luego combina dos
elementos.
? customer.first - customer.last
$
Comparación. Busca una expresión de caracteres
dentro de otra.
? ‘padre’ $ ‘padres’
? ‘Principal’ $ customer.address
Operadores para el tipo Logical
Estos operadores devuelven un valor lógico. La siguiente tabla muestra los operadores para el tipo
Logical en orden de preferencia.
Operador
Acción
Ejemplo de Código
()
Grupos de expresiones
cVar AND (cVar2 AND cVAR3)
Una vez iniciado el bucle de eventos,
la aplicación está bajo el control del último
elemento mostrado de la interfaz de usuario.
NOT, !
Lógico negativo
También debes proporcionar una forma
de terminar el bucle de eventos ejecutando un
comando CLEAR EVENTS. Normalmente el
AND
AND lógico
lVar0 AND lVar9
OR
OR lógico inclusivo
lVarX OR lVarY
76
11
IF NOT cVarA = cVarB
IF ! nVar1 = nVar2
E.M.P 3º S.
PROGRAMACIÓN
Semana 02
PROGRAMACIÓN
Semana 14
E.M.P 3º S.
comando CLEAR EVENTS se ejecuta desde un menú o botón de un formulario.
El comando CLEAR EVENTS suspende el proceso del evento en Visual FoxPro y devuelve el
control al programa que ejecutó el comando READ EVENTS e inició el bucle de eventos.
Por ejemplo, tu programa principal podría ser similar al siguiente:
DATOS Y CAMPOS
Código
Los datos y los campos son tan esenciales en
las aplicaciones, como en una biblioteca es esencial
la clasificación de los libros, por autor, título,
editorial y fecha.
DO CENTORNO.PRG
DO MENUPRINCIPAL.MPR
READ EVENTS
DO RECUPERAENTORNO.PRG
Siguiendo las instrucciones previas y el menú creado en procesos anteriores, crea un programa
principal que inicialice el entorno de tu aplicación, incluye la ruta o directorio por defecto de
tu aplicación, el llamado a tu menú principal y finalmente la ejecución del programa de
entorno inicial INIENTORNO.PRG, creado previamente.
Además, Visual FoxPro proporciona tipos de datos que se aplican únicamente a campos de
tablas.
Tipos de campos de Visual FoxPro
Tipo de
campo
Descripción
Tamaño
Generar archivo ejecutable de la aplicación
Intervalo
Double
Número de signo flotante de
precisión doble
8 bytes
+/-4,94065645841247E-324
8,9884656743115E307
Float
Igual que Numeric
8 bytes en memoria;
1 a 20 bytes en una
tabla
- .9999999999E+19 a .9999999999E+20
General
Referencia a un objeto OLE
4 bytes en una tabla
Limitado por la memoria disponible
Integer
Valores enteros
4 bytes
-2147483647 a 2147483647
Memo
Referencia a un bloque de datos
4 bytes en una tabla
Limitado por la memoria disponible
Character
Datos de tipo Character que
quiere mantener sin modificación
en páginas de códigos
1 byte por carácter
hasta 254
Cualquier carácter
Datos de campo Memo que
quiere mantener sin modificación
en páginas de códigos
4 bytes en una tabla
Limitado por la memoria disponible
(Binario)
Memo
(Binario)
Comentarios
Llama al programa para configurar el entorno (almacena los valores en
variables públicas)
Muestra la interfaz inicial de usuario
Establece el bucle de eventos. Un programa diferente al
MENUPRINCIPAL.mpr debe ejecutar el comando CLEAR EVENTS
Llama al programa que restaura el entorno antes de salir. En este
programa debes incluir todas las variables iniciales de entorno que
copiaste previamente
a
10
+/-
•
En el Administrador de proyectos, elige Generar.
•
Elige la opción para Generar ejecutable para generar un archivo .exe.
•
Marca la casilla Volver a compilar todos los archivos.
•
Haz clic en el botón Aceptar.
77
E.M.P 3º S.
PROGRAMACIÓN
Semana 14
PROGRAMACIÓN
Semana 02
E.M.P 3º S.
En la opción Guardar como, Deberás escribir el nombre del archivo ejecutable y presionar el botón
Guardar.
TIPOS DE DATOS Y CAMPOS
Todos los datos de Visual FoxPro tienen
un tipo, como una descripción de los valores
permitidos, y el intervalo y tamaño de los valores.
Cuando hayas especificado el tipo de datos que
estás usando, Visual FoxPro puede almacenar y
manipular los datos de forma eficaz.
Las variables y las matrices contienen un
subconjunto de los tipos de datos disponibles
de Visual FoxPro. Los tipos de datos adicionales
sólo están disponibles para campos de la tabla.
Para agregar un campo de un tipo específico a
una tabla mediante programación, coloca el tipo
de campo con una letra.
Puedes especificar el tipo de datos que se
almacena en cada campo de una tabla cuando
creas la tabla. El tipo de datos de una variable o
un elemento de matriz está determinado por el
valor almacenado en la variable o elemento de
matriz. La tabla siguiente muestra los tipos de
datos de Visual FoxPro.
Tipos de datos de Visual FoxPro
Tipo de datos
Ahora FoxPro empezará a mostrar el proceso de compilación de la aplicación. Cuando encuentre
errores responderá con mensajes de error. Haz clic en el botón Ignorar de este cuadro y FoxPro
continuará con el proceso de compilación. Si existieron errores durante el proceso de compilación,
FoxPro generará un archivo con el mismo nombre de la aplicación y la extensión .ERR.
Una vez terminado el proceso, puedes verificar en el disco duro que el programa ejecutable con el
nombre que definiste, existe con la extensión .EXE. Este archivo puede ser ejecutado en la memoria
de tu computador.
Ya que has desarrollado todas las actividades de este módulo, seguramente querrás tener un
programa ejecutable de todos los componentes creados, pues bien, en esta actividad tendrás
que generar un programa ejecutable denominado ESTUDIO el cual te permitirá ejecutar
toda la aplicación desarrollada.
78
Descripción
Tamaño
Intervalo
Character
Cualquier texto
1 byte por carácter
hasta 254
Currency
Cantidades monetarias
8 bytes
-922337203685477,5807 a
922337203685477,5807
Date
Datos cronológicos formados por
mes, año y día
8 bytes
Al usar formatos de fecha estrictos,
{^0001-01-01}, 1 de enero, 1 d.C. a
{^9999-12-31}, 31 de diciembre, 9999
d.C.
DateTime
Datos cronológicos formados por
mes, año, día y hora
8 bytes
Al usar formatos de fecha estrictos,
{^0001-01-01}, 1 de enero, 1 d.C. a
{^9999-12-31}, 31 de diciembre, 9999
d.C., más 00:00:00 a.m. a 11:59:59 p.m.
Logical
Valor booleano verdadero o falso
1 byte
Verdadero (.T.) o Falso (.F.)
Enteros o fracciones
8
bytes
en
la
memoria;
1 a 20 bytes en
una tabla
- .9999999999E+19 a .9999999999E+20
Definido por
programador.
Definido por el programador.
Numeric
Una variable de tipo Variant puedes
contener cualquier tipo de datos de
Visual FoxPro y el valor Null. Una
vez que se almacena un valor en una
variable del tipo Variant, ésta asume
el tipo de los datos que contiene.
Variant
Las variables tipo Variant se designan
con el prefijo e en la sintaxis del
lenguaje.
9
el
Cualquier carácter
E.M.P 3º S.
PROGRAMACIÓN
Semana 14
Semana 01
PROGRAMACIÓN
E.M.P 3º S.
Crear discos de distribución
Una vez definido el archivo ejecutable, el siguiente paso es crear los discos de instalación o
distribución. Los pasos para hacerlo son los siguientes:
IDEAS, LÓGICA,
CREATIVIDAD Y
ENTUSIASMO
Crea una carpeta en el directorio raíz del disco duro y denomínala con el mismo nombre de tu
aplicación pero con extensión .EXE. Por ejemplo, para la aplicación guía Proy1, la nueva carpeta se
llamará Proy1.EXE. Esta carpeta se utilizará para mantener una copia de la aplicación sin el código
fuente.
El desarrollo de un programa requiere además
de paciencia, mucha creatividad, escuchar con
atención las ideas de los futuros usuarios, organizar
y enfrentar con optimismo y entusiasmo las
diferentes tareas que te encontrarás a lo largo del
desarrollo.
Si se generan los discos de instalación con todo el código fuente en la misma carpeta de generación,
se incluirían automáticamente todos los archivos en los discos de instalación. Recuerda que debemos
proteger el código fuente y no permitir que otras personas manipulen el código fuente de nuestra
aplicación. Si otra persona toma nuestro código fuente, puede generar una nueva versión de nuestro
proyecto y distribuirlo a su vez con otro nombre de producto.
•
Entre los pasos básicos de la programación
cabe citar los siguientes:
• Definir el problema.
• Desglosar el problema en elementos
discretos o manejables.
• Construir los elementos.
• Comprobar y perfeccionar los elementos.
• Ensamblar los elementos.
• Comprobar el programa en su conjunto.
A continuación se enumeran algunos
aspectos que deberás tener presentes al
empezar a programar:
• Define claramente el problema antes de
intentar resolverlo. Si no lo haces, acabarás
por realizar numerosos cambios, desecharás
códigos, tendrás que empezar de nuevo o bien
terminarás con un resultado que no es realmente
lo que deseabas.
• Desglosa el problema en pasos manejables,
en lugar de intentar resolver todo el problema de
una sola vez.
• Prueba y depura secciones de código a
medida que desarrollas el programa. Comprueba
que el código hace lo que quieres que haga.
La depuración es el proceso de encontrar y
solucionar problemas que impiden que el código
se ejecute correctamente.
Copia el programa ejecutable a la nueva carpeta (Proy1.EXE)
• Ahora copia la carpeta de iconos si los hay. Para que FoxPro guarde en los discos de instalación
las imágenes utilizadas en la aplicación.
• Crea una nueva carpeta en el directorio raíz del disco duro y denomínala con el mismo nombre
de la aplicación pero con extensión .DSK. Esta carpeta será utilizada durante el proceso de creación de
los discos de instalación para guardar los archivos resultantes.
Ahora ya estás listo para ejecutar el proceso de creación de los discos de instalación.
Haz clic en el menú Herramientas, y selecciona Instalación del submenú.
• Perfecciona los datos y el almacenamiento
de datos para facilitar la manipulación de estos
datos a través del código del programa. Esto
suele implicar estructurar las tablas de forma
adecuada.
1. Busca amigos(as) que estén familiarizados con programación en informática desde sus trabajos
o estudios. Pregúntales sobre la utilidad de la programación. Comparte con tus compañeros(as) del
centro.
2. Reflexiona sobre algunas problemáticas de manejo de información más comunes en tu
comunidad. Anótalas en tu cuaderno y compartelas con tus compañeros(as) del centro.
3. Si cuentas con una computadora instala el programa Visual FoxPro.
8
79
E.M.P 3º S.
PROGRAMACIÓN
Semana 01
Semana 14
La siguiente ventana te permitirá seleccionar la carpeta donde reside el archivo ejecutable
(Proy1.EXE). Luego haz clic en el botón Siguiente.
PROGRAMACIÓN
El diseño y la programación orientada a
objetos representan un cambio de perspectiva
con respecto a la programación estándar por
procedimientos. En lugar de pensar en el flujo
del programa desde la primera hasta la última
línea de código, debes pensar en la creación
de objetos: componentes autocontenidos de
una aplicación que tienen funcionalidad privada
además de la funcionalidad que se puede
exponer al usuario. En Visual FoxPro cada
acción es un evento, por ejemplo el movimiento
del ratón, hacer clic sobre un botón, escribir
en un cuadro. Se programa en función a la
ocurrencia de un evento. Se llama objeto a todo
lo que aparece en pantalla, por ejemplo un
botón, un cuadro de texto, una imagen, cada
objeto tiene características muy particulares, las
cuales se denominan propiedades.
Requisitos mínimos para el uso e
instalación de Visual FoxPro
En la siguiente ventana, presiona en Componente de la aplicación, la opción Runtime de Visual
FoxPro, la aplicación se ejecutará en cualquier equipo sin necesidad de tener el Visual FoxPro instalado.
Marca las otras opciones si tu aplicación hace uso de ellas. Ahora haz clic en el botón Siguiente.
Puedes ejecutar Visual FoxPro con Windows
95 o posterior, o Windows NT 4.0 o posterior. A
continuación se exponen los requisitos mínimos
para ejecutar Visual FoxPro con los sistemas
operativos Windows:
• Un PC compatible con IBM con un
procesador 486 a 66MHz (o superior).
•
Un ratón.
•
16 MB de RAM.
• 85 MB para la instalación típica y 90 MB
para la instalación completa.
• Se recomienda un monitor VGA o de
mayor resolución
Importante: Si utilizas un programa de
protección antivirus en tu PC, no lo apliques, o
desactívalo antes de ejecutar el programa de
Asistente para instalación. Es posible que no se
ejecute correctamente el programa de Asistente
para instalación si está activada la protección
antivirus. Después de la instalación, asegúrate
80
7
E.M.P 3º S.
de volver a activar el programa de protección
antivirus.
Instalar Visual FoxPro desde CD-ROM
1. Inserta el CD en la unidad de CD-ROM.
2. En el menú Inicio, selecciona Ejecutar.
3. Escribe x:\instalar, donde x es la letra
que representa la unidad de CD-ROM y presiona
ENTRAR.
4. Sigue las instrucciones de la pantalla.
• Para una instalación mínima (15 MB),
selecciona Personalizada. Esta opción te
permite seleccionar únicamente los archivos
necesarios.
• Para una instalación típica (85 MB),
selecciona Completa. Esta opción deja los
archivos de Ayuda en el CD, pero instala
archivos de soporte, como ODBC.
Para instalar todos los archivos de Visual
FoxPro (192 MB), incluidos ActiveX y archivos
empresariales, resalta Visual FoxPro 6.0 y
selecciona Personalizada y, a continuación,
eliges Seleccionar todo en el cuadro de diálogo
Cambiar opción de las opciones que deseas
agregar
El proceso de la programación
La programación es un proceso reiterativo,
los pasos se repiten numerosas veces,
perfeccionándose el código a medida que se
avanza. Al principio, someterás el código a
prueba frecuentemente mediante un sistema
de prueba y tanteo. Cuanto más conozcas el
lenguaje, mayor será la rapidez con que puedas
programar y podrás realizar más pruebas
preliminares mentalmente.
E.M.P 3º S.
PROGRAMACIÓN
Semana 01
Saludos, bienvenido(a) a este nuevo e
interesante programa de formación basado en
Visual FoxPro, una herramienta novedosa y
muy potente. En este nivel seguramente estarás
interesado en involucrarte de una manera mucho
más intensa en el mundo de la programación y
en el desarrollo de aplicaciones o soluciones que
permitan manejar eficientemente la información,
cualquiera sea el entorno donde puedas
involucrarte. El mundo tecnológico avanza a una
alta velocidad, por lo tanto es muy importante
estar lo más actualizado posible, en este
aspecto estarás trabajando sobre un lenguaje
de programación muy actual y de moda, se
considera uno de los lenguajes denominado
de alto nivel, ya que ofrece grandes facilidades
para el desarrollo de aplicaciones a través de
asistentes que generan códigos o instrucciones
que de otra manera serían de mayor complejidad
para su generación.
Seguramente te has encontrado en diferentes áreas donde el manejo y control
de la información con frecuencia es muy
complejo por su volumen o por la repetición
de tareas que convierten un proceso en
algo sumamente lento y complicado, pues
bien, tienes la gran oportunidad de manejar
una herramienta que soluciona de manera
efectiva la información, podrás
convertir un proceso difícil en
un proceso rápido y eficiente.
Te invitamos a formar
parte del valioso grupo que
resuelve muchos problemas
de información.
PROGRAMACIÓN
E.M.P 3º S.
En la siguiente ventana selecciona el directorio o carpeta donde debes colocar los discos de
instalación, marca 1,44 MB de 3 ½ pulgadas. FoxPro creará una carpeta con el contenido de disco por
disco (dependiendo del tamaño de la aplicación). Presiona el botón Siguiente:
INTRODUCCIÓN AL
VISUAL FOX PRO
Acerca del programa de formación
Semana 14
Introducción sobre el lenguaje Visual
FoxPro
Visual FoxPro es un lenguaje de programación que permite el uso de la programación por
procedimientos y la programación orientada a
objetos, para permitirte crear aplicaciones potentes y flexibles. Visual FoxPro es uno de los
gestores de base de datos relacionales más
flexibles y prácticos del mercado, disponiendo
de un entorno de desarrollo altamente integrado
al sistema operativo Windows, lo cual te permitirá realizar soluciones verdaderamente potentes
en su utilidad y de fácil manejo para cualquier
tipo de usuario.
Cuando se programa por procedimientos,
se almacenan datos y se manipulan mediante
una serie de instrucciones. Los datos y los
contenedores en los que ellos se almacenan
constituyen la materia prima de la programación.
Las herramientas utilizadas para manipular
esta materia prima son comandos, funciones y
operadores.
6
Escribe el Título de la aplicación en el cuadro de diálogo de la instalación, escribe la información
de Copyright, relacionada con el derecho de autor, selecciona el archivo que ejecutará la aplicación, el
cual guardaste en la carpeta creada previamente. Presiona el botón Siguiente.
81
E.M.P 3º S.
PROGRAMACIÓN
Semana 14
Selecciona el directorio o carpeta predeterminada para la instalación de la aplicación. Presiona el
botón Siguiente.
INDICE
Pág.
En la siguiente ventana define la forma en que FoxPro distribuirá los archivos de la aplicación. Si
no deseas realizar ningún cambio presiona el botón Siguiente.
82
Introducción a Visual Fox Pro
6
Tipos de datos y campos
9
Aplicaciones
13
Base de datos y tablas
16
Tablas, indices y desencadenantes
19
Tablas y sus registros
23
Relación entre tablas
25
Formularos
28
Diseño de formularios
34
Diseñar menús
40
Informes
43
Diseñador de informes y entorno de datos
50
Creación de vistas
56
Programación en Visual FoxPro
67
Semana 14
PROGRAMACIÓN
E.M.P 3º S.
La ventana siguiente finaliza los parámetros de instalación. Haz clic en el botón Finalizar para que
FoxPro inicie el proceso de creación de los discos de instalación.
Instituto Radiofónico Fe y Alegría (IRFA)
Todos los Derechos Reservados.
Agosto 2006
Prohibida la reproducción total o parcial de esta obra por cualquier medio, sin permiso escrito del
Instituto Radiofónico Fe y Alegría.
Director Nacional de IRFA
José Rafael Roca
Coordinación Oficina Nacional del IRFA
Javier Barrios
FoxPro muestra una ventana donde aparece el progreso del proceso de creación de los discos de
instalación.
Producción:
Julio Blanco
Revisión y Corrección:
Oficina Nacional del IRFA
Diseño, Diagramación y Montaje
Yasu Correia
Instituto Radiofónico Fe y Alegría
Oficina Nacional
Calle 3B, Edificio Fe y Alegría C2-07, piso 2.
La Urbina. Caracas - Venezuela.
Teléfonos: (0212) 241.03.53 / 242.58.97 / 242.29.19 / 242.29.04 Fax: (0212) 242.35.55
www.feyalegria.org.ve Correo electrónico: [email protected]
83
E.M.P 3º S.
PROGRAMACIÓN
Semana 14
Cuando haya finalizado mostrará una ventana con la información sobre el proceso generado. Haz
clic en el botón Listo. FoxPro regresará a la ventana de comandos a esperar una nueva orden.
Ya puedes dar una mirada al disco duro y revisar la definición del proceso de creación de instalación
definió. La carpeta C:\Proy1.DSK, es la que contiene los archivos y carpetas de instalación.
Si quieres probar el proceso de instalación, borra la carpeta, que en este caso sería Proy1.EXE
y ejecuta el proceso de instalación desde la carpeta C:\Proy1.DSK\DISK144\DISK1\INSTALAR.EXE.
Una vez ejecutado el proceso de instalación, verifica el funcionamiento de la aplicación. Es importante
comprobar la salida de la aplicación, lo mismo que el enrutamiento correcto de los datos dentro de la
estructura del disco duro.
Esta actividad final culminará con éxito tus aprendizajes en este nivel de programación de
FoxPro. Deberás crear los discos de distribución de tu aplicación previamente desarrollada,
verificando el funcionamiento de la instalación, sigue los pasos descritos en este
módulo.
Te felicitamos por haber culminado exitosamente este curso, esperamos que sigas desarrollando
aplicaciones y profundizando la investigación de este lenguaje de manera autodidacta, recuerda que
siempre estarás en constante aprendizaje.
84
PROGRAMACIÓN
3º Semestre

Documentos relacionados