TUTORIAL MultiSpec - IES "Ramón J.Sender"

Comentarios

Transcripción

TUTORIAL MultiSpec - IES "Ramón J.Sender"
TUTORIAL MultiSpec
(1ª parte)
(versión 2.7 para Windows; febrero 2005)
Estos apuntes se han elaborado a partir de los tutoriales de
Larry B. Ryan (New Hampshire University, USA)
David Landgrebe y Larry Biehl (Purdue University, USA)
José L. Escuer (IES Ramón J. Sender; Fraga-HU, España)
Antonio Segovia (IES Universidad Laboral, Albacete-España)
MultiSpec 2.7 para Windows
1. ABRIR EL PROGRAMA MULTISPEC
El programa MultiSpec no requiere ser instalado. Simplemente se copia desde un diskette
o
bien
se
descarga
gratuitamente
de
internet
en
la
siguiente
dirección
http://dynamo.ecn.purdue.edu/~biehl/MultiSpec/. Una vez tengas el programa copiado en el disco
duro de tu ordenador puedes empezar a trabajar.
Para abrir MultiSpec sólo tienes que hacer doble clic con el ratón sobre el icono del
programa. Lo primero que aparece es una ventana en blanco llamada Text Output. Esta ventana
es un editor de texto donde aparecen todas las estadísticas y resultados que se van obteniendo
al manipular la imagen digital. Estos datos pueden trasladarse (Copiar+Pegar) a un procesador de
textos o a una hoja de cálculo para obtener gráficas o realizar operaciones matemáticas.
Como esta ventana de momento no interesa hay que minimizarla para que no moleste. Haz
clic en el cuadrito situado en la esquina superior derecha de la ventana.
2. ABRIR LA IMAGEN DE SATÉLITE
Desplegamos la imagen utilizando un solo canal1. Al hacer esto el programa asigna a cada
píxel un tono de gris entre 0 (negro) y 255 (blanco), de modo que existirán 256 tonalidades
diferentes entre el blanco y el negro. Recuerda que el color gris que tiene un píxel se corresponde
con un valor numérico denominado Valor Digital, el cual, a su vez, es proporcional a la energía
que el sensor recibe de la superficie terrestre en cada uno de los canales (=bandas) del espectro
que el satélite es capaz de detectar.
Ø
Open image
1
Utilizamos el término canal aunque puede utilizarse también banda. Con cualquiera de esos términos
nos referimos a aquella porción del espectro electromagnético que es capaz de detectar un sensor del
satélite.
2
MultiSpec 2.7 para Windows
Aparece un cuadro de diálogo en el que se selecciona la imagen que se va a abrir. En
nuestro caso vamos a abrir la imagen Fraga00c.lan. Hacemos doble clic y, aparece la siguiente
ventana:
En este cuadro hay que escoger las siguientes opciones:
Ø
Ø
Ø
Display/Type 1-Channel Grayscale
Bits of color 8
Channels 1 Grey
El resto de opciones no se modifican. Al hacer clic en OK se desplegará la imagen de la
siguiente forma:
Hemos escogido un solo canal del Landsat-TM (1-Channel Grayscale) es decir la
información recogida por uno sólo de sus sensores. El canal escogido en este caso es el 1
(Channels 1) que se corresponde con la energía recibida por el sensor en el canal Azul del
espectro. A cada píxel, por tanto, el programa MultiSpec le asigna un tono de gris (Grey) en
función de su Valor Digital en el azul.
Por supuesto, puede escogerse otro canal, simplemente escribiendo 2, 3, 4 ó 5 en la cajita
Channels Grey, a la izquierda de la caja de diálogo.
1. Hacemos click en OK
3
MultiSpec 2.7 para Windows
La imagen que se ha desplegado tiene diferentes tonalidades de gris. Podemos analizar
visualmente esta imagen y plantear algunas cuestiones:
Ø Aunque hemos escogido la imagen correspondiente a la banda azul, la imagen se
ve gris. ¿Puedes explicar por qué?.
Ø ¿Qué tonalidades tienen las áreas de regadío?. ¿Por qué?
Ø ¿Qué tonalidades tiene el agua?. ¿Por qué?
3. MANEJAMOS EL ZOOM POSITIVO Y EL ZOOM NEGATIVO
En primer lugar hay que abrir la imagen Fraga00c.lan visualizando únicamente el canal 1
(azul), tal como se ha indicado en el capítulo 2.
Una vez la tengamos en pantalla manejaremos el zoom para conseguir visualizar píxeles y
comprobar lo siguiente:
1.
Hay muchos tonos diferentes de gris en toda la imagen.
2.
Un píxel individual tiene un color uniforme ya que el Landsat-TM es incapaz de discernir
elementos más pequeños de 30 m x 30 m (resolución espacial) por lo que obtiene una media
de la energía que reflejan las diferentes cubiertas que componen el píxel.
- En la línea del menú principal hay tres cuadritos. Haciendo clic en el cuadrito en el que hay
dibujada una montaña pequeña hacemos zoom negativo y haciendo clic en click en el cuadrito
en el que hay dibujada una montaña grande hacemos zoom positivo. Para restablecer el
tamaño normal, hacemos clic en el cuadrito adjunto en el que pone x 1.0
- Puede seleccionarse una zona haciendo una caja con el ratón y a continuación hacer clic en
la casilla del zoom (cuadro en la esquina inferior derecha). El área seleccionada se mantendrá
siempre en el centro del monitor a medida que vaya progresando el zoom mediante sucesivos
clics.
Hacemos sucesivos zoom positivos hasta que únicamente veamos píxeles.
4
MultiSpec 2.7 para Windows
1.
2.
3.
4.
¿Cuánto mide en la realidad cada uno de los cuadritos (píxeles) que observas?.
¿Cuántos tonos de gris hay suponiendo que consideres el color blanco y el color
negro?
¿Cada tono de gris se corresponde con una cubierta diferente?. Explícalo
¿Al hacer sucesivos zoom positivos se ve mejor o peor?. ¿Se ve todo más cerca
como si mirases con un catalejo?
4. LA FIRMA ESPECTRAL: ¿Qué reflectividad tiene una
cubierta en cada uno de los canales LandSat-TM?
Vamos a seleccionar diferentes zonas de la imagen de las cuales conocemos sus
características, bien porque hayamos salido al campo y lo hayamos comprobado, bien porque
contamos con elementos cartográficos auxiliares (mapa topográfico y foto aérea). Es decir,
conocemos las diferentes cubiertas que aparecen en la imagen.
A continuación, veremos cual es el patrón de reflectividad que tiene cada una de las
cubiertas más características de la imagen.
Procede de la siguiente forma:
1.
Recuerda que seguimos con la imagen Fraga00c.lan desplegada con 1 canal de color
y la estás viendo en tu monitor en diferentes tonos gris.
2.
Selecciona una zona de la imagen que esté ocupada por una cubierta conocida, por
ejemplo REGADÍO y haz una caja con el ratón. Verás que si haces una serie de
zooms positivos, hasta ver únicamente píxeles, el área escogida se mantiene en el
centro de la imagen.
3.
Ve al menú Window y escoge la opción New selection graph
Aparece una pequeña ventana similar a la siguiente:
5
MultiSpec 2.7 para Windows
4.
A continuación escoge un píxel y haz clic con el ratón en su centro. En la ventana
Selection Graph aparece un nuevo gráfico. En abscisas (1,2,3,4,5) están los 5 canales
del Landsat-TM y en ordenadas en Valor Digital (VD) que tiene ese píxel en cada uno
de los canales.
Suponiendo que el píxel esté ocupado completamente por una cubierta “pura” de
REGADÍO se obtendrá el gráfico característico de esa cubierta. A este gráfico se le denomina
FIRMA ESPECTRAL. Así por ejemplo, la firma espectral de la vegetación sana y bien regada es
como sigue:
•
refleja poco en el azul
•
refleja algo más en el verde
•
refleja poco en el rojo
•
refleja mucho en el infrarrojo cercano
•
refleja algo menos en el infrarrojo medio.
El descenso de reflectividad en el infrarrojo medio se debe al contenido de agua en el
parénquima de la hoja que absorbe energía en esa longitud de onda.
1. ¿De qué color veríamos un bosque de hayas en verano si nuestros ojos detectasen
el Infrarrojo cercano?
Si en lugar de pinchar en un solo píxel escoges varios a la vez, el gráfico que aparece es
ligeramente diferente:
6
MultiSpec 2.7 para Windows
La línea roja (Average) representa el Valor Digital medio de todos los píxeles escogidos.
Las dos líneas azules (Min-Max) representan el Valor Digital máximo y el Valor Digital mínimo de
todos ellos. Las dos líneas verdes (StDv) representan la desviación típica positiva y negativa.
A continuación puedes hacer el siguiente ejercicio para que practiques. Para ello necesitas
tu imagen Landsat-TM, conocer bien el territorio o disponer de mapas topográficos y fotografía
aérea.
Ejercicio:
Obtén la Firma Espectral de las cubiertas más características:
-
Cultivos de regadío
Cultivos de secano
Suelo desnudo
Vegetación espontánea (pinares, matorral, caducifolios,…)
Agua
Áreas urbanas
Si se quiere conocer el VD exacto para cada banda hay que pinchar con el ratón en el
píxel o grupo de píxeles deseados. A continuación ir al menú Processor y escoger List Data. Los
resultados pueden verse en la ventana Text Ouput (Output Information: Multispectral Image Data
Values).
7
MultiSpec 2.7 para Windows
Desde allí, con “copiar y pegar” se pueden llevar los valores numéricos a una hoja de
cálculo y obtener resultados estadísticos y elaborar gráficas.
5. COMPOSICIÓN DE CANALES2
Hasta ahora has trabajado con la m
i agen Fraga00c.lan desplegando un solo canal del
espectro. Sin embargo, MultiSpec te permite visualizar la imagen escogiendo hasta tres canales
(=bandas) a la vez. A este proceso se le denomina Composición de bandas. Las composiciones
de bandas son muy interesantes porque permiten visualizar información que, de otro modo, es
difícil de detectar.
A continuación vas a hacer tres composiciones diferentes:
• Visualizar cinco imágenes al mismo tiempo, correspondientes a cada una de los canales
del Landsat-TM
• Visualizar la imagen en color verdadero, tal como podría verse desde el espacio
• Visualizar la imagen en falso color
5.1. Comparando imágenes canal a canal
Si tienes abierto el programa con la imagen desplegada ve al menú Processor.
Ø Processor
Ø Display image
2
Utilizamos canal porque es la traducción directa de Channels que es el término que aparece en
MultiSpec. Puede utilizarse también banda que quizás ilustra mejor la idea de segmento del espectro
que detecta un sensor del satélite.
8
MultiSpec 2.7 para Windows
Aparece una ventana como la que tienes a continuación. En ella verás la caja Display
type, allí escoge las opciones
Ø Side by Side channels
Ø Bits of color 8
Si abres MultiSpec por primera vez te aparecerá en primer lugar la Ventana Text Output.
Recuerda que la tienes que minimizar para que no estorbe. A continuación deberás ir al menú
File, seleccionar Open Image y abrir la imagen (en este caso Fraga00c.lan). Es entones cuando
te aparece esta ventana de diálogo en la que escoges la opción Side by Side Channels.
El resto de opciones se dejan igual y haces clic en OK.
Ahora puedes visualizar 5 imágenes, cada una de las cuales se corresponde con cada una
de los canales del espectro. Es decir en la imagen situada más a la derecha y que tiene un 1
encima, cada píxel tiene un tono de gris que se corresponde con su Valor Digital en el azul. En la
imagen contigua, con un 2 encima, cada píxel tiene un tono de gris que se corresponde con su
Valor Digital en el verde…..y así sucesivamente.
Es posible que en lugar de ver una ventana como ésta, te aparezca otra como la siguiente
o similar. Fíjate que encima de la imagen hay un número (el canal). ¿Qué ocurre?. Se trata de un
9
MultiSpec 2.7 para Windows
problema de zoom que puedes solucionar haciendo una serie de zooms negativos hasta que
consigas ver las 5 imágenes en pantalla. También puedes mover los cursores que hay en la barra
inferior de la pantalla y verás que van apareciendo sucesivamente las 5 imágenes
Ahora ya puedes resolver el siguiente ejercicio:
1.
Comenta las diferencias de reflectividad que puedes observar entre las diferentes
imágenes. Recuerda que las áreas claras reflejan mucha energía y las áreas oscuras
absorben mucho (reflejan poco). Para ello escoge las siguientes cubiertas: agua, suelo
desnudo, vegetación, regadíos, secanos y áreas urbanas.
5.2. COMPOSICIÓN DE BANDAS (=CANALES).
Visualización de la imagen en falso color
Esta combinación es muy interesante porque permite discriminar con gran precisión la
vegetación. Se basa en el hecho de que la vegetación tiene una elevada reflectividad en el
infrarrojo cercano (IR) y, en cambio, la del suelo es muy baja. Por ello esas dos cubiertas ofrecen
mucho contraste utilizando esta composición de bandas. Se denomina falso color porque los tres
cañones de color del monitor del ordenador aplican el color de la siguiente forma:
Cañón de color del monitor
Rojo (Red)
Verde (Green)
Azul (Blue)
Canal del Landsat-TM
4
3
2
(infrarrojo cercano)
(rojo)
(verde)
Según este procedimiento, la vegetación, que tiene una elevada reflectividad en el IR
cercano, va a verse de color rojo y el resto de cubiertas que no tienen ese valor de reflectividad en
esa banda no van a verse rojas.
10
MultiSpec 2.7 para Windows
Para poder visualizar la imagen en falso color procede como sigue:
En primer lugar hay que ir al menú Processor:
Ø Processor
Ø Display image
En la caja de diálogo que te aparece selecciona los canales correspondientes al falso color
(4,3,2) y haz clic en OK
Al pinchar en OK se despliega la imagen. Sitúa el zoom a tamaño normal (x1) y, a
continuación, realiza el siguiente ejercicio:
1. Con la imagen en falso color desplegada, averigua de qué color aparecen las siguientes
cubiertas.
Cubierta
Color
Agua
Vegetación espontánea
Regadíos
Secanos
Áreas urbanas
Ahora que ya puedes discriminar mejor las siguientes cubiertas haz lo siguiente:
2.
Haz un caja con el ratón sobre la cubierta regadío y a continuación haz una serie de
zooms positivos hasta que únicamente veas píxeles de colores, tal como tienes en la
siguiente figura. ¿Por qué a pesar de que esa cubierta es regadío aparecen tonalidades
diferentes de rojo?.
11
MultiSpec 2.7 para Windows
Para darte una pista y puedas resolver la pregunta, ve ahora al menú Window y selecciona
New Selection Graph
Ø Window
Ø New Selection Graph
Recuerda que con esta opción se muestra una pequeña gráfica en la que puedes visualizar
el Valor Digital de un píxel (o de un grupo) en cada una de las 5 bandas del Landsat. Si vas
pinchando en cualquier píxel rojo de los que tienes en la imagen, verás que la signatura espectral
es muy parecida….¿por qué aparecen pues diferentes tonos de rojo?. La respuesta es la
siguiente:
El satélite no sabe qué hay en la superficie de la Tierra. Sus sensores únicamente reciben
la energía que un determinado píxel refleja hacia el espacio. A continuación cada sensor
transforma ese valor energético en un número (el Valor Digital que un píxel tiene para cada una de
los canales Landsat-TM).
La imagen “bruta” recogida por una antena terrestre, por tanto, no es más que una
sucesión de números (del 0 al 255). Esta imagen inicial es elaborada para que pueda ser
visualizada en el monitor de un ordenador. Así pues, una vez que la imagen está instalada en
nuestro disco duro, MultiSpec asigna a cada píxel un determinado color en función de su VD. Ese
color es el que se visualiza en la pantalla.
Pues bien, imaginemos que en un campo de regadío hay melocotoneros jóvenes,
plantados a metro y regados con goteo. En el campo contiguo hay melocotoneros algo más vi ejos
(por tanto más grandes) y en el de más allá perales junto a una pequeña parcela de higueras y un
pequeño huerto con tomates y berenjenas que se riegan a manta. Todo eso es regadío y refleja
de forma parecida aunque no idéntica por lo que los VD de los diferentes píxeles que integran
esos campos serán parecidos pero no iguales. Al abrir la imagen y seleccionar en el cuadro de
diálogo la opción Channels: 4, 3, 2 el programa informático aplica a cada píxel una tonalidad de
rojo determinada acorde con sus VD (uno por banda).
¿Habría alguna manera de decirle a la máquina que, dado que todos los píxeles rojos que
hay en una determinada zona son regadío, los muestre en un único color?. En el próximo capítulo
(Clasificación supervisada) se analiza de qué forma puede resolverse este problema.
12
MultiSpec 2.7 para Windows
Visualización de la imagen en color verdadero
Se trata ahora de desplegar la imagen para visualizarla de forma similar a como podría
verse la Tierra desde el espacio. Para ello hay que ir de nuevo al menú Processor y en Display
image seleccionar las bandas 3,2,1. Al seleccionar esta combinación, los tres cañones de color
del monitor aplican a cada uno de los canales del Landsat-TM el color que le corresponde, tal
como puede verse en la siguiente figura:
Cañón de color del monitor
Banda del Landsat
Rojo (Red)
Verde (Green)
Azul (Blue)
3 (rojo)
2 (verde)
1 (azul)
Ejercicio:
1. Según esta composición de bandas, determina de qué color aparecen las siguientes
cubiertas
Cubierta
Color
Agua
Vegetación
Regadíos
Secanos
Áreas urbanas
2. De las dos combinaciones de bandas (falso color y color verdadero) que has utilizado
¿cual de ellas permite discriminar mejor la vegetación?.
3.
¿Hay algunas cubiertas que puedan confundirse en la combinación color verdadero?
6. CLASIFICACIÓN SUPERVISADA DE UNA IMAGEN DE
SATÉLITE: UNA APROXIMACIÓN AL MÉTODO
Uno de los objetivos del análisis digital de una imagen de satélite es la obtención de
cartografía temática. Con la imagen que G.L.O.B.E. proporciona y el programa MultiSpec se
pueden obtener con relativa facilidad mapas de usos y ocupación del suelo. Estos mapas pueden
exportarse a un Sistema de Información Geográfica (IDRISI, ARC/INFO, ArcView, MiraMon,
MapFactory,…) para hacer análisis del territorio o a programas de diseño gráfico, para mejorar la
presentación final del mapa.
En este capítulo vamos a ver de qué forma puede obtenerse un mapa temático a partir de
la imagen de satélite. La técnica, en realidad, requiere un cuidadoso análisis previo de las
13
MultiSpec 2.7 para Windows
estadísticas de la imagen, del patrón de reflectividad de las diferentes cubiertas para ver si sus
signaturas espectrales son similares (separabilidad), etc.
Sin embargo estos procesos previos son algo complicados y exceden el nivel del
Bachillerato. Vamos, por tanto, a hacer únicamente una aproximación al procedimiento de
clasificación supervisada con el fin de:
1. introducir esta técnica de análisis digital
2. obtener un mapa temático
La clasificación supervisada consiste en “presentar” a la máquina pequeños grupos de
píxeles representativos de cada una de las diferentes cubiertas que queremos que aparezcan en
el mapa temático final. A cada uno de estos grupos se le denomina campo de entrenamiento
(= campo de aprendizaje = Training Field).
En un segundo paso, el programa informático compara todos los píxeles de la imagen con
cada uno de los grupos de píxeles que constituyen cada campo de aprendizaje.
Según el parecido espectral de cada píxel de la imagen, MultiSpec lo asigna a cada una de
las cubiertas que se han determinado en la fase de entrenamiento.
6.1. Salida al campo para la determinación de las diferentes cubiertas existentes en el
área representada en la imagen.
Para llevar a cabo esta fase es imprescindible o bien conocer el territorio a la perfección o
bien salir al campo con diferentes elementos cartográficos (mapa topográfico, foto aérea) y,
especialmente, con la imagen LandSat impresa en papel (fotoimagen).
Durante el recorrido por el territorio se establecen los puntos representativos de cada
cubierta y se marcan con rotulador sobre el mapa, foto aérea, etc., tal como se indica en la figura
de la página siguiente. Cada círculo de color representa una clase temática diferente (regadío,
agua, matorral,…).
14
MultiSpec 2.7 para Windows
6.2. Definición de los campos de entrenamiento
6.2.1. ¿Cómo se establece un campo de entrenamiento sobre la imagen digital?
Abrimos la imagen tal como se ha indicado en capítulos anteriores. Sobre la imagen
desplegada se establecen los campos de entrenamiento. Cada campo debe tener entre 4 y 6
píxeles y debemos señalar unos 10-12 campos por cada cubierta para que la clasificación sea
correcta. Los campos de entrenamiento no tienen que ser exactamente iguales aunque sí
parecidos.
Para asegurarnos de que un campo de entrenamiento se corresponde con la cubierta
adecuada tenemos que abrir la ventana Selection Graph (recuerda el capítulo 4: la firma espectral)
y comprobar que los píxeles que vamos a escoger tienen la firma espectral característica de la
cubierta que vamos a definir.
Una vez tenemos abierta la ventana Selection Graph, vamos al menú Processor y
seleccionamos Statistics
Ø
Ø
Processor
Statistics
Pinchamos en OK en el primer cuadro de diálogo que surge sin modificar ninguna de las
opciones. A continuación aparece la ventana Project junto a la imagen desplegada.
15
MultiSpec 2.7 para Windows
1.
Hacemos una serie de zooms positivos en una de las cubiertas conocidas, por ejemplo
regadío, hasta que únicamente veamos píxeles.
2.
Comprobamos que los píxeles que vamos a seleccionar tienen la firma espectral típica
del regadío tal como se ha indicado en el capítulo 4.
3.
Hacemos una caja de 6 píxeles con el ratón y hacemos clic en el cuadro Add to List.
Ahora aparece la siguiente ventana:
16
MultiSpec 2.7 para Windows
En esta ventana hay que dar una serie de especificaciones. En la caja Enter Class Name
hay que sustituir Class 1 por la primera clase temática que vamos a definir, es decir regadio
(mejor no utilizar mayúsculas, acentos, espacios en blanco, guiones altos,…)
De esta forma le hemos dicho a la máquina que los seis píxeles que acabamos de señalar
(y que tienen unos VD determinados) pertenecen a la clase regadio. Obsérvese también que a
ese grupo de píxeles (que no son más que un campo de entrenamiento) se les da una etiqueta o
identificador (Field 1). Este nombre también puede cambiarse, simplemente escribiendo encima
riego_1.
17
MultiSpec 2.7 para Windows
Al dar a OK puede verse en la imagen la caja de los seis píxeles con la etiqueta regadio
riego_1.
6.2.2.
¿Cómo se establecen más campos de entrenamiento para la clase regadio?
Seleccionamos de nuevo 6-8 píxeles en otro lugar de la imagen en el que haya regadío.
Ten cuidado y distribuye bien los campos de entrenamiento por TODA la imagen. Obsérvese que
en la cajita Class de la ventana Project seguimos teniendo regadio
Ahora pinchamos en la caja Add to list de la ventana Select Field
En la ventana Define Class and/or Field Description, seguimos teniendo la clase regadio y,
dado que es el segundo campo de entrenamiento que establecemos, aparece escrito, en la cajita
Enter Field Identifier field 2. Escribiremos, encima de field 2, riego_2.
Obsérvese también que la ventana indica el número de píxeles del campo de entrenamiento
actual y el número total de píxeles que se han seleccionado para la clase regadio.
De esta forma continuaríamos hasta tener hasta 10 ó 12 campos de entrenamiento para la
clase regadío, procurando que estén uniformemente distribuidos por toda la imagen.
6.2.3.
¿Y que ocurre si nos equivocamos y queremos borrar un campo de
entrenamiento o una clase completa?
Si durante el proceso de designación de los campos de entrenamiento cometemos un error
o bien queremos eliminar un determinado campo, únicamente hay que activar la ventana Select
Field y pinchar en Class. Una vez hayamos hecho esto aparecerá una lista con todos los campos
de entrenamiento. Únicamente hay que seleccionar con el ratón el campo que queremos eliminar
y acudir a continuación al menú Edit del menu general y hacer clic en Cut Field
6.2.4.
¿Cómo se establecen nuevos campos de entrenamiento para otras clases
temáticas?
En principio pueden establecerse tantas clases temáticas como se desee, aunque, en
realidad esto no es posible ya que al establecer de antemano un elevado número de clases, con
toda seguridad dos o más tendrán un comportamiento espectral muy similar de forma que se
18
MultiSpec 2.7 para Windows
confundirán. Es muy difícil, por ejemplo diferenciar un pinar de un encinar, o un matorral de
romero con un 50% de cobertura de un matorral de jaras con un 50% de cobertura. Esto significa
que el mapa que se obtuviese, al clasificar la imagen con muchas clases temáticas, podría ser
erróneo ya que una cubierta A aparecería como B o viceversa.
Para evitar este problema hay que establecer un análisis estadístico previo a la
clasificación supervisada para determinar la separabilidad de las clases.
Este procedimiento no va a ser tratado por el momento, de forma que para que la
clasificación supervisada sea coherente hay que escoger un número de clases reducido y,
además, que tengan un comportamiento espectral diferenciado. Para empezar a aprender la
técnica puede empezarse con tres clases, por ejemplo agua, regadío y suelo desnudo. Una
clasificación con las siguientes clases temáticas puede llevarse a cabo, pudiéndose obtener un
mapa temático relativamente bueno:
•
regadío
•
suelo desnudo
•
agua
•
secanos
•
vegetación espontánea
Para establecer campos de entrenamiento para nuevas clases temáticas procedemos
como sigue:
Ø Con la imagen desplegada (4,3,2) seleccionamos New en la caja Class de la ventanita
Select Field .
Ø Seleccionamos con el ratón 6-8 píxeles representativos de otra cubierta, por ejemplo
agua.
Ø Comprobamos la firma espectral de los píxeles que vamos a seleccionar
Ø Hacemos clic en Add to list y tenemos de nuevo la siguiente ventana
19
MultiSpec 2.7 para Windows
Ø En la caja Enter Class Name escribiremos el nombre de la siguiente clase, es decir
agua.
Ø En la caja Enter Field Identifier escribiremos el nombre del primer campo de
entrenamiento para la clase agua, es decir agua_1. La ventana nos indica también el
núemro de píxeles que componen este campo.
Procederemos de esta forma hasta tener todos los campos de entrenamiento para todas
las clases temáticas.
En el caso de que la cubierta “agua” sea un río no excesivamente ancho hay que tener
cuidado a la hora de establecer los campos de entrenamiento ya que si escogemos 6-8 píxeles,
se corre el peligro de incluir en el campo de entrenamiento píxeles de la vegetación de ribera que
tiene un comportamiento espectral muy diferente del agua. Si esto se hiciera así, MultiSpec no
podría clasificar correctamente la imagen ya que confundiría agua con vegetación de ribera (muy
parecida espectralmente a los campos de frutales de regadío).
Para evitar este problema, hay que comprobar con cuidado la firma espectral de los píxeles
que van a seleccionarse y cerciorarse de que tienen el patrón espectral del agua.
6.2.5. Clasificación de los campos de entrenamiento
En esta fase MultiSpec recorrerá todos los campos de entrenamiento para “aprender y
guardar en su memoria” qué características espectrales tienen los píxeles que integran cada uno
de los campos de entrenamiento que se han establecido en el punto anterior.
Dicho de otro modo, lo que hace el programa es analizar los VD que tienen los píxeles de
cada campo de entrenamiento en cada una de las bandas.
Del menú Processor seleccionamos Classify y en la ventana que aparece seleccionamos
las opciones siguientes:
El algoritmo matemático que se utilizará es el de Máxima probabilidad
Ø Procedure: Maximum likelihood
20
MultiSpec 2.7 para Windows
Se van a clasificar todos los campos de entrenamiento de todas las clases:
Ø Class areas: All
Ø Training (resubstitution)
Ø Image selection
Para la clasificación se utilizan todos los canales
Ø Channels: All available
Una vez se hayan seleccionado estas opciones confirmamos con OK.
Una vez la máquina haya completado el proceso podemos abrir la ventana Text Output y
analizar las estadísticas resultantes de la clasificación de los campos de entrenamiento.
6.3. Clasificación de la imagen
Ahora MultiSpec ya conoce las características espectrales de los campos de
entrenamiento que nosotros hemos definido. En esta fase MultiSpec recorre todos los píxeles de
la imagen, los compara con cada uno de los campos de entrenamiento y, en función de su
parecido espectral, los asigna a una o a otra clase.
Al finalizar esta tarea, por lo tanto, obtendremos una imagen en la que todos los píxeles
pertenecerán a las diferentes clases temáticas definidas en el capítulo anterior (6.2).
Eso significa que, al finalizar el proceso, un píxel cualquiera de la imagen ya no tendrá un
VD (valor digital) para cada banda del espectro, sino que tendrá un único valor numérico al cual se
le asocia un color y una categoría temática que es la que aparece en la leyenda. Habremos
transformado, por tanto, la imagen multiespectral inicial en un mapa temático en formato ráster.
Para llevar a cabo esta fase procederemos de la siguiente forma:
En el menú Processor escogemos Classify y aparece la siguiente ventana de diálogo:
21
MultiSpec 2.7 para Windows
Aquí hay que escoger las siguientes opciones:
Ø Quitamos la selección Training (resubstitution) puesto que ahora se trata de clasificar
toda la imagen y no únicamente los campos de entrenamiento.
Ø Seleccionamos Image Selection
Ø El algoritmo matemático sigue siendo el de Máxima probabilidad (Maximum likelihood)
Ø Seleccionamos Threshold results at 2%, lo cual significa que únicamente se van a
incluir en las clases temáticas definidas aquellos píxeles que sean muy parecidos a
los píxeles que integran la clases de entrenamiento. Todos aquellos que MultiSpec los
considere diferentes en más de un 2% aparecerán en blanco, es decir, no serán
asignados a ninguna clase temática.
Ø En Write classification results to, seleccionamos también Disk File, es decir queremos
que guarde la imagen clasificada obtenida como un archivo.
Ø Finalmente confirmamos con OK
Durante la clasificación aparece una ventana en la que se observa como una serie de
números se mueven rápidamente. En ese momento MultiSpec está haciendo una serie de
pasadas sucesivas por todos los píxeles de la imagen (línea a línea) comparándolos con los
píxeles de los campos de entrenamiento y asignándolos a las diferentes clases temáticas.
Al finalizar la clasificación nos pregunta dónde y con qué nombre queremos guardar la
imagen clasificada. Se escoge un nombre y un directorio y se confirma con Aceptar.
Ya sólo queda abrir la imagen clasificada y comprobar la bondad del mapa.
1.
Acudimos al menú File y escogemos Open image. Ahora tendremos que abrir la imagen
clasificada que tiene extensión .GIS (en este caso la hemos llamado fragac.gis) y que será
algo similar a la figura siguiente en la que se muestra una imagen con únicamente dos clases
temáticas, “agua” y regadío”. Obsérvese que aparece un campo en la leyenda denominado
background, es decir todo aquello que no se corresponde ni con la clase agua ni con la clase
regadío.
2.
Únicamente resta cambiar los colores de la leyenda haciendo doble click sobre el cuadrito de
color que está junto al nombre de la clase. Al hacer esto se crea automáticamente otro
archivo al que deberemos dar un nombre con extensión .TRL. Este archivo va asociado al
archivo .GIS y es el que contiene la información temática (al igual que el que tiene extensión
.STA es el asociado a la imagen .IMG o .LAN).
3.
Finalmente, si guardamos este archivo como GEOTIFF en el menú File (Save image to
geotiff as) podremos llevarlo a un programa de diseño gráfico y mejorar la presentación final
del mapa, añadiendo flecha del norte, título, etc,...
4.
También podemos llevar este archivo tiff a un Sistema de Información Geográfica desde el
que podremos trabajar como con cualquier fichero ráster.
22
MultiSpec 2.7 para Windows
23
Nombre de archivo: MultiSpec27_Win.doc
Directorio:
C:\Mis documentos\TACO\MultiSpec
Plantilla:
C:\WINDOWS\Application
Data\Microsoft\Plantillas\Normal.dot
Título:
Tutorial MultiSpec 2.7 Windows
Asunto:
Autor:
José L. Escuer y Antonio Segovia
Palabras clave:
Comentarios:
Fecha de creación:
30/11/04 23:01
Cambio número:
14
Guardado el:
06/02/05 7:59
Guardado por:
pc
Tiempo de edición:
82 minutos
Impreso el:
06/02/05 7:59
Última impresión completa
Número de páginas: 23
Número de palabras: 4.834 (aprox.)
Número de caracteres: 24.174 (aprox.)

Documentos relacionados