unidad - eCasals

Comentarios

Transcripción

unidad - eCasals
14
UNIDAD
Dibujo en CAD,
modelaje de
sólidos
CONOCIMIENTOS TEÓRICOS
1 Configuración del modelizado
2 La ventana render
3 Utilización de materiales y texturas
4 Asignación de luces y determinación de sombras
4.1 Luz puntual
4.2 Luz distante
4.3 Foco de luz
5 Otros elementos paisajísticos y efectos realistas
5.1 Fondo
5.2 Niebla
APLICACIONES PRÁCTICAS
1 Realizar renders de instalaciones sencillas
CUESTIONES Y EJERCICIOS
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
Una representación fotorrealista, o render, es un procedimiento utilizado para dar una apariencia real a un objeto tridimensional construido
a partir de lo aprendido en la unidad 12.
Ahora es el momento de conocer las herramientas que nos permitirán
obtener una representación final. Entre otras, aprenderemos a asignar
materiales y texturas; a iluminar la escena provocando sombras y reflejos; a introducir imágenes de fondo para contextualizar la vista; a añadir
efectos atmosféricos como niebla; o a insertar elementos paisajísticos
como personas, coches, árboles... en un proceso que tiene como finalidad
enriquecer una escena tridimensional y aproximarla, tanto como podamos, a la realidad (Fig. 1).
Para el proceso de renderizado, existen otros programas más específicos
que AutoCAD, como, por ejemplo, 3D Studio MAX, aunque quizás estén
destinados a usuarios avanzados. Aun así, podremos intercambiar ficheros
entre los dos programas con las órdenes importar y exportar.
El orden en el proceso de diseño 3D y posterior renderizado es:
1 Diseño del objeto. Esta parte se estudió en la unidad 12.
2 Creación de la escena. En esta fase definimos el punto de vista
desde donde veremos el objeto y determinamos el tipo de proyección, ya sea cónica o paralela. Esta fase se trabajó en la unidad 13.
3 Asignación de materiales. Es la fase donde
definimos los materiales y las texturas de
los objetos.
4 Asignación de luces. Una vez definido el
punto de vista y los materiales asignados,
debemos introducir iluminación a la escena.
Dependiendo de nuestro objetivo, utilizaremos
alguno de los distintos tipos de luz existentes:
foco, luz puntual, luz distante o luz solar.
5 Insertar imágenes de fondo.
6 Insertar elementos paisajísticos.
7 Renderizado. Es el último paso del proceso y
el que nos muestra el resultado definitivo. En
él podemos escoger la calidad de la representación, la resolución de la imagen y el
formato de salida, entre otras opciones.
Representación fotorealista a vista de pájaro.
320
Dibujo en CAD, modelaje de sólidos
14
TEÓRICOS UNIDAD
CONOCIMIENTOS
UNIDAD
CONOCIMIENTOS
TEÓRICOS
1 CONFIGURACIÓN DEL MODELIZADO
Render de un coche.
Fig. 2
Para acceder al render, debemos ir a Ver →
Render. Se nos abre un menú desplegable
(Fig. 2), con las siguientes opciones:
• Render. Con esta opción realizamos el
renderizado directamente. Lo utilizaremos cuando tengamos todas las
demás opciones configuradas.
• Luz. Es donde creamos y modificamos
los distintos tipos de iluminación que
introduciremos en la escena, ya sea
una luz puntual, un foco o una luz
distante (Fig. 3).
Fig. 3
321
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
• Materiales. En este menú seleccionamos materiales de una biblioteca que ya tiene el mismo programa o que crearemos nosotros mismos
a partir de una combinación de color, brillo, transparencia y mapeado
sobre un determinado mapa de bits.
• Mapas. Definimos cómo se proyecta el mapa en el objeto. Tenemos
cuatro opciones posibles (Fig. 4):
Plana: El mapa se proyecta superficialmente.
Cuadrada: El mapa se proyecta en todas las caras, como si
envolviéramos una forma cúbica.
Cilíndrica: El mapa se ajusta como si se tratara de una etiqueta
que envuelve un envase cilíndrico.
Esférica: el mapa se envuelve en una esfera.
Fig. 4
• Entorno de modelizado. En este apartado tenemos la posibilidad de
introducir el efecto atmosférico de la niebla en la escena.
• Parámetros avanzados de modelizado. Se trata de la ventana principal en la realización de un render. En el menú de diálogo Parámetros
avanzados de modelizado de la figura 5 tenemos las opciones que
detallaremos a continuación.
Previamente, y según la calidad gráfica que queramos conseguir, escogeremos un tipo de modelizado: borrador, bajo, medio, alto o presentación. Debemos tener en cuenta que un modelizado en modo
presentación requiere más tiempo de cálculo que uno del tipo
borrador, mucho más sencillo y rápido, y que nos puede ser útil para
realizar una primera representación de la escena.
322
Dibujo en CAD, modelaje de sólidos
CONOCIMIENTOS TEÓRICOS
General
Contexto de modelización
- Procedimiento. Seleccionamos los elementos a renderizar
entre las opciones siguientes: vista, recortar y seleccionado. En escenas complejas que requieren un largo tiempo de
renderizado, si sólo queremos comprobar un objeto o parte,
podemos utilizar recortar para designar un fragmento de la
escena con una ventana, o seleccionado, para escoger objetos directamente del área gráfica.
- Destino. Escogemos la posibilidad de ver el render en la ventana gráfica de trabajo de AutoCAD o en una ventana
nueva, llamada Ventana Render y que explicamos más adelante.
- Tamaño de salida. Resolución de la representación final. A
mayor resolución, mayor tiempo de modelizado.
14
UNIDAD
Materiales. En este panel activamos o desactivamos los materiales
y texturas de los objetos a modelizar. Además, controlamos si queremos forzar dos lados, lo que significa que cuando está activado
el programa procesa todas las caras, incluidas las ocultas.
Mientras estamos elaborando la escena y realizando renders de
prueba, podemos desactivar alguna de estas opciones para agilizar el proceso.
Muestreo. El muestreo es una operación que evalúa el color de
cada píxel. Nos bastará con saber que a mayor diferencia entre máximo y mínimo, mejor calidad de renderizado.
Existen unos métodos predefinidos de filtrado:
Cuadrado. Equivale a la calidad borrador.
Triángulo. Equivale a la calidad bajo.
Gauss. Equivale a la calidad medio.
Mitchell. Equivale a la calidad alto.
Lanczos. Equivale a la calidad presentación.
Fig. 5
Debemos tener en cuenta el efecto antialiasing. Éste se utiliza para
evitar visualizar el efecto dentado en aristas y lados inclinados, como
podemos apreciar en el cono de la figura 6. El aliasing aparece únicamente en los renderizados de menor calidad: borrador y bajo.
Sombras. Seleccionamos el tipo de sombras en la escena y sus propiedades. Para obtenerlas es preciso haber creado alguna luz previamente. Podemos escoger entre sombras a partir de Mapas de sombras o de Trazado de rayos. En el primer caso, la sombra será más
difuminada.
Fig. 6
323
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
Trazado de rayos. La incidencia de los rayos de luz en los objetos
junto a las características de reflexión y refracción de los materiales
dan lugar a reflejos en la escena. Debemos definir el número de
reflexiones y refracciones que tendremos. Como siempre, a mayor
número, mayor tiempo de cálculo.
- Profundidad máxima. Número de veces que un rayo puede
reflejarse o refractarse.
- Reflexiones máximas / Refracciones máximas. Se utiliza
para definir el número de reflexiones y refracciones de manera
independiente.
Iluminación indirecta. Por iluminación indirecta entendemos el
efecto que, por ejemplo, produce un vaso rojo encima de una mesa
blanca. En la realidad, la mesa adquiere un color rojizo. Este efecto
es el que se controla mediante la iluminación global.
Final Gathering. Aumentamos el número de rayos trazados en el
tipo de iluminación global.
2 LA VENTANA RENDER
Como hemos visto en los parámetros avanzados de modelizado, en la
opción destino seleccionamos dónde vamos a realizar el render. Una
posibilidad es la ventana gráfica de AutoCAD, el entorno donde trabajamos normalmente. La otra opción es la denominada ventana (ventana
render). Cuando la designamos, el renderizado se realiza en una ventana
emergente.
Fig. 7
324
Dibujo en CAD, modelaje de sólidos
CONOCIMIENTOS TEÓRICOS
La principal ventaja de la ventana render respecto al renderizado en la ventana gráfica es que en la primera los diferentes modelizados que vamos
creando se almacenan en un historial de fácil acceso, en el que podremos
elegir el que más nos guste y, posteriormente, tener la posibilidad de guardarlo como un archivo de imagen (jpg u otro).
14
UNIDAD
Para familiarizarnos con las herramientas de configuración del modelizado, realizaremos un render a partir de objetos simples: cilindro, prisma y
pirámide de la figura 7.
En primer lugar, definimos el tipo de modelizado: alto.
En segundo lugar, en la opción procedimiento, seleccionamos: seleccionado.
En destino: ventana.
Tamaño de salida: 1024 x 768.
Desactivamos algunas opciones:
aplicar materiales: desactivada
filtrado de textura: desactivada
forzar dos lados: desactivada
En el apartado muestreo:
Tipo de filtro: Lanczos
Finalmente, activamos la opción iluminación global.
Concluida la edición de los parámetros, seleccionamos la orden render.
Como hemos escogido la opción seleccionado, debemos designar los
objetos que queremos modelizar. El resultado lo visualizaremos en la ventana render (Fig. 8).
Fig. 8
325
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
3 UTILIZACIÓN DE MATERIALES Y TEXTURAS
Los materiales utilizados en el proceso de modelizado no son más que
mapas de puntos que recubren una superficie y que controlan una serie
de características: color, brillo, transparencia, mapeado... Las herramientas
relacionadas con los materiales las encontramos en el menú Ver → render
→ materiales. En el editor de materiales de la figura 9 podemos elegirlos
desde una biblioteca o crearlos de nuevo de manera personalizada.
Editor de materiales
Al abrir el editor de materiales, encontramos una zona superior (Fig. 10),
con diferentes opciones. Las tres primeras, a la izquierda, hacen referencia
a la previsualización del material en el mismo menú:
Geometría de muestra. Elegimos el sólido para previsualizar el
material entre cubo, cilindro o esfera.
Calco subyacente a cuadros activado. Sirve para comprobar la
transparencia de los objetos.
Vista preliminar de modelo de iluminación de muestra.
Podemos escoger entre dos tipos de iluminación del material.
En la parte derecha encontramos otras opciones más importantes:
Fig. 9
Crear material nuevo. Debemos seleccionarlo cada vez que queramos crear un nuevo material.
Limpiar del dibujo. Eliminamos materiales que no estén asignados
a ningún objeto del dibujo.
Indicar materiales en uso. El programa nos informa de los materiales que se están utilizando.
Aplicar material a objetos. Sirve para enlazar materiales a objetos. Esto también se puede hacer directamente arrastrando el material hasta el objeto.
Eliminar materiales de objetos seleccionados. Para desenlazar
materiales de objetos.
Fig. 10
326
Dibujo en CAD, modelaje de sólidos
CONOCIMIENTOS TEÓRICOS
A continuación, pasamos a los paneles inferiores. En primer lugar,
tenemos una primera ventana llamada Global donde debemos
escoger entre cuatro tipos diferentes. Estos son:
Realista. Es el tipo predefinido por defecto.
Metal realista. Contiene los parámetros propios de materiales metálicos.
Avanzado. Variante del realista. En éste podemos controlar
perfectamente la definición del color, entre otras opciones.
Metal avanzado. Metal realista mejorado.
Las opciones realista y metal realista contienen a su vez
plantillas con patrones definidos (Fig. 11).
14
UNIDAD
Fig. 11
Color
Sabemos que el color de un objeto es el resultado de la luz que refleja, ya
sea procedente del sol o a partir de un foco o luz puntual.
En el render de AutoCAD, cada material está compuesto de tres colores:
– El color principal o difuso. Controla el color de la parte directamente iluminada del objeto.
– El color ambiente. Es el color que se muestra en las partes del objeto que sólo reciben luz ambiental.
– El color de reflexión o especular. Determina el color de los brillos
del objeto; a valores altos corresponden brillos muy concentrados.
Brillo
Define la manera de reflejar luz de un material y le da la característica de
áspero o brillante.
Opacidad
Aplicando un factor de transparencia (entre 0 y 1), podemos conseguir
efectos de refracción en materiales transparentes. 0 es opacidad total y 1,
transparencia total.
Índice de refracción
Permite controlar el factor de distorsión de los objetos visualizados a través de un objeto transparente.
Autoiluminación
Se aplica a objetos que sean emisores de luz, por ejemplo, en el caso de
una lámpara.
Luminancia
Con la luminancia podemos introducir un valor real de la luz reflejada por
el material.
327
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
Mapas
Los mapas se crearon para dar una apariencia más real a los objetos de
la que se puede conseguir con colores uniformes. Por ejemplo, una puerta de madera tiene, además de un color marrón general, unas partes más
oscuras, otras más claras, unas líneas de veteado..., es lo que denominamos textura de un material. Gracias a la utilización de los mapas, que son
imágenes del tipo tiff, gif, bmp o jpg, conseguiremos crear texturas en los
materiales. Éstas las podemos obtener directamente desde una biblioteca
de Autocad (Fig. 12), o también podemos importar imágenes desde una
cámara digital, escáner...
Fig. 12
Los tipos de mapas son:
Mapa difuso. Definimos el aspecto de la superficie del objeto
basándonos en una imagen de puntos. Por ejemplo, en la figura 13
esta imagen es una pared de ladrillo.
Mapa de reflejos. Permite crear la sensación de reflejo de un mapa
(por ejemplo, el cielo) en la fachada acristalada de un edificio.
Mapa de opacidad. Especificamos áreas de transparencia y opacidad; por ejemplo, en una chapa perforada.
Fig. 13
328
Mapa de relieve. Creamos un efecto de relieve basado en la intensidad de la iluminación de los puntos del mapa por medio de una
escala de grises, diferenciando zonas profundas (más oscuras) de
zonas que sobresalen (más brillantes).
Dibujo en CAD, modelaje de sólidos
CONOCIMIENTOS TEÓRICOS
14
UNIDAD
Los diferentes mapas pueden combinarse. Por ejemplo, si queremos obtener un pavimento de madera de piezas longitudinales muy pulido, aplicaremos un mapa de reflexión para reflejar los otros elementos, un mapa de
bits de madera y un mapa de relieve en forma de pieza de parquet.
Escala y mosaico de materiales
Este panel se utiliza para definir la escala y escoger el tipo de mosaico que
formará el material. Las opciones son:
Unidades de escala. Seleccionamos las unidades con las que definiremos el material.
Mosaico de U y V. Seleccionamos la disposición del mapa en las
dos direcciones. Podemos escoger una combinación entre ninguno,
mosaico o simetría.
Desfase y vista preliminar de material
Aquí podemos previsualizar el material y aplicarle cambios, por ejemplo, el
desfase y la rotación.
En la práctica siguiente queremos dibujar una pared de ladrillo de 10 metros
de largo, 30 cm de ancho y 3 metros de altura.
En primer lugar, dibujamos un rectángulo extruido con las dimensiones
anteriores.
Vamos al menú de materiales Ver → render → materiales. Se nos abre el
menú de diálogo.
Seleccionamos la opción Crear material nuevo. Lo llamamos «ladrillo».
Vamos a la opción mapas.
Mapa de textura. Seleccionamos la imagen. El programa tiene una biblioteca bastante completa con muchos mapas de bits simulando materiales.
Podemos escoger uno de esta lista o de otra creada por nosotros mismos.
Elegido el mapa, nos aparece el muro como en la figura 14.
Mapa de relieve. Vamos a la biblioteca de materiales, subcarpeta Bump,
donde encontramos el relieve asociado al mapa de textura,
Masonry.Unit Masonry.Brick.Modular.English Cross.bump, que es el que
nos dará la sensación de aspereza de la pieza (Fig. 15).
Para modificar el tamaño del mapa, accedemos a Escala y mosaico de
materiales, donde definimos la escala correcta, obteniendo la figura 16.
Ahora, para practicar con los mapas de opacidad, vamos a realizar una celosía metálica por delante del muro ya construido, que permitirá verlo a través.
Fig. 14, 15 y 16
329
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
En primer lugar, seleccionamos el mapa de textura tipo metal galvanizado de la figura 17. En segundo lugar, seleccionamos el mapa de opacidad, dentro de la subcarpeta cutout. En ella escogemos el mapa de la
figura 18. En un mapa de opacidad, las zonas blancas se texturizan y las
negras se convierten en agujeros.
Cuando tenemos el mapa, comprobamos su escala. Después seleccionamos el tipo de mapa Textura plana. Una vez modelizado, comprobamos las
transparencias y las sombras que la chapa arroja tanto en el muro anterior
como en un plano del suelo, que habremos añadido previamente a la
escena (Fig. 19).
Fig. 17
Fig. 18
Fig. 19
4 ASIGNACIÓN DE LUCES Y DETERMINACIÓN DE SOMBRAS
La iluminación, junto con la asignación de materiales, constituyen las
herramientas principales para la obtención de una correcta representación
«real» de una escena tridimensional.
AutoCAD permite trabajar con cuatro tipos de luces:
– Luz ambiente. Es una luz que se proyecta desde todos los
lados y sirve para mejorar la iluminación general de la escena. No
es conveniente que sea demasiado intensa ya que puede apagar
los efectos de sombras y volúmenes. La podemos modificar en el
menú Ver → render → parámetros avanzados de modelizado →
iluminación indirecta.
– Luz puntual. Es una fuente de luz que surge de un punto y se
proyecta en todas las direcciones, como si fuera una bombilla. El
icono, en el área gráfica, aparece representado por un círculo con
una cruz.
330
Dibujo en CAD, modelaje de sólidos
CONOCIMIENTOS TEÓRICOS
14
UNIDAD
– Foco. Es una luz direccional, que nace en un punto y se proyecta hasta otro de forma cónica. El icono en el área gráfica simula
un foco.
– Luz distante. Se proyecta en forma de rayos paralelos, similar a
la luz solar. Como no proviene de un punto concreto sino que viene
dada por una dirección de incidencia, no visualizamos nada en el
área gráfica.
Ubicación geográfica
Desde este menú (Fig. 20), podemos definir la posición geográfica exacta
donde se encuentra la escena. Con ello definimos la dirección del norte
respecto a los ejes XY del SCU.
Fig. 20
Propiedades del sol
Podemos modificar la intensidad, el color, la hora del día (Fig. 21). La
intensidad varía entre 0 (sin luz ambiente) y 1 (intensidad total). Es importante recordar que con mucha luz ambiente desaparecen los contrastes de color. Este concepto está relacionado con la ubicación geográfica.
4.1 Luz puntual
Para crear una luz puntual vamos a: Ver → render → luz → nueva luz puntual. En el cuadro de diálogo se nos muestra:
Comando: _pointlight
Fig. 21
331
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
Precise ubicación de origen <0,0,0>: Podemos seleccionar un punto de la
pantalla o escribir sus coordenadas en el cuadro de diálogo.
Indique una opción para modificar
[Nombre/Intensidad/Estado/Sombra/aTenuación/Color/sAlir]
<sAlir>: Podemos modificar estas opciones en el cuadro de diálogo o en
el menú Propiedades (Fig. 22). Las opciones principales son:
Fig. 22
Nombre: Bombilla
Intensidad: de 0 (apagada) a 1. El valor máximo está relacionado con
la atenuación.
Estado: Activada/desactivada. En el caso de preparar distintas escenas.
Sombra: Activada/desactivada.
Atenuación: Existen tres tipos:
- Ninguna. Los objetos cercanos y lejanos reciben la misma iluminación.
- Inversamente lineal. La intensidad de la luz disminuye linealmente con la distancia: a doble distancia, mitad de iluminación.
- Inversamente cuadrada. La luz disminuye en proporción inversa al
cuadrado de la distancia: a doble distancia, cuatro veces menos luz.
Color: Designamos el color de la luz que queremos crear. Normalmente
trabajaremos con un tipo de luz blanca para no modificar el color de los
objetos.
4.2 Luz distante
Lo primero que haremos es especificar el nombre y la intensidad. En el
caso de la luz distante, no existe atenuación con la distancia.
Comando: _distantlight
Precise DE DÓNDE procede la luz <0,0,0> o [Vector]: Designamos el primer punto del vector que nos define la dirección de los rayos paralelos.
Precise A DÓNDE se dirige la luz <1,1,1>: Especificamos el segundo punto
del vector.
Indique una opción para modificar [Nombre/Intensidad/Estado/Sombra/
Color/sAlir]<sAlir>: Modificamos estas opciones o lo dejamos para hacerlo posteriormente en el menú Propiedades (Fig. 23).
4.3 Foco de luz
Además de las opciones comunes a los anteriores tipos de iluminación,
encontramos:
Fig. 23
332
Haz de luz: Determina el ángulo del cono de luz, entre 0 y 160 grados.
Dibujo en CAD, modelaje de sólidos
CONOCIMIENTOS TEÓRICOS
Difuminación: Se trata del ángulo a partir del que la intensidad disminuye rápidamente. A mayor ángulo de difuminación, mayor definición de la luz.
14
UNIDAD
Como ejemplo para comprobar las diferencias entre los tipos de luz,
hemos iluminado la silla Red&Blue de G. Rietveld, a partir de una luz
distante (Fig. 24), una luz puntual (Fig. 25), y un foco (Fig. 26).
Fig. 24, 25 y 26
333
UNIDAD 14 CONOCIMIENTOS TEÓRICOS
Dibujo en CAD, modelaje de sólidos
5 OTROS ELEMENTOS PAISAJÍSTICOS Y EFECTOS REALISTAS
5.1 Fondo
Para insertar un fondo a nuestra escena, ya sea un color, un gradiente de
colores o una imagen, accedemos a Ver → vistas guardadas. Se nos abre
un menú de diálogo (Fig. 27). Seleccionamos Vista modelo → nueva... En
la siguiente ventana (Fig. 28), seleccionamos la opción de fondo que nos
interese. En el caso de ser una imagen como la de la figura 29, debemos
enlazarla. Podemos escalar la imagen, estirarla o introducirla en forma de
mosaico. Debemos tener en cuenta que las imágenes de fondo sólo se
muestran en los renders realizados en la ventana render.
Fig. 27
Fig. 28
334
Fig. 29
Dibujo en CAD, modelaje de sólidos
CONOCIMIENTOS TEÓRICOS
5.2 Niebla
14
UNIDAD
Podemos introducir efectos de niebla para dar mayor realismo a la escena.
Para ello accedemos a Ver → Render → Entorno de modelizado. Nos aparece el menú desplegable de la figura 30. En él podemos configurar:
Fig. 30
Color. Asignamos el color de la niebla.
Fondo niebla. Si queremos que la niebla afecte la imagen de fondo.
Distancia cercana / lejana. Especificamos la distancia desde la cámara a partir de la que empieza/acaba la niebla.
Porcentaje de niebla cercana / lejana. Con estas dos opciones,
introducimos un valor que será la densidad de niebla en la distancia
cercana o lejana.
Ejemplos de renderizado de formas
complejas.
335
UNIDAD
14
APLICACIONES PRÁCTICAS
Dibujo en CAD, modelaje de sólidos
1 REALIZAR RENDERS DE INSTALACIONES SENCILLAS
Como aplicación práctica de la unidad, vamos a realizar un sencillo renderizado de un proyecto del arquitecto Mies van der
Rohe, «la casa con tres patios», caracterizada por el uso de grandes superficies acristaladas, espacios diáfanos y el contacto directo con los patios que envuelven el espacio interior.
Es un tipo de arquitectura muy similar al Pabellón de Barcelona que
este arquitecto realizó para la Exposición Universal de Barcelona de
1929 (Fig 31).
Fig. 31
Una vez abierto el modelo, nos encontramos las siguientes capas:
Jardín
Muro exterior
Muros interiores
Pavimento
Pilares
Techo
Vidrio
Luces
En primer lugar, vamos a crear los diferentes materiales de la escena y a
enlazarlos a los objetos. El enlace lo podemos realizar seleccionando
materiales y después objetos, o enlazando directamente objetos a
capas. Esto último sólo es posible si, en el momento de crear el modelo,
ya tenemos presentes los materiales.
Las características a definir de los materiales de nuestra escena serán:
- Capa jardín / material césped
Editor de materiales
Tipo: avanzado
Mapas: césped
Mapa difuso: sitework.planting.grass.thick.jpg (Fig. 32)
Mapa de relieve:
sitewok.planting.grass.bluegrass. bump1.jpg (Fig. 33)
Fig. 32 y 33
336
Escala y mosaico de materiales
Unidades de escala: metros
Anchura: mosaico 1.0000
Altura: mosaico 1.0000
Dibujo en CAD, modelaje de sólidos
APLICACIONES PRÁCTICAS
- Capa muro exterior / material ladrillo
14
UNIDAD
Editor de materiales
Tipo: realista
Plantilla: albañilería
Mapas: ladrillo
Mapa difuso:
Masonry.Unit Masonry.Brick.Norman.One-Third Running
(Fig. 34).
Mapa de relieve:
Masonry.Unit Masonry.Brick.Modular. Running.Brown.bump,
(Fig. 35).
Escala y mosaico de materiales
Unidades de escala: metros
Anchura: mosaico 1.0000
Altura: mosaico 1.0000
- Capa pavimento / material travertino
Editor de materiales
Tipo: realista
Plantilla: piedra pulida
Brillo: 50
Mapas: travertino
Mapa difuso: Masonry.Stone.Travertine.Cream (Fig. 36).
Mapa de relieve:
Finishes.Flooring.Tile.Square.Grey. Dark.bump (Fig. 37).
Escala y mosaico de materiales
Unidades de escala: metros
Anchura: mosaico 1.0000
Altura: mosaico 0.5000
- Capa pilares / material acero inoxidable
Editor de materiales
Tipo: metal avanzado
Brillo: 100
Reflexión: 50
Mapas: acero inoxidable
Mapa difuso:
Metals.Ornamental Metals.Stainless.Bright (Fig. 38).
Mapa de reflejos:
Metals.Ornamental Metals.Aluminium. Brushed
Fig. 34, 35, 36, 37 y 38
337
UNIDAD
14
APLICACIONES PRÁCTICAS
Dibujo en CAD, modelaje de sólidos
- Capa techo / material hormigón pintado
Editor de materiales
Tipo: realista
Plantilla: pintura mate
Color: Seleccionamos el color real número 235, 235, 235
- Capa vidrio / material vidrio
Editor de materiales
Tipo: avanzado
Color difuso: Seleccionamos el color real 224, 240, 251
Brillo: 100
Opacidad: 0
Reflexión: 20
Índice de refracción: 1.5
Translucidez: 2
- Capa muros interiores
En esta capa tenemos dos materiales, que enlazaremos directamente a los
objetos. Unos muros serán de piedra serpentina y los otros, de madera.
Serpentina
Editor de materiales
Tipo: realista
Plantilla: piedra pulida
Brillo: 30
Fig. 39
Mapas: serpentina
Mapa difuso:
Masonry.Stone.Marble.Square.Stacked. Polished.
White – Green (Fig. 39).
Escala y mosaico de materiales
Unidades de escala: metros
Anchura: mosaico 5.0000
Altura: mosaico 5.0000
Madera
Editor de materiales
Tipo: realista
Plantilla: madera barnizada
Fig. 40
338
Mapas: madera
Mapa difuso:
Woods - Plastics.Finish Car-pentry.Wood.White Ash
(Fig. 40).
Dibujo en CAD, modelaje de sólidos
APLICACIONES PRÁCTICAS
UNIDAD
Escala y mosaico de materiales
Unidades de escala: metros
Anchura: mosaico 1.0000
Altura: mosaico 1.0000
14
Fig. 41
Una vez creados los objetos, vamos a enlazarlos a las distintas capas. Para
ello teclearemos enlazarmat en el cuadro de diálogo. Nos aparece un
menú (Fig. 41). A la izquierda tenemos los materiales creados y a la derecha, las capas del dibujo. Sólo debemos arrastrar el material a la capa que
queramos.
Cuando tenemos los materiales, iluminamos la escena. Para practicar
con los distintos tipos de luz, vamos a realizar vistas de día y de noche.
Para la vista de día utilizaremos una luz distante; para las nocturnas,
crearemos luces puntuales y focos.
En primer lugar, para crear una luz distante, vamos a Ver → render → luz →
nueva luz distante
Comando: _distantlight
Precise DE DÓNDE procede la luz <0,0,0> o [Vector]: Para definir la dirección, por ejemplo, escogemos el punto 1,1,1.
Precise A DÓNDE se dirige la luz <1,1,1>: Ahora designamos el punto 0,0,0.
Indique una opción para modificar [Nombre/Intensidad/Estado/Sombra/
Color/sAlir]: para modificar estas opciones, es recomendable utilizar el
menú Propiedades (Fig. 42).
Fig. 42
339
UNIDAD
14
APLICACIONES PRÁCTICAS
Dibujo en CAD, modelaje de sólidos
Para crear luces puntuales y focos, necesitamos designar un punto en el espacio. En nuestro modelo previamente hemos situado unos puntos en el pasillo de
entrada, a nivel de techo, que corresponderán a luces
puntuales, y otros en el patio de acceso, a nivel de
suelo y tipo foco, para iluminar el pavimento de acceso al interior. Estos puntos están situados en la capa
luces.
Debemos tener en cuenta que hay que activar o desactivar las distintas luces en función de la escena a realizar. Por ejemplo, en la escena nocturna desactivaremos
la luz distante.
Para crear una luz puntual vamos a Ver → render → luz → nueva luz puntual y designamos el punto en el espacio. Las opciones las modificamos en
el menú Propiedades al seleccionar la luz en cuestión. Los parámetros que
definimos son:
General
Factor de intensidad: 0.5
Atenuación
Tipo: Inversamente lineal
Para crear un foco vamos a Ver → render → luz → nueva luz (foco).
Comando: _spotlight
Precise ubicación de origen <0,0,0>: Designamos el punto donde
se situará el foco.
Precise ubicación de mira <0,0,-10>: Seleccionamos el punto de mira.
Escribimos sus coordenadas o designamos un punto en pantalla directamente. Un consejo al designar puntos en el espacio es tener activadas más de
una ventana para dirigir bien el rayo. En nuestro caso, el punto de mira será
un punto del muro exterior; por tanto, el foco estará inclinado hacia arriba.
Indique una opción para modificar [Nombre/Intensidad/Estado/Haz luz/
Difuminación/Sombra/ aTenuación/Color/sAlir] <sAlir>: Parámetros que definiremos posteriormente desde el menú Propiedades:
General
Ángulo de haz de luz: 50
Ángulo de difuminación: 70
Factor de intensidad: 2
Atenuación
Tipo: Inversamente lineal
340
Dibujo en CAD, modelaje de sólidos
APLICACIONES PRÁCTICAS
Tenemos los materiales y las luces, ahora es el momento de crear las cámaras para definir las escenas; con ello podremos introducir imágenes de
fondo que nos ayuden a completar la vista.
UNIDAD
14
Crearemos cámaras en el patio exterior de entrada y en el interior de la
casa. Para ello es preferible, como antes, ver más de una vista a la vez para
poder definir su situación. Para simular la realidad, la altura de visión será
de 1,7 metros.
Para definir la escena, debemos seleccionar como vista actual la de la
cámara que queramos y entrar en el menú ver → vistas guardadas. Vamos
a la opción Vistas de presentación y seleccionamos nueva.
En el siguiente menú, nombramos la vista y seleccionamos una imagen de
fondo que escalamos y desfasamos para encuadrarla en la escena. Antes
de salir del menú vistas guardadas, debemos definir la vista como vista
actual.
Finalmente, y después de realizar modelizados de prueba en calidad borrador, y a fin de obtener la imagen definitiva, realizaremos un renderizado
tipo presentación, de alta resolución, con las sombras activadas y los demás
parámetros en alta calidad (Fig. 43 y 44).
Fig. 43
Fig. 44
341
UNIDAD
14 CUESTIONES Y EJERCICIOS
Dibujo en CAD, modelaje de sólidos
1. Recuperando prácticas de unidades
anteriores, como los sólidos de la unidad
12, aplicarles diferentes materiales y
después iluminarlos para crear
representaciones reales de las figuras.
2. A partir del dibujo de la «casa con tres
patios» de Mies van der Rohe, construir
dos escenas, una interior y otra exterior,
esta última desde uno de los patios
traseros y mirando hacia el otro.
- Introducir las luces que consideres
oportunas, tanto en el interior como
en el exterior, para definir una vista
de día y otra de noche.
- Aplicar materiales diferentes a los
utilizados en Aplicaciones prácticas
de la unidad para poder ver otros
efectos. Por ejemplo, puedes utilizar
un vidrio con cierto grado de
translucidez, un pavimento
de madera con un despiece de
parquet, cambiar el césped por
una lámina de agua que refleje la
fachada… El dibujo en AutoCAD lo
encontrarás en el CD.
puedes hacer fotos y luego insertarlas
como imágenes .jpg.
4. A partir de las vistas diédricas de los dos
diseños de G. Rietveld, figuras 45 y 46,
construye el sólido tridimensional. Luego
aplica materiales y texturas diferentes.
Fig. 45
3. Realizar una representación
tridimensional de un fragmento de
tu casa. Construir en primer lugar el
modelo, luego aplicar materiales
y luces. Para los mapas de texturas
Fig. 46
Contenidos básicos de la unidad en formato hipermedia, en el CD.
Más actividades en el CD
El arte no reproduce lo visible. Lo hace visible.
PAUL KLEE
342
Términos utilizados
343
Abatimiento
Se dice de la acción de Girar un plano respecto a su intersección con otro,
hasta hacerlo coincidir con él
Adyacentes
Ángulos con un lado en común
Afinidad
Transformación geométrica de una forma en otra, en la que varían las formas
y sus ángulos
Binocular
Referido a la visión, implica la intervención simultánea de ambos ojos
Charnela
Es el nombre que se da al eje o recta de giro respecto a la cual realizamos
un abatimiento
Cono de
revolución
Es aquel en el que cualquiera de las posiciones de la generatriz forma
siempre un ángulo invariable con el eje del mismo; en el cono recto, lo
anterior sólo se cumple si la directriz es una circunferencia
Contorno
aparente
Conjunto de líneas que limitan la representación de un objeto en una
determinada proyección
Contraescala
Parte de una escala gráfica que sirve para medir fracciones de la unidad
principal
Diámetro
conjugado
Respecto a otro diámetro de una elipse; pasa por el punto medio
del que es conjugado, siendo paralelo a las tangentes trazadas a
la cónica por los extremos de éste
Elemento
doble
Elemento que, en una transformación, se transforma en sí mismo.
Puede ser un punto, una recta, etc.
Equiángulo
Polígono con los ángulos iguales
Exinscrita
Circunferencia tangente a las prolongaciones de los lados de un triángulo
Extrusionar
En los programas de CAD, orden que proyecta una polilínea o región en una
dirección determinada
Flanco
Nombre que se da al perfil lateral de los dientes en una rosca, engranaje, etc.
Homólogos
Par de elementos relacionados en una transformación geométrica
Homónimas
Del mismo nombre; por ejemplo, dos proyecciones, ambas verticales
Huella
Parte plana de una escalera
Impropio
Referido a punto, recta o plano, hace referencia a estos elementos no
situados en nuestro espacio afín sino en el infinito
Invariante
Propiedad geométrica, o conjunto de las mismas, que no varía al realizar una
transformación o una proyección
344
Lugar geométrico
Conjunto de puntos con una misma propiedad geométrica
Mapa
En el renderizado de un programa de CAD, el mapa es una archivo tipo
JPG, ligado a la asignación de materiales, que permite dar mayor
aspecto de realidad a la superficie a la que se aplica
Media proporcional
Segmento o magnitud que forma una proporción con otras dos
magnitudes dadas
Partición áurea
Parte de un segmento que, respecto a la longitud total del mismo,
guarda la relación áurea
Pinzamiento
En un programa de CAD, son los puntos que aparecen en torno a
un objeto al seleccionarlo; mediante estos puntos, podemos efectuar
determinadas modificaciones del objeto, que denominamos como
efectuadas por pinzamientos
Pivotar
Pequeños movimientos a izquierda y derecha de una cámara fotográfica
Poliedro convexo
Es aquel en el que se verifica que cualquier par de puntos ubicados
en su interior determinan un segmento de recta también interior
al poliedro
Posición favorable
Posición relativa de recta o plano respecto al plano de proyección y
de la cual se derivan, de forma directa, propiedades métricas
o simplificaciones en el proceso de resolución de problemas
Potencia
La potencia de un punto P respecto a una circunferencia es el
producto de las distancias desde ese punto a cualquier par de puntos
de la circunferencia alineados con el punto P
Radio vector
En una elipse, cada uno de los segmentos que unen uno cualquiera de
sus puntos con los focos
Recta de centros
Es la recta sobre la que se hallan los centros de dos circunferencias tan
gentes, o de las circunferencias tangentes respecto a una recta
Rectas antiparalelas
Dos rectas trazadas entre los lados de un ángulo, la primera forma,
con uno de los lados, un ángulo igual al que forma la segunda con
el otro lado
Rectificación
Acción de encontrar un segmento con la misma longitud que un arco
o curva dada
Renderizado
En un programa de CAD, dotar a un modelo 3D de materiales,
texturas, luces, etc., para conseguir un aspecto lo más realista posible
SCP
En los programas de CAD, es el acrónimo utilizado para referirse
al Sistema de Coordenadas Personales
345
Semidistancia
Mitad de una distancia determinada; el prefijo semi corresponde a mitad
Semieje
Mitad de la longitud correspondiente a un eje
Software
Hace referencia al equipamiento lógico (programas) de un equipo
informático
Superficie
alabeada
Es una superficie reglada no desarrollable, es decir, en ella dos
posiciones sucesivas de la generatriz no son coplanarias
Superficie
radial
Es la superficie generada por el movimiento de una directriz alrededor de
un eje, con el que se corta en un vértice propio o impropio
Superficie
reglada
Es la generada por una recta, denominada generatriz, al desplazarse sobre
a o varias líneas, denominadas directrices
Terna
Nombre que, en perspectiva axonométrica, se da a las proyecciones de
los ejes sobre el plano del cuadro o del dibujo
Transformación
proyectiva
Transformación de un elemento en otro a través de una proyección
Transformada
de la sección
Línea que en el desarrollo de una superficie corresponde
a los puntos de la sección producida por un plano determinado
Traza
Referido a un plano o recta, es su intersección con uno de los planos
de proyección
Trirrectángulo
Ángulo triedro formado por tres planos que se cortan perpendicularmente
Verdadera
magnitud
Valor en proyecciones de una determinada magnitud que coincide con su
valor real antes de efectuar la proyección
346
Bibliografía
González Monsalve, M. y Palencia Cortes, J.: Trazado Geométrico; Dibujo Técnico I. Edición de
los autores; Sevilla 1986.
Recoge numerosas construcciones, razonadas, de geometría plana; desde el nivel más elemental hasta otras que superan ampliamente el nivel de este curso.
González Monsalve, M. y Palencia Cortes, J.: Normalización Industrial; Dibujo Técnico III. Edición
de los autores; Sevilla 1986.
Compendio de las principales normas que se deben aplicar en el campo del Dibujo técnico
y de la representación técnica en general.
Corbella Barrios, D.: Trazados de dibujo geométrico. Edición del autor. Madrid, 1970.
Reúne las construcciones geométricas más usuales, señalando aplicaciones prácticas en
algunas de ellas.
Codina Muñoz, X. y García Almirall, I.: Geometría plana para dibujo técnico. Ediciones Media.
Barcelona 1995.
Curso básico de geometría plana, basado en tres grandes apartados: tangencias, polígonos
y curvas cónicas.
Castelnuovo, E.: La matemática. La geometría. Kestres Editora. Barcelona 1981.
A medio camino entre las matemáticas y el dibujo técnico, amplía conceptos al tiempo que
nos puede introducir por nuevas vías de conocimiento.
Weyl, H.: Simetría. McGraw-Hill editores. Madrid 1990.
Resumen de las aplicaciones del principio de simetría en física, química, biología, así como
su papel en el arte.
Sánchez Gallego, J. A.: Geometría descriptiva. Sistemas de proyección cilíndrica. Alfaomega. 1999.
Sistemas basados en la proyección cilíndrica (diédrico, axonométrico y acotado), su interrelación y sus características.
SISTEMA DIÉDRICO
Sánchez Gallego, J. A.: Geometría descriptiva. Sistemas de proyección cilíndrica. Barcelona, Edicions
UPC 1997.
Sánchez Gallego, J. A.; Villanueva Bartrina, Lluís: Dibuix tècnic. Barcelona, Edicions UPC 1991.
PERSPECTIVA CÓNICA
Villanueva Bartrina, Lluís: Perspectiva lineal, su relación con la fotografía. Barcelona, Edicions UPC
1996.
347
Editorial Casals, fundada en 1870
Libro adaptado a los contenidos que prescribe el Real Decreto 1467/2007, de 2 de noviembre,
por el que se establece la estructura del Bachillerato y se fijan sus enseñanzas mínimas.
Las actividades de este libro se proponen
como modelos de ejercicios que cada alumno/a
debe resolver en su libreta o cuaderno.
En ningún caso debe realizarlas en el propio libro.
Coordinación editorial: F. Infante
Revisión lingüística: María del Mar Ramos
Diseño de cubierta: Eumogràfic
Diseño interior y maquetación: E. Martínez y M. Alier
Ilustración: R. Gasull
Fotografía: ACI, Aisa, Primsa, R. Gasull y B. Mas
Las reproducciones se han realizado según el artículo 32 de la Ley de Propiedad Intelectual.
© Del libro y del CD, B. Mas y R. Gasull
© Editorial Casals, S. A.
Caspe 79, 08013 Barcelona
Tel.: 93 244 95 50 Fax: 93 265 68 95 http://www.editorialcasals.com http://www.ecasals.net
Primera edición: abril de 2009
ISBN: 978-84-218-4033-7
Depósito legal: : B-16.768-2009
Printed in Spain
Impreso en Índice, S. L., Fluvià 81, 08019 Barcelona
No está permitida la reproducción total ni parcial de este libro, ni su tratamiento informático,
ni la transmisión bajo ningún concepto ni por ningún medio (electrónico, mecánico, fotocopia,
grabación u otros métodos) sin el permiso escrito de los titulares del copyright.

Documentos relacionados